This weekend our forum will be unavailable for a few hours due to maintenance.

  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 47
  •   
Win HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR
(2015-10-23, 15:28)HTPC-ASR Wrote: Hi to all,

i need to discuss about settings for MadVr, not too technical aspect cause i'm not a specialist.

My pc is below:

TV Panasonic 55Dt50 (it 1080p/24p supports)
CPU Intel i7 4770
GPU MSI nvidia gtx960 Gaming
RAM 16GB DDR3 1800Mhz
MOBO Asus z87

and so on...

I would like to know what setting about scaling algorithm...
AS-IS situation

Profile: "1080p"
Chroma: super-xbr150 + AR
Image: Jinc3 + AR
Image Doubling: Off
Upscaling Refinement: Off
Artifact Removal - Debanding: Medium/High
Image Enhancements: FineSharp (strength: 0.5)
Dithering: Error Diffusion 2

Profile: "720p and SD"
Chroma: super-xbr150 + AR
Image: Jinc3 + AR
Image Doubling: Off
Upscaling Refinement: SuperRes (strength: 1)
Artifact Removal - Debanding: Medium/High
Image Enhancements: Off
Dithering: Ordered


In this situation, the video seems to be a little "jerky"...not so much....but i'd like to know if there some wrong setting...

My first need is related to configure correctly madvr, considering my htpc! Smile Thank you!!

Are you using display refresh rate matching? This can influence how smooth the video appears.

You need to use the information below as a guide to the whether there is something wrong with your madVR settings:

How Do I Measure the Performance of My Chosen Settings?

Once the settings have been configured to your liking, it is important madVR's settings match the capabilities of your hardware. To determine this, the menu below can be overlaid during playback by pressing Cntrl + J to provide feedback on your PC’s rendering performance. Combining several settings labelled Medium or higher will create a large load on the graphics card.

Rendering performance is dependent upon the average rendering and present time of each frame in relation to the movie frame interval. In the example below, a new frame is drawn every 41.71ms. However, at an average rendering time of 49.29ms plus a present time of 0.61ms (49.29 + 0.61 = 49.90ms), the computer is unable to keep up with the framerate of the video. The result is dropped frames, presentation glitches and generally choppy playback. As such, settings in madVR will have to be dialed-down. Predicting the load placed on the graphics processor is factor of the resolution of the video and the display, as well as the framerate and bit depth of the video. A video with a native framerate of 30 frames/s will require madVR to work 25% harder than a video with a framerate of 23.976 frames/s. It is advised to find a demanding source (SD or 720P) to test your settings, ensuring some headroom is left under the movie frame interval.

Display Rendering Stats:
Cntrl + J during full screen playback:
Image
Reply
Image

Smile

what do you think?
Reply
(2015-10-22, 08:10)Warner306 Wrote: I don't have any ISO files, but I do know DSPlayer does not support Blu-ray ISO and has limited support for DVD ISO. This would explain why madVR doesn't appear to be working; the file is likely being loaded by DVDPlayer. Press O during playback to confirm.

I didn't know that, shame. Thanks anyway
Reply
(2015-10-23, 21:18)HTPC-ASR Wrote: Image

Smile

what do you think?

Your rendering time is well below the frame interval, so your madVR settings should be fine. The composition rate says 60hz, however. I'm not sure if this is normal. The composition rate and display rate should both be 23.976Hz or close to this value. I don't think anything is wrong given the rendering stats, but this seems unusual.

Are you using display refresh rate switching with madVR or Kodi?
Reply
Maybe i don't understand your question. I'm using kodi, but in this case i play mpc-hc directly from pc without using kodi interface.

If i push "info" on tv i see 1080p/24hz so this let me know the resolution it's ok.

Now i installed ReClock and i configured it as http://www.ezoden.com/htpc/38/reclock

rendering go down (10ms) but dropped frames go up (49)!

movie frame rate interval remained the same.

It's ok?
Reply
(2015-10-24, 02:20)HTPC-ASR Wrote: Maybe i don't understand your question. I'm using kodi, but in this case i play mpc-hc directly from pc without using kodi interface.

If i push "info" on tv i see 1080p/24hz so this let me know the resolution it's ok.

Now i installed ReClock and i configured it as http://www.ezoden.com/htpc/38/reclock

rendering go down (10ms) but dropped frames go up (49)!

movie frame rate interval remained the same.

It's ok?

Everything sounds like it is ok. 24Hz playback will never be perfectly smooth. But something could be wrong with ReClock. I wouldn't use it if playback is suffering.
Reply
(2015-10-24, 05:44)Warner306 Wrote:
(2015-10-24, 02:20)HTPC-ASR Wrote: Maybe i don't understand your question. I'm using kodi, but in this case i play mpc-hc directly from pc without using kodi interface.

If i push "info" on tv i see 1080p/24hz so this let me know the resolution it's ok.

Now i installed ReClock and i configured it as http://www.ezoden.com/htpc/38/reclock

rendering go down (10ms) but dropped frames go up (49)!

movie frame rate interval remained the same.

It's ok?

Everything sounds like it is ok. 24Hz playback will never be perfectly smooth. But something could be wrong with ReClock. I wouldn't use it if playback is suffering.

mmhh... Smile

this http://forum.doom9.org/showthread.php?t=162675 probably is the reason of reclock problem...i unistalled it and all goes fine!

Overall, if you tell me those "numbers" tell us: "All it's ok!" ...I am calm.
Reply
a composition mismatch is not ok this can create all kinds of problems.
use FSE, overlay or use a windows that's not windows 7 or older. the aero desktop composition is pretty much broken under windows 7 and older.
Reply
(2015-10-27, 03:10)huhn Wrote: a composition mismatch is not ok this can create all kinds of problems.
use FSE, overlay or use a windows that's not windows 7 or older. the aero desktop composition is pretty much broken under windows 7 and older.

What would cause this mismatch? I don't understand the concept.
Reply
a bug in windows aero.

this can happen when you switch from 60p to 23p. and you only have one desktop composition so if you use a TV at 23p and a monitor at 60p you get a composition rate of either 23p or 60p for both screens. only FSE and overlay mode don't need the desktop composition so they will work any way.

under windows 8+ a mismatch after changing the refreshrate shouldn't happen what so ever.
Reply
(2015-10-27, 10:38)huhn Wrote: . only FSE and overlay mode don't need the desktop composition so they will work any way.

under windows 8+ a mismatch after changing the refreshrate shouldn't happen what so ever.

Huh?
Reply
(2015-10-27, 21:18)HTPC-ASR Wrote:
(2015-10-27, 10:38)huhn Wrote: . only FSE and overlay mode don't need the desktop composition so they will work any way.

under windows 8+ a mismatch after changing the refreshrate shouldn't happen what so ever.

Huh?

Are you using fulscreen exclusive mode?
Reply
Not always, it's important?!
Reply
(2015-10-27, 22:52)HTPC-ASR Wrote: Not always, it's important?!

This should correct the issue where the display rate and composition rate are different. Or you could use windowed mode with windows overlay enabled.

Both of these settings are found in the madVR control panel.
Reply
(2015-10-27, 23:21)Warner306 Wrote:
(2015-10-27, 22:52)HTPC-ASR Wrote: Not always, it's important?!

This should correct the issue where the display rate and composition rate are different. Or you could use windowed mode with windows overlay enabled.

Both of these settings are found in the madVR control panel.

Now i put thi setting...

Image

Image

it's correct?
Reply
  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 47
  •   



Logout Mark Read Team Forum Stats Members Help
HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR7
This forum uses Lukasz Tkacz MyBB addons.