•   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 70
  •   
[RELEASE] Flix2Kodi - Just another Netflix-Addon
(2016-01-06, 21:30)sh33p Wrote: which repo got the 6.0.4 chromium? im running OE 6 as well but got only 6.0.1

I got it from: https://www.dropbox.com/sh/7rwud8jv5xu85...omium?dl=0 (7.0.x doesnt work on Openelec 6.x).

And this location i got from the following thread: http://openelec.tv/forum/128-addons/7759...mitstart=0
Reply
Updated to 0.46 and the plugin crashes. When i go to movies or tv shows i'm getting a spining circle.. when i press back i'm getting an error saying i should check the logs. Maybe it is a good idea to add the log location to your FAQ Smile
Reply
Allright, first error:

Code:
21:43:23 T:140657049970432  NOTICE: [plugin.video.flix2kodi] Loading netflix: https://www.netflix.com/ Post: None
21:43:23 T:140657049970432  NOTICE: [plugin.video.flix2kodi] None
21:43:23 T:140657049970432   ERROR: /storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
                                              SNIMissingWarning

Uhh okay.. this is the moment the little circle starts spinning, after backing out, i get the message asking if i want to refresh my login, when i hit yes i get the following:

Code:
21:43:55 T:140659544192896   ERROR: GetDirectory - Error getting plugin://plugin.video.flix2kodi/?mode=main&thumb&type=tv&url
21:43:55 T:140659544192896   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.flix2kodi/?mode=main&thumb&type=tv&url) failed
21:43:55 T:140659004520192  NOTICE: Thread JobWorker start, auto delete: true
21:43:55 T:140658610259712  NOTICE: Thread LanguageInvoker start, auto delete: false
21:43:55 T:140658610259712  NOTICE: -->Python Interpreter Initialized<--
21:43:55 T:140657360369408  NOTICE: Thread BackgroundLoader start, auto delete: false
21:44:01 T:140657737844480   ERROR: CPythonInvoker(13, /storage/.kodi/addons/plugin.video.flix2kodi/addon.py): script didn't stop in 5 seconds - let's kill it
21:44:01 T:140659004520192   ERROR: GetDirectory - Error getting
21:44:01 T:140658610259712  NOTICE: Thread LanguageInvoker start, auto delete: false
21:44:01 T:140657360369408  NOTICE: Thread JobWorker start, auto delete: true
21:44:01 T:140658610259712  NOTICE: -->Python Interpreter Initialized<--
21:44:02 T:140657049970432  NOTICE: [plugin.video.flix2kodi] parameters: ?mode=main&thumb&type=tv&url
21:44:02 T:140657049970432   ERROR: [plugin.video.flix2kodi] Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 83, in <module>
                                                handle_request()
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 35, in handle_request
                                                general.main(video_type)
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/general.py", line 38, in main
                                                add_dynamic_lists(video_type)
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/general.py", line 28, in add_dynamic_lists
                                                content = connect.load_netflix_site("https://www.netflix.com/")
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/connect.py", line 111, in load_netflix_site
                                                ret, status_code = load_site_internal(url, session, post, netflix=True)
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/connect.py", line 168, in load_site_internal
                                                response = session.get(url, headers=headers, cookies=cookies, verify=certifi.where())
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 480, in get
                                                return self.request('GET', url, **kwargs)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 468, in request
                                                resp = self.send(prep, **send_kwargs)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 597, in send
                                                history = [resp for resp in gen] if allow_redirects else []
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 195, in resolve_redirects
                                                **adapter_kwargs
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/sessions.py", line 576, in send
                                                r = adapter.send(request, **kwargs)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/adapters.py", line 376, in send
                                                timeout=timeout
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py", line 559, in urlopen
                                                body=body, headers=headers)
                                              File "/storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py", line 376, in _make_request
                                                httplib_response = conn.getresponse(buffering=True)
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.0/Python-2.7.3/.install_pkg/usr/lib/python2.7/httplib.py", line 1030, in getresponse
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.0/Python-2.7.3/.install_pkg/usr/lib/python2.7/httplib.py", line 439, in begin
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.0/Python-2.7.3/.install_pkg/usr/lib/python2.7/mimetools.py", line 25, in __init__
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.0/Python-2.7.3/.install_pkg/usr/lib/python2.7/rfc822.py", line 108, in __init__
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.0/Python-2.7.3/.install_pkg/usr/lib/python2.7/httplib.py", line 280, in readheaders
                                            SystemExit
21:44:11 T:140657049970432   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.NameError'>
                                            Error Contents: name 'login' is not defined
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 90, in <module>
                                                if login.login()==True:
                                            NameError: name 'login' is not defined
                                            -->End of Python script error report<--

Username is filled, haven't chagned that. Regarding the first error about the certificate, i've tried all SSL settings in the plugin, but it doesn't matter, i keep getting the same error.
Reply
I have the same problem with version 0.46, uninstalled, re-installed. Spinning circle and crash.
Reply
@mhoogenbosch & cwh060,
When I updated to 0.46, I received an update failed, uninstalled, attempted to reinstall, same problem. Restarted PC, reinstall worked.
On trying TV from the main Flix2Kodi menu however, I kept getting spinning circle of death too. I used the delete cache and cookies (or whatever the two delete options are the, I think, Advanced section on the Add-on's settings), I can't remember if I rebooted again, but was then working okay thereafter. You might want to if you haven't already Smile
Reply
I just installed vezion 0.4.7. And I only can watch film with Chrome. So If I select a movie then it is getting playin in the background in Chrome. If I change the settings to chromelauncher then nothing is happenning.

(sorry my bad english)
Reply
Hi, short update:

Just released 0.4.7, please update!

After Update:

cwh060, mhoogenbosch, harry fine, SamBotte, brashquido, vorta, Bearhunter73: please try again.
edge-users: please try again. (fullscreen)
benno.1973: please open an issue on github (encoding, playcount)

I added support for custom scripts.
These are neccessarry if you want to call something before and after launching the browser (for example a window-manager, something for remote-control)
You can also create a custom browser script.

For custom scripts create a folder called "custom" in the addon_data folder for the plugin ( something like /home/kodi/.kodi/userdata/addon_data/plugin.video.flix2kodi )
In the folder you can create 3 files:
before_playback.cmd (or on linux before_playback.sh)
after_playback.cmd (or on linux after_playback.sh)
playback.cmd (or on linux playback.sh)
If flix2kodi finds one of them, it will call them. If a custom playback script exists, it is called instead of the default.

Please do not modify the shell scripts anymore cause they will be overwritten by update.
If you use this custom directory, they will be persistent.

And perhaps someone could write a guide how to launch a dm like blackbox or openbox in the before-script and killing it in the after script.
Perhaps also for autohotkey on windows and other needs.
I could add the scripts as examples for other users.

Please note: the playback-script has to block until playback finished, cause flix2kodi will update playcounts after playback.
Reply
(2016-01-07, 01:53)idioty Wrote: I just installed vezion 0.4.7. And I only can watch film with Chrome. So If I select a movie then it is getting playin in the background in Chrome. If I change the settings to chromelauncher then nothing is happenning.

(sorry my bad english)

You should provide further informations, like which OS you use. Have you installed chromelauncher addon?
Have you seen the post by "harry fine"? Perhaps he could help.
Reply
logi85, 0.4.7 downloaded and working again. Thanks!
Reply
(2016-01-06, 18:16)Cassiuss Wrote:
(2016-01-06, 02:57)tree_and_kite Wrote: I updated my AHK script for more comfortable usage. Please try it out. https://dl.dropboxusercontent.com/u/1122...etflix.zip

Caveats:

1. Windows only, obviously.

2. You probably need the MCERemote addon from the kodi repo installed. Could someone test and tell me if it works without it?

3. Subtitle toggling is not implemented. I might add it if people want it

I have tried your script, thanks for sharing! But it does not seem to do anything for me... I already played around with MCE Remote before trying to exit for flix2kodi but can't get it to work. Which option in MCE Remote do I need to choose to get your script to work?? I am on windows 10 btw, will this make a difference??

Also tried to program alt+F4 on my harmony remote (that I am using downstairs, upstairs I have a cheap chinese MCE remote) but can't get this to work as well..

And tried to remap some keys with LM Remote keymap, but this did not work as wel..

Maybe one of the things that I have tried is interfering with the other, I don't know, but it is starting to get annoying Big Grin

I've just added a script to help with debugging. Please re-download the zip and run keyboardOSD.exe. What does it say when you press 'stop' on your remote?

edit: it should look something like this

Image


Edit 2: You are using chrome right?
Reply
Here's the thread and links to the current version of Chromium. There is a 7.0 at the site, but it gave me and others dependency errors, so I stayed with 6.0.4.

http://openelec.tv/forum/128-addons/7664...mitstart=0
Reply
Anyone using Yatse android app with this for a remote? I can't for the life of me get anything to work for controls once I launch chrome or IE, pause and close window are the important ones. It was working before, maybe 3-4 updates ago?
Reply
(2016-01-07, 01:57)logi85 Wrote: And perhaps someone could write a guide how to launch a dm like blackbox or openbox in the before-script and killing it in the after script.
Perhaps also for autohotkey on windows and other needs.
I could add the scripts as examples for other users.

You really want to add a buffering window manager and openbox.

Otherwise you will get tearing.

I put mine in /usr/bin/kodi-standalone but there is probably a better place.

Install compton with apt-get to do the compositing then add these lines to your kodi-standalone

>compton --backend glx --paint-on-overlay --glx-no-stencil --vsync opengl-swc --shadow-exclude "! name~=''" -b &
>openbox &


If you can find a better place to put these, let me know.

There is no real need to exit openbox afterwards but you could kill it.
Reply
(2016-01-06, 02:09)logi85 Wrote: hi, please remove series/movies from the database-folder .../addondata.../library/ which contain ’ in it's name and try again. If it works, try to add these series/movies again to library and try again.

(2016-01-07, 01:57)logi85 Wrote: benno.1973: please open an issue on github (encoding, playcount)

Sorry for the delay - I've done some testing and it's definitely the single apostrophe causing the issue. If I remove any tv series titles that contain an apostrophe, the issue goes away.

I've raised a github issue for this, as well as one for adding movies to My List (Flix2Kodi crash).

Thanks!
Reply
(2016-01-07, 02:07)logi85 Wrote:
(2016-01-07, 01:53)idioty Wrote: I just installed vezion 0.4.7. And I only can watch film with Chrome. So If I select a movie then it is getting playin in the background in Chrome. If I change the settings to chromelauncher then nothing is happenning.

(sorry my bad english)

You should provide further informations, like which OS you use. Have you installed chromelauncher addon?
Have you seen the post by "harry fine"? Perhaps he could help.

I forget this Sad
OS: OSx 10.11.2, Kodi 15.2, Chromelauncher installed. And I also forget, this problem was appear also with previous version 0.4.6.
Chromelauncher is working, but exmple the vimeo will appear also in the background.
Reply
  •   
  • 1
  • 10
  • 11
  • 12(current)
  • 13
  • 14
  • 70
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Flix2Kodi - Just another Netflix-Addon8
This forum uses Lukasz Tkacz MyBB addons.