• 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 16
How to get a seamless remote experience
I have the HP MCE Remote, and all in all it works great with Kodibuntu. I've seen a lot of people commenting about having problems coming out of Standby mode. My only issue is coming out of the screen dimming mode. I don't have it going into standby or anything like that, but if it spends a good amount of time in the screen dim mode, the remote doesn't do anything. I have to grab my keyboard, and tap any key, then the remote will continue working again. I do notice whenever this happens, the red light on the reciever is solid, as if it's getting a signal from the remote none stop... but it's not. Again, tapping a key on the keyboard stops all that, and the remote resumes normal operation.
Hi guys,

Sorry for all the help I've been requiring but here is one more for you.

Lubuntu 15.04 (kernel: Linux 3.19.0-15-generic)
Kodi 15.2 Git:02e7013
Intel NUC

I'm trying to run ir-keytable -c -w /etc/rc_keymaps/rc6_mce

sudo ir-keytable -c -w /etc/rc_keymaps/rc6_mce
Invalid parameter(s)
ir-keytable: -w: (PROGRAM ERROR) Option should have been recognized!?
Try `ir-keytable --help' or `ir-keytable --usage' for more information.

I'm sure it is a small error but cant seem to figure it out for the life of me!

Thanks once again!

I have exactly the same problem that this guy: http://forum.kodi.tv/showthread.php?tid=177845

My OS is Ubuntu 14.04 (kernel 4.3) with OrigenAE M10 (15c2:0036 device) and a MCE Remote (Philips RC197). I installed ir-keytable and lirc without any problem. Then I did sudo dpkg-reconfigure lirc and select Linux input layer and my device without problems. Finally I executed: /usr/bin/ir-keytable -w /lib/udev/rc_keymaps/imon_mce -p RC6 (I didn't remember exactly the command, but was worked).

Finally I tested with: ir-keytable -t and every button worked lovely. But....the pause, stop, guide, and 3-4 more buttons has the same problem with the "Double Presses'. It's very easy to identify with the "ir-ketable -t" and pressing any of this buttons...

Any ideas?
(2015-09-25, 03:05)LupinSansei Wrote: Man I am struggling like hell getting this to work. I have simple commands working like volume up and down, enter, arrow up and down etc but nothing else no matter what rc6_map I use :/

Here is my rc6_mce file.


and my keyboard.xml for Kodi.


I just want the normal basic commands nothing special like hitting ok to open, guide button for contex guide butong going back home etc please help. Bout to pull my hair out lol.

I moved to a new linux mint 17.3 cinammon, and i was having issues with some buttons working and others did not.

Somehow when you load a custom keytable is not getting loaded or something.

I had to copy my "custom table" and overwrite this file:


and then reboot...and it was heaven again!

I have a problem with the RC of DVB S2 TBS6982SE. I have installed Ubuntu Server 15.10, where it is installed KODI.

In the RC does not work all the keys.
Do not operate below these keys:
POWER, Back, OK, CHL + CHL-, *, #, TV, Zoom, FAV Mode, the EPG, SUB, REPLAY, SKIP.

After applying the ir-keytable command in the console shows that the pilot sends commands with these keys.

sudo ir-keytable  -t

Testing events. Please, press CTRL-C to abort.
1454241106.710528: event type EV_MSC(0x04): scancode = 0x84
1454241106.710528: event type EV_KEY(0x01) key_down: KEY_POWER2(0x0001)
1454241106.710528: event type EV_SYN(0x00).
1454241106.710593: event type EV_MSC(0x04): scancode = 0x84
1454241106.710593: event type EV_SYN(0x00).
1454241106.962500: event type EV_KEY(0x01) key_up: KEY_POWER2(0x0001)
1454241106.962500: event type EV_SYN(0x00).
1454241120.510525: event type EV_MSC(0x04): scancode = 0x99
1454241120.510525: event type EV_KEY(0x01) key_down: KEY_OK(0x0001)
1454241120.510525: event type EV_SYN(0x00).
1454241120.510562: event type EV_MSC(0x04): scancode = 0x99
1454241120.510562: event type EV_SYN(0x00).
1454241120.762517: event type EV_KEY(0x01) key_up: KEY_OK(0x0001)
1454241120.762517: event type EV_SYN(0x00).

In KODI also I installed application to map the keys, but it is not possible to map onto these keys. In KODI they do not work.

More info:

sudo ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event7) with:
        Driver saa716x, table rc-tbs-nec
        Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other
        Enabled protocols: NEC LIRC
        Name: saa716x IR (TurboSight TBS 6982S
        bus: 1, vendor/product: 6982:0002, version: 0x0001
        Repeat delay = 500 ms, repeat period = 125 ms

How to solve the presented problem?

Harmony 650: Profiles "MCE Remote SE" plus "MCE Keyboard" Ubuntu 14lts

Hi IR profs ;-)
With ir-keytable protocols RC-6 and mce_kbd enabled, "MCE remote" works but MCE keyboard gives trouble ...

"MCE Keyboard":
1 Quite often repeated keys
2 Mouse buttons: no button Up is dedected (or it comes too late). It comes when I press another button like "mouse move" in the example below
Event: time 1459697933.706289, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 1 = Button Down
Event: time 1459697934.507118, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 2 = Repeat
Event: time 1459697934.707126, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 2
Event: time 1459697935.107119, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 2
Event: time 1459697935.210348, type 2 (EV_REL), code 0 (REL_X), value -5 = I pressed Mouse Move button
Event: time 1459697935.210348, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 0 = then Button Up comes

So right now I gave up on using the kernel modules and try to use LIRC instead.
+ I got the "MCE Remote" working, when checking with irw.
+ I also see the signals from "MCE Keyboard" when using "mode2 -d /dev/lirc0", but nothing with irw.
- I did not find any lirc.conf for the "MCE Keyboard"

MODULES="lirc_dev mceusb ir_lirc_codec"

After researching for weeks I am still not sure which mode I should use to get "MCE Keyboard (not Remote)" working: "lirc only" or "kernel+lirc" and how to do that.

a) Is there a lirc.conf for "MCE keyboard" ?
b) how to configure hardware.conf ?
Does anyone have or know where I can get an rc6_mce file? I was dumb and accidentally overwrote mine without backing it up :/
Asrock Rog Z390-H | Intel i9 9900K | Windows 10 Pro x64 | Pop!_OS 20.10 |Nvidia Shield TV Pro (2019)
EVGA Hybrid FTW GTX 1070 | Corsair 16GB DDR4
Samsung 500GB SSD | 500GB Nvme SSD |500GB WD Black Nvme SSD |6TB HDD
how to edit hardware.conf ?
I am having a strage problem.

ir-keytable shows my keymap is working correctly.

But some key presses are not detected by kodi (17).

KEY_UP, KEY_SELECT, KEY_I are working for example.
But KEY_H, KEY_PAGEUP, ... are not shown in the kodi's debug log.

Does anybody have an idea why this happens?

My system:
Lubuntu 16.04
Kodi 17 Beta 3


I found the solution!

You need to restart the X server (restart kodi service or reboot), because it only triggers on KEYs that are mapped during the start of X.

You also need to load your keymap with ir-keytable befor you restart X.

I'm having trouble with my IR remote. I'm running ubuntu 16.04 and kodi 16.1 and everything is fine after a reboot (i.e. the remote control can be used to operate kodi). However when I suspend the PC I'm able to wake up using the IR remote but it's no longer usable in kodi.

Below is the output of dmesg:
[ 31.767341] lirc_dev: IR Remote Control driver registered, major 244
[ 31.793877] usbcore: registered new interface driver mceusb

lsusb shows this:
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 005 Device 002: ID 1d57:ac01 Xenta Wireless Receiver (Keyboard and Mouse)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

From what I have seen in various postings there should be an entry for the IR control. Is there anything that I could do to get this resolved. (I tried to use lirc but so far to no result).

Thanks alot for any helpful hints.

PS I forgot to mention that even after waking up from suspend ubuntu is accepting the shutoff IR command (i.e. it opens the selection whether one would like to sleep, shutdown, restart etc.)
The path to the lirc device changed on zesty. To use lirc with kodi on zesty, you need to point kodi to the new device:
kodi -l /var/run/lirc/lircd
I had to change from LIRC to ir-keytable because LIRC flat out refused to work for me after upgrading to zesty, and I'm still trying to figure ir-keytable out.
Some keymaps lag more than others, for example, the perceivable input lag with keys like KEY_LEFT and other directional keys is okay; while keys like KEY_ENTER or KEY_BACKSPACE are horrendously slow - what could be the cause here?
(2017-06-03, 14:18)halfer Wrote: Some keymaps lag more than others, for example, the perceivable input lag with keys like KEY_LEFT and other directional keys is okay; while keys like KEY_ENTER or KEY_BACKSPACE are horrendously slow - what could be the cause here?
That could be caused by the longpress modifiers in keyboard.xml - kodi then has to wait for a key release or repeat event before it knows which action to perform.
see eg https://github.com/xbmc/xbmc/blob/master...rd.xml#L43

You could try with a keyboard.xml without longpress entries.

so long,

Trying out LIRC again after it stopped working for me after upgrade to Zesty.
The devinput driver I used before is not working at all (can't record keypresses with irrecord), the default driver is glitchy - after an hour of standby or a reboot the driver stops receiving inputs, almost like it fell asleep - if you mash the remote buttons, it will start to function again, but only to "fall asleep" an hour later.
Any direction I should look into to troubleshoot this?
hi all,

i'm having trouble as well. I got this working before but not sure why it isn't working this time. I would expect with the setup below at least the left, right, up, down, and numeric keys to work,but no. I'm running on Ubuntu 16.04.1 LTS with kodi 16.1.
I got lircd.conf setup and testing with irw returns the keys when I press the remote on cli. I then configured the LIrcmap.xml and remote.xml but no dice

my Lircmap.xml located in ~/.kodi/userdata
<remote device=samsung>

my lircd.conf located in /etc/lirc/:
begin remote

  name  yaUsbIR_frontswitch
  bits            5
  flags RC5
  eps            30
  aeps          100

  one           884   884
  zero          884   884
  plead         884
  pre_data_bits   8
  pre_data       0xF8
  gap          100000
  min_repeat      2
#  suppress_repeat 2
#  uncomment to suppress unwanted repeats

      begin codes
          KEY_F1                   0x00
          KEY_F2                   0x01
          KEY_F3                   0x02
          KEY_F4                   0x03
          KEY_F5                   0x04
          KEY_F6                   0x05
          KEY_F7                   0x06
          KEY_F8                   0x07
          KEY_F9                   0x08
          KEY_F10                  0x09
          KEY_F11                  0x0A
          KEY_F12                  0x0B
          KEY_F13                  0x0C
          KEY_F14                  0x0D
          KEY_F15                  0x0E
          KEY_F16                  0x0F
          IN_1_L                   0x10
          IN_1_H                   0x11
          IN_2_L                   0x12
          IN_2_H                   0x13
          IN_3_L                   0x14
          IN_3_H                   0x15
          IN_4_L                   0x16
          IN_4_H                   0x17
          IN_5_L                   0x18
          IN_5_H                   0x19
          IN_6_L                   0x1A
          IN_6_H                   0x1B
          IN_7_L                   0x1C
          IN_7_H                   0x1D
          IN_8_L                   0x1E
          IN_8_H                   0x1F
      end codes

end remote

begin remote

  name  yaUsbIR_control
  eps   1
  aeps  1

  ptrail 0
  repeat 0     0
  gap    31000

      begin raw_codes
          name 0
          name 1
          name 2
          name 3
          name 4
          name 5
          name 6
          name 7
          name 8
          name 9
          name 10
          name 11
          name 12
          name 13
          name 14
          name 15
          name 16
          name C_END
          name C_WATCHDOG
          name C_OUTPUT
          name C_INPUT
          name C_IR

      end raw_codes

end remote

# Please make this file available to others
# by sending it to <[email protected]>
# this config file was automatically generated
# using lirc-0.9.0(ya_usbir) on Sat Jun 17 16:51:42 2017
# contributed by
# brand:                       lircd.conf
# model no. of remote control:
# devices being controlled by this remote:

begin remote

  name  samsung
  bits           16
  flags SPACE_ENC
  eps            30
  aeps          100

  header       4550  4473
  one           592  1649
  zero          592   529
  ptrail        592
  pre_data_bits   16
  pre_data       0xE0E0
  gap          46852
  toggle_bit_mask 0x0

      begin codes
          Key_1                    0x20DF
          Key_2                    0xA05F
          Key_3                    0x609F
          Key_4                    0x10EF
          Key_5                    0x906F
          Key_6                    0x50AF
          Key_7                    0x30CF
          Key_8                    0xB04F
          Key_9                    0x708F
          Key_0                    0x8877
          Key_stop                 0x629D
          key_record               0x926D
          Key_Playpause            0xE21D
          key_playpause            0x52AD
          key_forward              0x12ED
          key_rewind               0xA25D
          key_mute                 0xF00F
          key_volumeup             0xE01F
          key_volumedown           0xD02F
          key_channelup            0x48B7
          key_channeldown          0x08F7
          key_menu                 0x58A7
          key_back                 0x1AE5
          key_exit                 0xB44B
          key_info                 0xF807
          key_program              0xF20D
          key_left                 0xA659
          key_right                0x46B9
          key_up                   0x06F9
          key_down                 0x8679
          key_ok                   0x16E9
          key_subtitle             0xA45B
          key_language             0x00FF
          key_text                 0x34CB
          key_scale                0x7C83
          key_a                    0x36C9
          key_b                    0x28D7
          key_c                    0xA857
          key_d                    0x6897
          key_e                    0x14EB
          key_f                    0xF906
          key_g                    0xFC03
          key_h                    0x9E61
          key_i                    0xC837
          key_j                    0xD629
      end codes

end remote

my remote.xml located in ~/.kodi/userdata/keymaps:
      <menu mod="longpress">Menu</menu>

don't know what is going wrong here.
some info on my lirc setup though that does not seem to be the problem. There are no other lirc processes or demons running, I start lirc with
sudo lircd --driver=ya_usbir /etc/lirc/lircd.conf
irw returns this when pressing buttons:
00000000e0e016e9 00 key_ok samsung
00000000e0e016e9 01 key_ok samsung
00000000e0e016e9 02 key_ok samsung
00000000e0e016e9 03 key_ok samsung
00000000e0e016e9 04 key_ok samsung
00000000e0e016e9 05 key_ok samsung
00000000e0e016e9 06 key_ok samsung
00000000e0e08679 00 key_down samsung
00000000e0e08679 01 key_down samsung
00000000e0e08679 02 key_down samsung
00000000e0e08679 03 key_down samsung
00000000e0e08679 04 key_down samsung
00000000e0e08679 05 key_down samsung
00000000e0e08679 06 key_down samsung
00000000e0e08679 07 key_down samsung
00000000e0e006f9 00 key_up samsung
00000000e0e006f9 01 key_up samsung
00000000e0e006f9 02 key_up samsung
00000000e0e006f9 03 key_up samsung
00000000e0e006f9 04 key_up samsung
00000000e0e046b9 00 key_right samsung
00000000e0e046b9 01 key_right samsung
00000000e0e046b9 02 key_right samsung
00000000e0e046b9 03 key_right samsung
00000000e0e046b9 04 key_right samsung
00000000e0e046b9 05 key_right samsung
00000000e0e016e9 00 key_ok samsung
00000000e0e016e9 01 key_ok samsung
00000000e0e0f906 00 key_f samsung
00000000e0e0f906 01 key_f samsung
00000000e0e0f906 00 key_f samsung
00000000e0e0f906 00 key_f samsung

any help much appreacited
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 16

Logout Mark Read Team Forum Stats Members Help
How to get a seamless remote experience9
This forum uses Lukasz Tkacz MyBB addons.