•   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 32
  •   
Beta Amber for Leia with Skinshortcuts
(2019-06-16, 23:25)treboR2Robert Wrote:
(2019-06-16, 21:41)bsoriano Wrote: @treboR2Robert , I liked your idea of episode widgets showing the season poster and not the tv show poster, so I went ahead and made that change.  It is already on Git.  If there is no season poster, it will display the tv show poster.  For the widgets where episodes are grouped, the label will now be "Season xx" (skin helper already provides this label).  For single episodes, the label remains the same (SxxExx).

I think this is kind of what you were looking for.  Please test and let me know.  Thanks.

Regards,

Bart 

Hi Bart,

I just tried the latest from Git and there is still no label being shown on the recently added widget.
Also it still shows the show poster rather than season poster.
I tried all 4 Recently added widgets 

The 1's from "default widgets" and "additional widgets" show no label at all and the show poster not season poster.
The 1 from "video library" doesn't stack/group the episodes and doesn't show "season posters" but does show SxxExx on the individual episodes.
The 1 from "video library" that is PKC shows both the label and the season poster but does not Stack/Group the episodes.

I can't find any other settings anywhere that would change this ? 
@treboR2Robert , I am not sure what is going on, in my setup it is working as I described:

Image

That is the default widget.  The one from skin helper widgets (grouped episodes):

Image

I will check to see if there was any problem uploading to Git.

Regards,

Bart
(2019-06-16, 23:31)treboR2Robert Wrote:
(2019-06-16, 18:43)bsoriano Wrote: Hello all,

Just a small update on what I will be looking at next, so you know what to expect.

1. Some requests for changes in the video info dialog.  These will be the last changes I do for this screen before merging this version with current Amber for Leia.
2. Integration with PKC (basically testing on my part).
3. Possible changes to the recently added episodes widgets.
4. @Mr. V has been kind enough to point out where the source of the "lag" for widgets and menu option transitions is.  The changes I will be taking on for the widgets are massive for me, but I understand their necessity.  This will take me a while, most likely 1 -2 weeks.  During this time, I will not be providing any other changes to the skin.

Given 4. above, I think it would be best if you pull tonight whatever changes I publish to Git today, and then don't update again from Git until I let you know that I am finished with the widgets work, since the skin might be broken or things will not function correctly while I am working on this.

Thank you all for your understanding and patience.

Regards,

Bart

That's interesting you have found something, Thanks @Mr. V 

What's wrong with it ? tell me it's too complicated to explain if you like lol, I imagine it is anyway Rofl

1-2 weeks is no time at all, I am happy to wait. Does that mean you are going to hold off uploading to the kodi repository until you have solved the lag problem ?

Thanks
Rob 
@treboR2Robert , it has to do with using the templates feature of skinshortcuts, so that a different container id is generated for the widgets for each menu item, instead of using the same id, which causes Kodi to refresh that same container every time you move from one menu item to the next, which can cause lags.  Given that I am only adapting/adding to skin code that was already there, it is a really big task for me to use the templates feature, which, for me, is quite complicated.

And yes, I will not upload to the Kodi repo or merge with current Amber until I have done this.

Regards,

Bart
(2019-06-16, 23:33)edjalmo Wrote:
(2019-06-16, 21:44)bsoriano Wrote: @edjalmo , please test the latest from Git.  I centered the certification flag as best as I could, the tv show banner is now displayed (if present) if there is no cast, and the list on the right now has "infinite scrolling" as you call it.  Please let me know if this is what you were looking for.  Thanks.

Regards,

Bart
Thanks you very much! It's perfect!
I have two more things too say (one suggestion and one "bug" in some TV show poster), but I will telling just later, after you you fix this things you mentioned before.
Thanks again!
(2019-06-16, 21:41)bsoriano Wrote: For the widgets where episodes are grouped, the label will now be "Season xx" (skin helper already provides this label).
I already have recent add TV show and in progress TV widgets, but I'm not getting this labels. I have to change some settings? 
@edjalmo , I would rather you let me know the issues today, since it might be weeks before I get to them otherwise.

The widgets that should show Season posters are all episode widgets.  There is no setting you need to change.

Regards,

Bart
@treboR2Robert , @edjalmo, I had made a mistake with the position of a label for episode widgets when two shelves are shown together.  I have fixed that.  I checked the files uploaded to Git and all the changes are there.  Please download from Git, and check again if your episode widgets show season posters (if you have them).  If not, please try setting the widget to None, pressing back, and then selecting again your desired widget.  Thanks.

Regards,

Bart
(2019-06-17, 00:42)bsoriano Wrote:
(2019-06-16, 23:34)treboR2Robert Wrote: @bsoriano 

I found the page showing all my movie genres with the icons Big Grin

I cannot find anywhere at all though that the country icons are displayed.

@treboR2Robert , you can acces it going to Movies, Browse, Countries.  You can also set it up as a widget, Video Library, Movies, Countries, Use as widget.  The following images should show this:

https://imgur.com/a/c7VaWxi

Regards,

Bart

hmm ok I will check again, pretty sure I couldn't see any widget or submenu options for countries though.
(2019-06-17, 01:09)bsoriano Wrote: @treboR2Robert , @edjalmo, I had made a mistake with the position of a label for episode widgets when two shelves are shown together.  I have fixed that.  I checked the files uploaded to Git and all the changes are there.  Please download from Git, and check again if your episode widgets show season posters (if you have them).  If not, please try setting the widget to None, pressing back, and then selecting again your desired widget.  Thanks.

Regards,

Bart

Still not showing any labels or season posters Bart.

dont know whats going on

I tried setting it to none aswell and redoing it but same result
(2019-06-17, 01:36)treboR2Robert Wrote:
(2019-06-17, 01:09)bsoriano Wrote: @treboR2Robert , @edjalmo, I had made a mistake with the position of a label for episode widgets when two shelves are shown together.  I have fixed that.  I checked the files uploaded to Git and all the changes are there.  Please download from Git, and check again if your episode widgets show season posters (if you have them).  If not, please try setting the widget to None, pressing back, and then selecting again your desired widget.  Thanks.

Regards,

Bart

Still not showing any labels or season posters Bart.

dont know whats going on

I tried setting it to none aswell and redoing it but same result 
@treboR2Robert , I don't know what to tell you.  I am sure you have season posters in the db for your shows, right?  Does the skin helper widgets recently added episodes show the episode label (SxxExx) for all the episodes, or are there missing labels? Did you have PKC cache all of the artwork to Kodi?

Regards,

Bart
(2019-06-17, 01:44)bsoriano Wrote:
(2019-06-17, 01:36)treboR2Robert Wrote:
(2019-06-17, 01:09)bsoriano Wrote: @treboR2Robert , @edjalmo, I had made a mistake with the position of a label for episode widgets when two shelves are shown together.  I have fixed that.  I checked the files uploaded to Git and all the changes are there.  Please download from Git, and check again if your episode widgets show season posters (if you have them).  If not, please try setting the widget to None, pressing back, and then selecting again your desired widget.  Thanks.

Regards,

Bart

Still not showing any labels or season posters Bart.

dont know whats going on

I tried setting it to none aswell and redoing it but same result  
@treboR2Robert , I don't know what to tell you.  I am sure you have season posters in the db for your shows, right?  Does the skin helper widgets recently added episodes show the episode label (SxxExx) for all the episodes, or are there missing labels? Did you have PKC cache all of the artwork to Kodi?

Regards,

Bart 
Yes I have season posters for everything, they show up when browsing normally.
Everything is cached yes.
I have just spent the last 10 minutes trying every possible way, all 4 widgets, tried horizontal menu, tried 1 shelf on its own, tried changing to widget 1 .

Didn't check what happens if i disable the group tv shows in skin helper though i will try that now.
well something fishy is going on because i disabled the group episodes option in skin helper and they are all still showing as grouped even after deleting the widget and redoing it.

I will try a fresh install of amber and see what happens
(2019-06-17, 01:53)treboR2Robert Wrote:
(2019-06-17, 01:44)bsoriano Wrote:
(2019-06-17, 01:36)treboR2Robert Wrote: Still not showing any labels or season posters Bart.

dont know whats going on

I tried setting it to none aswell and redoing it but same result  
@treboR2Robert , I don't know what to tell you.  I am sure you have season posters in the db for your shows, right?  Does the skin helper widgets recently added episodes show the episode label (SxxExx) for all the episodes, or are there missing labels? Did you have PKC cache all of the artwork to Kodi?

Regards,

Bart   
Yes I have season posters for everything, they show up when browsing normally.
Everything is cached yes.
I have just spent the last 10 minutes trying every possible way, all 4 widgets, tried horizontal menu, tried 1 shelf on its own, tried changing to widget 1 .

Didn't check what happens if i disable the group tv shows in skin helper though i will try that now.  
@treboR2Robert , could you please PM me the link (put it up in whatever file sharing or cloud drive site you use) to your script-skinshortcuts-includes.xml file? You will find it in the skin's 1080i folder.  That 
way I can check the attributes that are being set for your widgets.  Maybe there is something there. Thanks.

Regards,

Bart
@bsoriano 

Ive PM'd you it Bart.

I forgot to turn on link sharing at 1st, but have done so now and it is accessible.

Thank you
I have been planning on doing a fresh install of kodi and PKC on my s912, so I will do that now and see what happens with the widgets.
(2019-06-17, 02:19)treboR2Robert Wrote: @bsoriano 

Ive PM'd you it Bart.

I forgot to turn on link sharing at 1st, but have done so now and it is accessible.

Thank you
@treboR2Robert, thanks for the file.  Something was going on, since in the file it shows you only have one widget for tv shows, and it seems you had a second one, but it looks incomplete (maybe you sent me the file after you had set the second widget to None, but before you had re-added it?)

In any case, you can quit Kodi, delete the file, and have skinshortcuts re-create it (this will happen automatically when you restart Kodi).  Please let me know how it goes after that.  You may have to re-do your widgets.  Thanks.

Regards,

Bart
(2019-06-17, 01:00)bsoriano Wrote: @edjalmo , I would rather you let me know the issues today, since it might be weeks before I get to them otherwise.

The widgets that should show Season posters are all episode widgets.  There is no setting you need to change.

Regards,

Bart
The thing I want to add is an option in video info to show fanart.
The thing I called "bug" is that a strange line appears on the right edge of the poster in video info of some Tv shows. The thing more weird (and I only noticed this now) is that this don't happend in my PC, only in my Raspberry (LibreELEC) that is connected in my TV.
Look images https://imgur.com/a/wOsiugY
I tried update Tv show, but not solved.

Sorry not telling this before, is because I forget.
Supercalifragilisticexpialidocious! (inscribed in large friendly letters)
My hardware is a Raspberry Pi 3b (with LibreELEC)
(2019-06-17, 02:47)bsoriano Wrote:
(2019-06-17, 02:19)treboR2Robert Wrote: @bsoriano 

Ive PM'd you it Bart.

I forgot to turn on link sharing at 1st, but have done so now and it is accessible.

Thank you
@treboR2Robert, thanks for the file.  Something was going on, since in the file it shows you only have one widget for tv shows, and it seems you had a second one, but it looks incomplete (maybe you sent me the file after you had set the second widget to None, but before you had re-added it?)

In any case, you can quit Kodi, delete the file, and have skinshortcuts re-create it (this will happen automatically when you restart Kodi).  Please let me know how it goes after that.  You may have to re-do your widgets.  Thanks.

Regards,

Bart 

Yes I had been trying everything I could possibly try including deleteing all widgets from tv shows and then adding it again.

The one that is there atm is recently added.

I have been doing all this testing on my pc lately. I have just turned the s912 on to do a fresh install and check what happens on there.

Will report back in 15 mins, and will pm you the same file from the s912 once i have it set up.
  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 32
  •   



Logout Mark Read Team Forum Stats Members Help
Amber for Leia with Skinshortcuts1
This forum uses Lukasz Tkacz MyBB addons.