My NFO Files do not work
#1
I did not want to start another thread regarding this issue that I just found while adding an artist to my music library. In the past few weeks I've been adding every artist/album from my collection manually using MediaElch to create the NFO file, which I added the reviews etc to. It was extremely pain staking to say the least, especially to find many artist that don't' even exist on any of the music info platforms. Anyway, today I tried to add a group called "Big Country", as well as "'Til Tuesday" but for some reason it does not save the artist "Bio" from the NFO files.

However, I do realize that I don't have the proper setup for the AIF, but this is not the issue because I've added all the necessary artwork to root, as well as all the required NFO files for the artist, as well as the albums. It has been working great, but only today I discovered the above mentioned issues. I am quite certain I added "'Til Tuesday" last week and did see the bio in there. I know this because I add every single album manually then go check them to make sure all the data s in there. I also realzied that if there is an "allmusic id tag" in any of the NFO files, Kodi simply does not recognize the nof file. Anyway, this with the 2 artist mentioned above.

Here is my log file showing what's going on, but none of it makes any sense to me. Sad

https://paste.kodi.tv/xodutifivu.kodi

Thanks in advance for any help on this.

Shedrock
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#2
You seem to have a conflict with MBID's where you are adding a new entry with an MBID that already exists in the database.

Are you adding these MBID's manually to the NFO File for scanning?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
(2019-11-11, 21:15)Karellen Wrote: You seem to have a conflict with MBID's where you are adding a new entry with an MBID that already exists in the database.

Are you adding these MBID's manually to the NFO File for scanning?

No, I am just pulling the MBID's using MediaElch.
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#4
For example, I had .38 Special added over 1 month ago and the BIO was there up to 2 days ago because I added another album, but today when I checked it was gone. If I refresh and read the locally stored NFO file, it appears, but once I move away from the artists/album then it returns to blank. Could it be a corrupt database?

the only thing I see in the artist NFO files that are different to the ones that work is the following:

<?xml version='1.0' encoding='UTF-8' standalone='yes'?>

all the ones that work have:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

Even if I go back and add that change, then clean the library and refresh, it still doesn't work.
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#5
(2019-11-11, 21:23)shedrock Wrote: No, I am just pulling the MBID's using MediaElch.
Into nfo file?

No don't do this. Tag your music files properly using MusicBrainz Picard. Music library is not like Video library. Music library is created from music file tags. You cannot create music library entries using nfo files. The most you can do is add additional information, and edit some minor items that come from tags like genre, themes, mood etc. Those trivial items.

Read here as we are explaining it in another thread at the same time. You are basically doing the same thing, but with nfo files instead of the new addon. Start from my post and read onwards esp. posts from daveblake... https://forum.kodi.tv/showthread.php?tid...pid2898857
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#6
(2019-11-11, 21:55)Karellen Wrote:  
So this NFO is not sufficient?

https://paste.kodi.tv/ofavepomuj

These are basically how all the artist NFO files are using MediaElch. I am just at a lost as to why it was working for some but not for others. I will have a look at the post and see if I can figure it all out. The other issue is that Picard does not recognize some of my artist, so this is a major problem. Sad
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#7
(2019-11-11, 22:00)shedrock Wrote: So this NFO is not sufficient?

Depends what you are trying to do.  If you're trying to update an artist that is already in your music library, then yeah, Kodi should use the .nfo file in preference to scraping online.  If you're trying to add an artist, then no, that's not the way to do it.

BTW, this isn't at all skin related Wink
Learning Linux the hard way !!
Reply
#8
(2019-11-11, 22:00)shedrock Wrote: So this NFO is not sufficient?
No. You cannot create an entry via nfo file. It needs to be created from the music file tagging. Your NFO then adds additional informationafter the entry has been created

Why do some work? At a guess I would say there is some tagging in the music file that created an entry, and the nfo added the additional information.

I find it strange that you have artists that are not listed at MB. Can you provide an example?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#9
(2019-11-11, 22:13)Karellen Wrote: I find it strange that you have artists that are not listed at MB. Can you provide an example? 
Boulevard (Sweden) is just one of a few that's not listed there. Also, I even had to add a Quiet Riot album a few weeks ago. Discogs has much more reliable info, especially when it comes to Heavy Metal and obscure Glam Rock bands.

@black_eagle We know, but I keep screwing up and adding to this post. Maybe @Karellen can move it to the last "new" post we created a few weeks back.

Sorry about the posts @mikeSiLVO in here.

Shedrock

BTW: @Karellen I am using the file tagging option when scanning the albums in the DB. I just happen to have the NFO files already created in there for the artist. So far I have only for 5 artist that their Bio's aren't being saved, and every one has that (') instead of (") at the start of the XML file.
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#10
Thanks @black_eagle
Split to music.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#11
(2019-11-11, 22:42)shedrock Wrote: every one has that (') instead of (") at the start of the XML file.

Have you tried changing the single quotes to double quotes and then refreshing those artists ?  I'm not sure that the single vs double quotes should make a difference, but it would seem from your statement that they might well do.
Learning Linux the hard way !!
Reply
#12
(2019-11-11, 22:50)black_eagle Wrote:
(2019-11-11, 22:42)shedrock Wrote: every one has that (') instead of (") at the start of the XML file.

Have you tried changing the single quotes to double quotes and then refreshing those artists ?  I'm not sure that the single vs double quotes should make a difference, but it would seem from your statement that they might well do.  
Yes, I've changed them and then cleaned the library, but that did not do the trick. I just find it strange that it works for over 25 albums from a band called Uriah Heep, as well as Asia's massive album collection, and not one glitch wiith the artist or album info using the NFO files, but yet it would not work for Whitey Houston's 2 albums that I have and a few others. Given the fact I also have over 2000 artist and just a few aren't working is even weirder, and as I mentioned that all of them that have the (') quotes instead of the (") are the ones giving trouble.
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#13
https://paste.kodi.tv/imawajazov <- Whitney Houston, The Greatest Hits
https://paste.kodi.tv/oyoroziwop <- The Ultimate Collection
https://paste.kodi.tv/berofahuro <- Whitney Houston

See how yours look compared to mine.  Hopefully I've matched at least one of your albums !!

BTW, cleaning won't work.  You need to refresh info for that album or artist and answer NO when it asks you if you want to ignore local info and refresh from the internet.  Then the local nfo file should be loaded.
Learning Linux the hard way !!
Reply
#14
(2019-11-11, 23:05)black_eagle Wrote: https://paste.kodi.tv/imawajazov <- Whitney Houston, The Greatest Hits
https://paste.kodi.tv/oyoroziwop <- The Ultimate Collection
https://paste.kodi.tv/berofahuro <- Whitney Houston

See how yours look compared to mine.  Hopefully I've matched at least one of your albums !!

BTW, cleaning won't work.  You need to refresh info for that album or artist and answer NO when it asks you if you want to ignore local info and refresh from the internet.  Then the local nfo file should be loaded.
Mine looks noting like that for the Whitney Houston - ST album. As @Karellen knows. I don't have this issue with Windows. It is only happening to e on LibreELEC. If I try to use an AIF, it just returns an error regarding my credentials, which is correct. I even tried to create the Artist Info folder on my LibreELEC "music" folder and it still shows up an error regarding my path and credentials. I figured using the NFO file created by MediaElch would be an easy workaround, but apparently it isn't, at least for some artists. I also thought using the NFO files would override everything if I left the MBID's out but that's not a solution either. Anyway, I will just leave it for now, or maybe I should just stick to the good old cassettes or even vinyl. Big Grin

Thanks for all the help guys, but I think I can't win this battle using LibreELEC, even if others have it working on their systems.

Shedrock
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply
#15
(2019-11-11, 23:05)black_eagle Wrote: BTW, cleaning won't work.  You need to refresh info for that album or artist and answer NO when it asks you if you want to ignore local info and refresh from the internet.  Then the local nfo file should be loaded.

I do that, but the Artist info is not being saved, only the album NFO is being saved. Every time I go back to the album and pull up artist info, it is blank.
Philippians 4:13 (KJV) - I can do all things through Christ which strengtheneth me.
Reply



Logout Mark Read Team Forum Stats Members Help
My NFO Files do not work0
This forum uses Lukasz Tkacz MyBB addons.