•   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 45
  •   
WIP Ember Media Manager 1.9.x - Download & Discussion Thread
(2021-01-24, 23:11)DanCooper Wrote:
(2021-01-24, 16:22)shaktoo Wrote: -scrapemovies -newauto all

I think i should be (not really tested):
Code:
-scrapemovies newauto all

"newauto" and "all" are sub-parameter of "-scrapemovies" and these must not be preceded by a hyphen
Thanks Dan for clarifying . 
I have done this but still the automatic command line scraping isnt working.
Do you want the full log ?
(2021-01-25, 21:36)shaktoo Wrote: Do you want the full log ?
Yes, please a clean one with only one try to run the command.
(2021-01-25, 21:36)shaktoo Wrote:
(2021-01-24, 23:11)DanCooper Wrote:
(2021-01-24, 16:22)shaktoo Wrote: -scrapemovies -newauto all

I think i should be (not really tested):
Code:
-scrapemovies newauto all

"newauto" and "all" are sub-parameter of "-scrapemovies" and these must not be preceded by a hyphen
Thanks Dan for clarifying . 
I have done this but still the automatic command line scraping isnt working.
Do you want the full log ?
You know what I stand corrected.
Its Working again perfectly.
I deleted 1 movie from the database from ember & deleted all artwork etc. 
ran the batch script & BAM.... worked like a charm
I think there was a previous film ( the White Tiger ) which being new was probably causing the issue.
Thanks Dan.
(2021-01-25, 22:02)shaktoo Wrote:
(2021-01-25, 21:36)shaktoo Wrote:
(2021-01-24, 23:11)DanCooper Wrote: I think i should be (not really tested):
Code:
-scrapemovies newauto all

"newauto" and "all" are sub-parameter of "-scrapemovies" and these must not be preceded by a hyphen
Thanks Dan for clarifying . 
I have done this but still the automatic command line scraping isnt working.
Do you want the full log ?
You know what I stand corrected.
Its Working again perfectly.
I deleted 1 movie from the database from ember & deleted all artwork etc. 
ran the batch script & BAM.... worked like a charm
I think there was a previous film ( the White Tiger ) which being new was probably causing the issue.
Thanks Dan.
Maybe Ember was faster than your shadow... or vice versa Big Grin
(2021-01-25, 22:31)DanCooper Wrote:
(2021-01-25, 22:02)shaktoo Wrote:
(2021-01-25, 21:36)shaktoo Wrote: Thanks Dan for clarifying . 
I have done this but still the automatic command line scraping isnt working.
Do you want the full log ?
You know what I stand corrected.
Its Working again perfectly.
I deleted 1 movie from the database from ember & deleted all artwork etc. 
ran the batch script & BAM.... worked like a charm
I think there was a previous film ( the White Tiger ) which being new was probably causing the issue.
Thanks Dan.
Maybe Ember was faster than your shadow... or vice versa Big Grin
It IS... its faster than the flash .. Wink
But in all honesty Yes, the scraping is much faster especially Trailers. although I have yet to try Apple & Dave's as these were causing loads of issues previously.
Cheers Bud !
Image
(2021-01-25, 22:41)shaktoo Wrote: But in all honesty Yes, the scraping is much faster especially Trailers. although I have yet to try Apple & Dave's as these were causing loads of issues previously.
Apple and Dave (mostly also Apple trailers) are still fu***** slow, at least from Europe. Maybe it's faster from other countries. On YouTube I noticed that the videos in MP4 load very quickly (audio and video stream in same file), but all others load very slowly, as audio and video streams are stored separately and have to be downloaded individually. I thinks it's a streaming optimisation and you get only that much how you need to stream it without breaks. That means 2 min for a 2 min video...
Hi Dan,

I'm having some problems downloading some image types.
Code:
2021-01-26 16:32:13.2064;EmberAPI.HTTP;EmberAPI.HTTP.DownloadImage;32;ERROR;DownloadImage <https://assets.fanart.tv/fanart/movies/393559/moviebanner/my-life-as-a-courgette-5af2b66b76cf9.jpg>;"EXCEPTION OCCURRED:System.Net.WebException: A ligação subjacente foi fechada: Não foi possível estabelecer uma relação de confiança para o canal seguro SSL/TLS. ---> System.Security.Authentication.AuthenticationException: O certificado remoto é inválido de acordo com o processo de validação.
em System.Net.Security.SslState.StartSendAuthResetSignal(ProtocolToken message, AsyncProtocolRequest asyncRequest, Exception exception)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
em System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
em System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
em System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
em System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
em System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
em System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
em System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size)
em System.Net.ConnectStream.WriteHeaders(Boolean async)
--- Fim do rastreio da pilha de excepção interna ---
em System.Net.HttpWebRequest.GetResponse()
em EmberAPI.HTTP.DownloadImage()* em System.Net.HttpWebRequest.GetResponse()
em EmberAPI.HTTP.DownloadImage()"

 I think it's because of certificate validation on the endpoint.

EDIT: yeah... Certificate has expired today
Image
Image Image
Hello, I really like Ember and I'm using it for years now, thank you.

I use the scheme " $1\$E" for one movie per folder in the bulk rename but since this version the 1st letter is added twice to the target folder.

So the correct path is "2\2012 (2009)" and now it is "2\2\2012 (2009)".

Regards.
(2021-01-26, 23:41)Just-Me_A-User Wrote: I use the scheme " $1\$E" for one movie per folder in the bulk rename but since this version the 1st letter is added twice to the target folder.
The was always an "problem" in ALL older versions. If you use subfolder in the folder pattern you have to use $B to make the path absolute, otherwise you have the described problem after you rename the movie again. $B is always the path of the source, so with

Code:
$B\$1\$E

you have an absolute path e.g. "D:\Movies" + "\A" + "\Avangers, The"

Without $B the new path is relative to the path before renaming.
(2021-01-27, 00:04)DanCooper Wrote:
Code:
$B\$1\$E
Thank you very much!

BTW $1 has always the case of the first letter of $E: Avatar → D:\Mov\A\Avatar, a gone wild → D:\Mov\a\a gone wild. So one of these will be always renamed.

Really no show stopper ...
As you’ll read here Trakt TV is pulling away from TVDB because moral reasons and switching to TMDB.

Track TV Switching to TMDB

Have you considered switching to TMDB as well?
HTPC: Dell Optiplex 7050 SFF i7-7700 quad-core, 3.6GHz, 16GB
NAS: Synology DS1813+ and DX513, Hybrid RAID (SHR) 48TB usable space
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
(2021-01-27, 23:45)CaptainKen Wrote: As you’ll read here Trakt TV is pulling away from TVDB because moral reasons and switching to TMDB.

Track TV Switching to TMDB

Have you considered switching to TMDB as well?
Ember already supports TMDb for tv shows.
I'm considering whether to write a new scraper for TVDb that works with the user subscription model. Unfortunately, I have to buy a subscription first, which doesn't make it much more attractive. But I want to offer TVDb, because there should also be users who want to use this service.
(2021-01-27, 00:22)Just-Me_A-User Wrote: BTW $1 has always the case of the first letter of $E: Avatar → D:\Mov\A\Avatar, a gone wild → D:\Mov\a\a gone wild. So one of these will be always renamed.
Nice information! This is a bug and should be fixed because it can create issues with Unix based access if a path/file no longer is in the same proper uppercase/lowercase.
(2021-01-25, 23:01)DanCooper Wrote:
(2021-01-25, 22:41)shaktoo Wrote: But in all honesty Yes, the scraping is much faster especially Trailers. although I have yet to try Apple & Dave's as these were causing loads of issues previously.
Apple and Dave (mostly also Apple trailers) are still fu***** slow, at least from Europe. Maybe it's faster from other countries. On YouTube I noticed that the videos in MP4 load very quickly (audio and video stream in same file), but all others load very slowly, as audio and video streams are stored separately and have to be downloaded individually. I thinks it's a streaming optimisation and you get only that much how you need to stream it without breaks. That means 2 min for a 2 min video...
Hi Dan - is their a way to not download the actual trailer but set the youtube url to the nfo in automatic scrape, I can do that manually but dont see an option to do it in auto mode.
(2021-01-28, 15:25)geek-baba Wrote: Hi Dan - is their a way to not download the actual trailer but set the youtube url to the nfo in automatic scrape, I can do that manually but dont see an option to do it in auto mode.
No, because the data and trailer scraper are different modules. Will be possible in Ember 3.0.
  •   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 45
  •   



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.9.x - Download & Discussion Thread2
This forum uses Lukasz Tkacz MyBB addons.