TVheadend has to be restarted
#1
Everytime I start my system I have to restart tvheadend:
Code:
sudo service tvheadend restart

is there a way to automate this?
Reply
#2
Strange behavior. Although my server PC is constantly on, I don't have any problems on reboot.

I recommend using Pulse-Eight packages. On Ubuntu 10.04 I don't have any problems with them.
Reply
#3
I am using the pulse eight build too. I think it might be because I use an hdhomerun device. It seems to be a delay with that. As soon as it is up I can do the service restart and it is fine. Maybe a startup script to restart it after system is turned on? Like one minute in.
Reply
#4
Try changing your /etc/rc*.d contents. S20tvheadend is for starting tvheadend. Rename it to S99tvheadend in every folder (only the ones starting with S) and it should be loaded at the end of the boot sequence. I haven't tested this, I hope it helps.
Reply
#5
Yea that did it. Took about 1 minute for the web interface but I bet if I play with the 99 to something more like 70 or so it would be perfect.

Thanks a bunch!
Reply
#6
(2012-01-24, 23:44)ntadej Wrote: Try changing your /etc/rc*.d contents. S20tvheadend is for starting tvheadend. Rename it to S99tvheadend in every folder (only the ones starting with S) and it should be loaded at the end of the boot sequence. I haven't tested this, I hope it helps.

Can you elaborate on this? I have the same issue.
Reply



Logout Mark Read Team Forum Stats Members Help
TVheadend has to be restarted0
This forum uses Lukasz Tkacz MyBB addons.