(Home)Menu link to video or picture folder doesn't show content
I've just updated from Dharma and I'm having trouble accessing a videos folder and a pictures folder. It worked perfectly on Dharma.

For the pictures folder, even if I set my folder as default folder for my pictures, I always get to the view where there is a list with my pictures folder, "add source", "picture add-ons", etc.. No way it will go to my pictures folder directly.
I tried adding the folder to my favourites, then adding it to the home menu, but accessing it I get this:


Same with the videos folder, but with a different view.
Can't make a fav link in the home menu to access the folder directly with a list view.
Also, I try to add the fav to that folder in a home submenu and I cannot change the name of it. I press DOWN, the box appears, I rename it, ENTER, and it remains unchanged. If I try to rename it again, it displays the name I tried to gave it before.
Had the same issue (with the videos) and Big Noid said it was a bug. To fix, be sure to add the videos as a favorite. Then open up the favourites.xml and remove quotes around the affected folder. Then go back to customize the home menu and add the favorite.

Removed quotes:

<favourite name="Videos">ActivateWindow(10025,&quot;H:\\Videos\\&quot;)</favourite>

<favourite name="Videos">ActivateWindow(10025,H:\\Videos\\)</favourite>

Just to be clear, this is not a skin bug, but an bug in the way non library folders are are added to favorites in XBMC.
Yes, sorry I didn't mention it that way. Smile
It worked for both the videos and pictures. Thanks alot. I would never have found the problem myself.
Awesome, glad it worked for you!
Is this going to be fixed before the eden final is released? This bug is still in beta 2.
kavond Wrote:Is this going to be fixed before the eden final is released? This bug is still in beta 2.

Maybe ask ronie (in the Transparency thread), he fixed this bug in the favourites script for me:
Thanks this helped me too.

Had this issue with RC-2 shoudnt this be fixed in final version?
This one post solved something thats been taking me a day to figure out...
Thank you very much! Smile
Sorry to bump a sort-of old thread but I had the same problem. One favourite is now fixed but another uses an apostrophe. The favourite comes up as D:\\Brad&apos;s Files\\My Documents but the custom menu setting shows it as D:\\Brad\'

Replacing with an apostrophe does not work.

Plan B is to move the source folder.
Desktop / Media Server: Win10 x64, ThermalTake Commander G42 case, Asus Maximus VII Hero, Intel Core i5 4460 3.20GHz, Gigabyte Geforce GTX750, CM M 1000w, 8GB GSkill, Samsung SSD 840 Pro 120GB, 2x WD Black 1TB RAID 1, WD 6TB + WD 4TB spanned, single 3TB

Intel NUC with Openelec in TV room.
I have a folder called : Onze Videos. I made this a add to favorites.
then i set in custom 1 as favorite this favorite Onze Videos
when i select Onze Videos in the home screen, i get a screen with all sorts of windows but not my Onze videos.

In Aeon nox 2.0 everything worked fine, very irritating aeon nox update itself to 3.0.
cannot rollback,

the fix with in favorites,xml to get the quotes removed also does not work.

is there away to get aeon nox 2.0 back ? or fix the folder to favorites error ?

all the time i read it is not a skin problem, but with every other skin it works ok, only since aeon nox updatet itself it stopped working please help me ?

Got it, thanks to Phil :


Logout Mark Read Team Forum Stats Members Help
(Home)Menu link to video or picture folder doesn't show content0
This forum uses Lukasz Tkacz MyBB addons.