Advice and help for 2nd XBMC
#1
Hi guys,

I have been using XBMC for abit over a year I migrated over from TEAM MEDIAPORTAL. First of all I would like to congratulate everyone who developed this wonderful piece of software and all the add-on developers.

My main machine running XBMC was a windows box and all the scrapping was done locally and my media was remotely on my NAS. Everything was running perfect. Well 2 days ago I decided it was time to add another XBMC terminal in my bedroom so decided to get a ATV2.

I want these 2 devices to keep track of my watched folders and store my thumbnails and fan art centrally so I don’t need to scrap it with both of them.

I followed the following and everything was working perfect regarding using a centralized MySQL database. http://lifehacker.com/5634515/how-to-syn...-the-house

I was reading that saving the thumbnails within MySQL wasn’t possible. Apperently some people had some success into centralizing it at least so I have these question to ask.
  • With XBMC Eden 11.0 is it still impossible to store the art within the MySQL DB?
  • Whats the best practice to centralize it? Putting the album art within the Movie folder with the nfo file? If so does anyone have a good link for this procedure?

If anyone could shed some light for this issue I would greatly appreciate it.

Happy Holidays

K
Reply
#2
Use these instructions instead: http://wiki.xbmc.org/index.php?title=HOW..._libraries

This also includes the pathsub modification for thumbnails/fanart.
Reply
#3
Thanks for the reply,

So I am trying to get this done and I am stuck with the following error on the xbmc.log

Code:
18:30:31 T:6940 M:1028681728   ERROR: SQL: The table does not exist
                                            Query: select count(1) from musicvideo
18:30:31 T:6940 M:1028681728   ERROR: CVideoDatabase::HasContent failed
18:30:34 T:9868 M:1004322816   ERROR: WEATHER: Unable to get data: Invalid License Key.
18:30:37 T:6940 M:1004085248   ERROR: SQL: The table does not exist
                                            Query: select idMovie from movie join files on files.idFile=movie.idFile where files.idPath=-1
18:30:37 T:6940 M:1004077056   ERROR: CVideoDatabase::GetMovieId (smb://L33TNAS/Movies/21/) failed
18:30:47 T:6940 M:1001951232   ERROR: SQL: The table does not exist
                                            Query: select idMovie from movie join files on files.idFile=movie.idFile where files.idPath=-1
18:30:47 T:6940 M:1001951232   ERROR: CVideoDatabase::GetMovieId (smb://L33TNAS/Movies/21/) failed
18:30:57 T:6940 M:1002536960   ERROR: SQL: The table does not exist
                                            Query: select idMovie from movie join files on files.idFile=movie.idFile where files.idPath=-1
18:30:57 T:6940 M:1002536960   ERROR: CVideoDatabase::GetMovieId (smb://L33TNAS/Movies/21/) failed
18:31:04 T:6940 M:1002725376   ERROR: SQL: The table does not exist
                                            Query: select idMovie from movie join files on files.idFile=movie.idFile where files.idPath=-1

This is my advancesetting values.

Code:
<advancedsettings>
                                              <videodatabase>
                                                <type>mysql</type>
                                                <host>192.168.55.55</host>
                                                <port>3306</port>
                                                <user>xbmc</user>
                                                <pass>xbmc</pass>
                                                <name>xbmc_video</name>
                                              </videodatabase>
                                              <musicdatabase>
                                                <type>mysql</type>
                                                <host>192.168.55.55</host>
                                                <port>3306</port>
                                                <user>xbmc</user>
                                                <pass>xbmc</pass>
                                                <name>xbmc_music</name>
                                              </musicdatabase>
                                              <pathsubstitution>
                                                <substitute>
                                                  <from>special://masterprofile/Thumbnails/</from>
                                                  <to>smb://192.168.55.55/thumbs/</to>
                                                </substitute>
                                              </pathsubstitution>
                                            </advancedsettings>

When I look at MySQL I do see the databases are created.

xbmc_music
xbmc_video

Any help would be greatly appreciated.
Reply
#4
Well I got it to work on Eden (11.0b1). Is there a reason that it would run on Eden but not on Dharma Stable release.

I am really hoping to get this running on Dharma because my ATV2 is running on Dharma and I preter the stable build then a beta build.

Any information would be great. Thank you,
Reply
#5
Well it seems that the watched option is working and resume on another tv but my media art is not working. Sad

I dont see any errors, and i upgraded everything to eden.

Anyone?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Advice and help for 2nd XBMC00
This forum uses Lukasz Tkacz MyBB addons.