Thread Rating:
  • 0 Vote(s) - 0 Average
xbmc crashes when trying to play video
#1
Sad 
Fresh install of xubuntu 11.10 and xbmc. Was working fine. Added video files to library and played a few and was fine. Made some changes to settings and added some addons and now it's crashing every time I try to play a video. Did some searching and enabled debug. Crash log below. I'm not sure what to do next. Suggestions?

P.S. I can't figure out how to attach a crash log so... crash log

P.P.S I just noticed... this only happens if I'm using the web remote control. If I use the mouse it plays the video.
Reply
#2
don't want this to drop off the page w/o an answer... Anyone have an idea?
Reply
#3
Code:
#0  0x086b009a in CXBMCRenderManager::AutoInterlaceMethodInternal(EINTERLACEMETHOD) ()

Try turning off interlace handling. Other than that I'm crap for reading logs.
Reply
#4
I just started having the same problem.

Recently installed XBMCBuntu beta 3 and it was working fine for a couple days, and now won't play anything.

Sound started to forget it's settings, and then the menu sounds stopped working, and now it just crashes when I try to play any video.

Crashlog: http://pastebin.com/wZy2DFkC
Reply
#5
I don't have any crashes at all , except on exit.
I really don't understand this problem, tried different distros, happens on Gnome and KDE, tried it with opensource drivers and proprietary drivers, same thing happens. Sometimes it exits without crash but that's really rare. 1 out of 10 maybe.
What's going on with this issue ?
Is it really that hard to close XBMC application without crashing the whole desktop ?

I really don't know what else I can try to solve this issue , any suggestions ?
Reply
#6
I also just bought a pc remote. I have the same problem with it. if I use the mouse on the remote... video is fine. If I use the arrow keys and enter to select... video crashes client.
Reply
#7
thanks to you all who hijacked my thread with completely irrelevant crap.
Reply
#8
Irrelevant crap ??
XBMC is crashing on exit 99% of the time ?
That's irrelevant ?

Well, probably your crap is more relevant than that crap, interesting ...
Reply
#9
Yes idiot... mine crashes when trying to PLAY video with a remote not when trying to exit... Go start your own thread.
Reply
#10
Okay dumb ass , but if I see you on my thread I'm gonna kill you !!

ROFL calm down, it's not the end of the world.
Reply
#11
no but your blathering has kept me from getting support and hence... not using xbmc. fking moron troll.
Reply
#12
Ahh ... if my ONE completely normal and polite post prevented you from getting support for your problem , then I'm sorry. However, I think you have some other more important issues to solve in your life. That anger will get you nowhere, calling people idiots and fking morons, what can I say ... good luck.
Reply
#13
Lol. Thanks for taking the bullet for me Kowalsky!

BTW Daisychick, I solved my problem -- .asoundrc was corrupted. I erased it (so a new one would automatically be created) and everything worked. I also found one other corrupted file (TV database), so I bet there's more corrupted files...
Reply
#14
In my case I solved this issue by disabling Video Hardware Acceleration (VAAPI) in Settings->Video
Reply
#15
(2012-03-01, 15:42)Kowalsky Wrote: In my case I solved this issue by disabling Video Hardware Acceleration (VAAPI) in Settings->Video

The issue I was experiencing was that XBMC crashes when I tried to watch any video. This solved it. Thanks!
Reply



xbmc crashes when trying to play video00