•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 23
  •   
Associate extras and/or alternative versions to a movie/TV show title
#46
Once Aeon Nox added full support and the setup gets much easier it will become one of the most wanted add-ons. You should consider adding it to some popular repository.

I did not check the theme functionality yet, but I'm curious: does this add-on play the theme from the very beginning, or does it start a little bit into the song? I consider using the original songs for it, but we all know the interesting parts start after 10 or more seconds.
Maybe you could add something like this to the configuration:

Play theme music starting at X seconds.
Start at a random point. (you could write a little function finding a random point between 5% and 50% of the file so the playback would never really start at the very end of the song).

I'm sorry to ask you so much, but you made something awesome and I would really love to see it grow and become even better. If you ever need more ideas I'm always happy to help :-)
#47
(2013-03-09, 21:00)seeebek Wrote: Once Aeon Nox added full support and the setup gets much easier it will become one of the most wanted add-ons. You should consider adding it to some popular repository.

I did not check the theme functionality yet, but I'm curious: does this add-on play the theme from the very beginning, or does it start a little bit into the song? I consider using the original songs for it, but we all know the interesting parts start after 10 or more seconds.
Maybe you could add something like this to the configuration:

Play theme music starting at X seconds.
Start at a random point. (you could write a little function finding a random point between 5% and 50% of the file so the playback would never really start at the very end of the song).

I'm sorry to ask you so much, but you made something awesome and I would really love to see it grow and become even better. If you ever need more ideas I'm always happy to help :-)

The themes start from the beginning, but so far I've managed to get themes to play on any movie's info screen that I've added a theme.mp3 to Cool I suppose a fade could be added, but to be honest I'm happy just to have what we do already Big Grin
#48
I looked around and can't find any way to start audio playback from something other than the beginning of the song. It might exist, but I sure can't find it. Adding a fade should be possible.
#49
I'm assuming its related because this add-on is the only change I've made to my setup. Just done my first library scan since installing the add-on and have noticed some strange behaviour. It seems all the local trailers and extras are now visible to the scanner and any near matches are being added to my movie library Confused Is this something anyone else has noticed and brentosmith is there a possible fix?

Other than that it's great Big Grin
#50
Starting at a specific point is not possible, but there is a method for seeking:

Player().seekTime()
http://xbmc.sourceforge.net/python-docs/...r-seekTime

Maybe it is possible to move to a selected point just after the playback begins.

this might be also interesting:
getTotalTime(...)

I tried to make it myself for a test, but I seem to do something wrong. Even just unpacking the archive and repacking it breaks the addon. Using github helped me to make proper archive but my approach still didn't work.

(2013-03-10, 13:58)Deano316 Wrote: I'm assuming its related because this add-on is the only change I've made to my setup. Just done my first library scan since installing the add-on and have noticed some strange behaviour. It seems all the local trailers and extras are now visible to the scanner and any near matches are being added to my movie library Confused Is this something anyone else has noticed and brentosmith is there a possible fix?

Other than that it's great Big Grin

Did you add this to your advanced settings?
Code:
<video>
  <excludefromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludefromscan>
  <excludetvshowsfromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludetvshowsfromscan>
</video>

I scanned a few times and trailers and extras were always recognized properly.
#51
(2013-03-10, 14:05)seeebek Wrote: Starting at a specific point is not possible, but there is a method for seeking:

Player().seekTime()
http://xbmc.sourceforge.net/python-docs/...r-seekTime

Maybe it is possible to move to a selected point just after the playback begins.

this might be also interesting:
getTotalTime(...)

I tried to make it myself for a test, but I seem to do something wrong. Even just unpacking the archive and repacking it breaks the addon. Using github helped me to make proper archive but my approach still didn't work.

(2013-03-10, 13:58)Deano316 Wrote: I'm assuming its related because this add-on is the only change I've made to my setup. Just done my first library scan since installing the add-on and have noticed some strange behaviour. It seems all the local trailers and extras are now visible to the scanner and any near matches are being added to my movie library Confused Is this something anyone else has noticed and brentosmith is there a possible fix?

Other than that it's great Big Grin

Did you add this to your advanced settings?
Code:
<video>
  <excludefromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludefromscan>
  <excludetvshowsfromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludetvshowsfromscan>
</video>

I scanned a few times and trailers and extras were always recognized properly.

It may be that I did something incorrectly there, I'll go back and double check Wink
#52
(2013-03-10, 14:48)Deano316 Wrote:
(2013-03-10, 14:05)seeebek Wrote: Starting at a specific point is not possible, but there is a method for seeking:

Player().seekTime()
http://xbmc.sourceforge.net/python-docs/...r-seekTime

Maybe it is possible to move to a selected point just after the playback begins.

this might be also interesting:
getTotalTime(...)

I tried to make it myself for a test, but I seem to do something wrong. Even just unpacking the archive and repacking it breaks the addon. Using github helped me to make proper archive but my approach still didn't work.

(2013-03-10, 13:58)Deano316 Wrote: I'm assuming its related because this add-on is the only change I've made to my setup. Just done my first library scan since installing the add-on and have noticed some strange behaviour. It seems all the local trailers and extras are now visible to the scanner and any near matches are being added to my movie library Confused Is this something anyone else has noticed and brentosmith is there a possible fix?

Other than that it's great Big Grin

Did you add this to your advanced settings?
Code:
<video>
  <excludefromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludefromscan>
  <excludetvshowsfromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludetvshowsfromscan>
</video>

I scanned a few times and trailers and extras were always recognized properly.

It may be that I did something incorrectly there, I'll go back and double check Wink

I have the same problem using universal movie scanner.
#53
Had to create an advancedsettings.xml, added it to my userdata folder. Here's how it looks:

Code:
<advancedsettings>
<video>
  <excludefromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludefromscan>
  <excludetvshowsfromscan>
    <regexp>-extras-</regexp>
    <regexp>/Extras/</regexp>
  </excludetvshowsfromscan>
</video>
</advancedsettings>

What did I miss?
#54
The regexp part looks correct. A couple of things to try, my settings file has this as the very first line:
Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
That is a standard xml file header, I'm not sure if xbmc expects that to exist or not.
The other thing I noticed is that I had to reboot after adding the exclusions so the scanner could read that file again. Note that once the scanner has found them you'll have to manually remove them from your library (Context menu -> Remove from Library). Simply adding these exclusions after the fact will not remove them for you.

I've ran several library scans and haven't had this problem so hopefully one of those two things help you out.
#55
Version 1.1.0 has been released
This version contains support for random start points for theme music playback and multiple theme files support.

You can add multiple mp3 files to your movie directory just make sure they all start with theme. The script will randomly pick one of the songs to play. There is also a config option to select random start points for music. You can also specify manual start points for any given song like this:
theme[10].mp3 - Song will start playing at the 10 second mark

theme[10,152].mp3 - Song will start playing at either 10 seconds or 152 seconds

theme[10,152,random].mp3 - Song will start playing at either 10 seconds, 152 seconds, or a random location

If this format is used on a file it will override the global random start configuration for this specific file. If no start point is specified in the filename it will either start playback at the beginning or at a random place depending on your configuration.
#56
(2013-03-10, 21:49)brentosmith Wrote: Version 1.1.0 has been released
This version contains support for random start points for theme music playback and multiple theme files support.

You can add multiple mp3 files to your movie directory just make sure they all start with theme. The script will randomly pick one of the songs to play. There is also a config option to select random start points for music. You can also specify manual start points for any given song like this:
theme[10].mp3 - Song will start playing at the 10 second mark

theme[10,152].mp3 - Song will start playing at either 10 seconds or 152 seconds

theme[10,152,random].mp3 - Song will start playing at either 10 seconds, 152 seconds, or a random location

If this format is used on a file it will override the global random start configuration for this specific file. If no start point is specified in the filename it will either start playback at the beginning or at a random place depending on your configuration.

..........Outstanding Cool
#57
(2013-03-10, 21:37)brentosmith Wrote: The regexp part looks correct. A couple of things to try, my settings file has this as the very first line:
Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
That is a standard xml file header, I'm not sure if xbmc expects that to exist or not.
The other thing I noticed is that I had to reboot after adding the exclusions so the scanner could read that file again. Note that once the scanner has found them you'll have to manually remove them from your library (Context menu -> Remove from Library). Simply adding these exclusions after the fact will not remove them for you.

I've ran several library scans and haven't had this problem so hopefully one of those two things help you out.

Still no luck, I've removed the incorrectly scanned items and rebooted and rescanned but they keep appearing Confused One thing I've noticed as well is because of the naming convention I use for trailers (moviename-trailer), random movies trailers are also being scanned. The two that come immediately to mind are bad boys and transformers the movie. The thing is that without the add-on running the trailers are ignored just fine.

Could someone who has theirs running correctly be kind enough to post a copy of their advancedsettings.xml so I can eliminate that as a problem. Just want to get this issue out of the way nowConfused
#58
Deano316, I have the exact same issues as you i.e. random trailers being scanned (I also use the same naming convention moviename.bdrip-trailer.xyz). I removed the trailer a couple of times and then restarted XBMC but it came back dutifully every time I scanned. I thought it was just me so I deleted the trailer and moved on. If it helps the file name was 'tangled.brrip-trailer.mov'.

Also, I have gone through the three steps carefully i.e. Extras folder with files in no specific order, XBMC File Exclusions in Advancedsettings.xml, Skin Modifications in DialogVideoInfo.xml (though its in 1080i folder and my entire setup is 720p). I tried rebooting and restarting XBMC several times before scanning, even cleared my temp files, caches but haven't had any success. 'Extras' folders always get scanned regardless of what I do.

1. Is 'Extras' folder case-sensitive?
2. After modifying DialogVideoInfo.xml in 1080i folder of Aeon Nox [Frodo], the 'Extras' button shows up in the upper left corner and it remains inaccessible. Here is a screenshot:

Image


In any case, I want to thank brentosmith for this wonderful contribution.
#59
(2013-03-11, 21:32)MeggyChoo Wrote: Deano316, I have the exact same issues as you i.e. random trailers being scanned (I also use the same naming convention moviename.bdrip-trailer.xyz). I removed the trailer a couple of times and then restarted XBMC but it came back dutifully every time I scanned. I thought it was just me so I deleted the trailer and moved on. If it helps the file name was 'tangled.brrip-trailer.mov'.

Also, I have gone through the three steps carefully i.e. Extras folder with files in no specific order, XBMC File Exclusions in Advancedsettings.xml, Skin Modifications in DialogVideoInfo.xml (though its in 1080i folder and my entire setup is 720p). I tried rebooting and restarting XBMC several times before scanning, even cleared my temp files, caches but haven't had any success. 'Extras' folders always get scanned regardless of what I do.

1. Is 'Extras' folder case-sensitive?
2. After modifying DialogVideoInfo.xml in 1080i folder of Aeon Nox [Frodo], the 'Extras' button shows up in the upper right corner and it remains inaccessible. Here is a screenshot:

Image


In any case, I want to thank brentosmith for this wonderful contribution.

You might want to double check with regards to the extras button, it's supposed to sit alongside 'play', 'trailer' etc. Hopefully there's enough info here to help brentosmith troubleshoot with us.
#60
I have tried editing the DialogVideoInfo.xml in a couple of ways and Extras button still show up in the upper-left corner. I am assuming it has something to do with my 720p resolution and 1080i files I am editing but there are no 720p files for Aeon Nox or perhaps I am doing something wrong. I simply add the code at the end of the <control> group. Perhaps I should try to insert it between play and trailers.

Now the most disheartening thing is that since I upgraded to version 1.1 *all* my trailers got scanned and pushed to the library. I have a library of over 2,000 movies and close to 600 trailers got pushed to the library. SNAFU.

What is the best way to solve this problem? Delete all the trailers with a command prompt script and then clean the library? Is there any way to undo this scrap?
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 23
  •   



Logout Mark Read Team Forum Stats Members Help
Associate extras and/or alternative versions to a movie/TV show title8
This forum uses Lukasz Tkacz MyBB addons.