Larger font for Composite TV
#1
I thought I would share this as it took me a while to try and figure out how to do it and thought others might appreciate it. I view my apple tv (2nd gen) on a composite tv (through a converter box) but with the confluence stock fonts they are all very small and almost unreadable especially the movie descriptions. So I figured out how to do a tweak that enlarges the text.

What we are going to do it make a new font set that has a larger size than the default. You can switch to the new font in the appearance section of the XBMC settings, so if you don’t like it just switch back to default.

Before we start I want to make it clear that I am by no means a good programmer I just did a lot of googling and experimentation. Having said that I have done this simple tweak on several versions of xbmc and it always works for me. I have done it on both Eden and dharma. It does get lost when you update to a newer version of xbmc but it is a 5min job to reset it. If anyone can tell me a better way to do it that would be great.

I would exit out of XBMC. I don’t know if you need to but it makes sense to me not to mess with the settings whilst they are being used.

First you need to make a connection to the atv (I use WinSCP) and navigate to the Font.xml file and add some script into it. I find that file at /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/720p/font.xml. At this point I would make a safety copy of the file before you edit it. So copy it to the desktop unedited and edit the one on the ATV

At the end of the script insert the following lines just before the last line of the script (which should say </fonts>).

Code:
    <fontset id="Massive" idloc="31393" unicode="true">
    <!-- Normal Fonts -->
         <font>
            <name>font10</name>
            <filename>DejaVuSans.ttf</filename>
            <size>12</size>
        </font>
         <font>
            <name>font12</name>
            <filename>DejaVuSans.ttf</filename>
            <size>23</size>
        </font>
         <font>
            <name>font12caps</name>
            <filename>DefaultCaps.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font13</name>
            <filename>DejaVuSans.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font13caps</name>
            <filename>DefaultCaps.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font16caps</name>
            <filename>DefaultCaps.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font30</name>
            <filename>DejaVuSans.ttf</filename>
            <size>30</size>
        </font>
         <font>
            <name>fontContextMenu</name>
            <filename>DejaVuSans.ttf</filename>
            <size>25</size>
        </font>


    <!-- Title Fonts -->
         <font>
            <name>font10_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>12</size>
        </font>
         <font>
            <name>font12_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>16</size>
        </font>
         <font>
            <name>font13_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>20</size>
        </font>
         <font>
            <name>font24_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>24</size>
        </font>
         <font>
            <name>font28_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>28</size>
        </font>
         <font>
            <name>font30_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>30</size>
        </font>
         <font>
            <name>font35_title</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>35</size>
        </font>
         <font>
            <name>font50caps_title</name>
            <filename>DejaVuSans-Bold-Caps.ttf</filename>
            <size>43</size>
        </font>

         <font>
            <name>WeatherTemp</name>
            <filename>DejaVuSans-Bold.ttf</filename>
            <size>80</size>
        </font>
    </fontset>

When you have inserted the new lines and saved the file. Go back into XBMC and go to system > settings > appearance > fonts and change the blank selection (I wanted it to be called MASSIVE font but the name doesn't show up and I didn't really mind it worked). This should then have made all your fonts nice and large.

Hope this helps somebody not spend hours trying to figure it out themselves. Big Grin

UPDATE FOR FRODO & GOTHAM

Some of the coding is slightly different when you change from Eden v11 up to Frodo v12 & Gotham v13. So I thought I would update this post to reflect the changes as it has been quite popular.

First add the following block of code into "Font.xml"
(ATV location /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/720p/Font.xml)
(Win7 file location C:\Program Files (x86)\XBMC\addons\skin.confluence\720p\Font.xml)
(Raspbmc goto /home/pi/.xbmc-current/ then from that folder navigate to xbmc-bcm/xbmc-bin/share/xbmc/addons/skin.confluence/720p/Font.xml)
(Openelec has a read only file system so unfortunately this hack wont work)


Code:
########################################Custom MASSIVE Font
<fontset id="Massive" idloc="31393" unicode="true">
        <!-- Normal Fonts -->
        <font>
            <name>font10</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>14</size>
        </font>
        <font>
            <name>font12</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>23</size>
        </font>
        <font>
            <name>font13</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
        <font>
            <name>font14</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
        <font>
            <name>font16</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
        <font>
            <name>font30</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>30</size>
        </font>
        <font>
            <name>fontContextMenu</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>


        <!-- Title Fonts -->
        <font>
            <name>font10_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>12</size>
        </font>
        <font>
            <name>font12_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>17</size>
        </font>
        <font>
            <name>font13_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>20</size>
        </font>
        <font>
            <name>font24_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>24</size>
        </font>
        <font>
            <name>font28_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>28</size>
        </font>
        <font>
            <name>font30_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>30</size>
        </font>
        <font>
            <name>font35_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>35</size>
        </font>

        <font>
            <name>font_MainMenu</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>40</size>
        </font>
        <font>
            <name>WeatherTemp</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>80</size>
        </font>
    </fontset>
##########################################

Add the Name of the font set into the Strings.po file (Thanks to dizygotheca for helping with this part)
(ATV file location /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/language/English/Strings.po)
(Win7 file location C:\Program Files (x86)\XBMC\language\English\strings.po)
(Raspbmc goto /home/pi/.xbmc-current/ then from that folder navigate to xbmc-bcm/xbmc-bin/share/xbmc/addons/skin.confluence/language/English/Strings.po)
(Openelec has a read only file system so unfortunately this hack wont work)


Code:
########################################Custom MASSIVE Font
msgctxt "#31393"
msgid "Massive"
msgstr ""
################################

then select the "Massive" font from within XBMC (System > Settings > Appearance > Skin > Fonts)

and all your text will Bigger!
Reply
#2
Nice! I was looking for the same, then my old glass tube tv set burned up and I got a FHD Smile
Thanks for sharing this.
Reply
#3
So the last line will be " </fonts> " after we cut and paste this script?

Reply
#4
That's right
Reply
#5
Thank you very much for this!! I was looking for it! I tried it also in aother skins and is working almost perfect! Thank you very much!
Reply
#6
Thanks for posting this.

To fix the menu you also need to add the name to the skin's language file(s).

I added

<string id="31393">Massive</string>

to

/usr/share/xbmc/addons/skin.confluence/language/English/strings.xml


Reply
#7
Which of the "Fonts" control the size of the letters in the "Pictures" menu when viewing in "List" mode?
Thanks
Reply
#8
I don't really know. I just experimented and changed one at a time till the one I wanted changed, be warned though after you find the one you want check around the rest of XBMC the same fonts are used in several places so you might have increased the size of a piece of text you didn't want to or text no longer fits in the space allowed for it. It is a bit of a balancing act to get the sizes right.

I only know a couple of them that i wrote down when playing with sizes myself.....

font_50caps_title (is the large fonts on the home page (weather, Movies, TV Shows etc.)
font12 (is the smaller text on the home page (e.g. title, library, add-ons etc.)
font13 (is the font that the movies names are listed in when browsing movies)

Just have an experiment. and if you figure it out post it here. Good luck
lovin your work dizygotheca! I will try that out. thanks for contributing
Reply
#9
I just tried the fix for getting the name correct. it worked for me (Nice one dizygotheca :-) )but as I am on ATV (iOS) I couldn't find the directory structure you were talking about. So I added the line to this file and it works.

/private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/language/English/string.xml

I would love someone to tell me if there is a way of getting this mod to carry across XBMC updates. it is a pain having to do it each time I update. like some how getting it in the user data folder. I assume as confluence is the default skin, when XBMC updates the skin I have to mod it each time.

Any XBMC skinning geniuses out there?
Reply
#10
Do you know about this skin mod?

http://forum.xbmc.org/showthread.php?tid=129733&page=42

The writer has make a selectable "large font" choice that you don't loose in any update. It is a very nice mod and font! Have a look!
Reply
#11
Thank you very much for this! Confluence is just a little too difficult to read with most of the video views on a CRT, no matter how high the res; this has really fixed things and saved me a good few hours.
Reply
#12
I have a 40 in LCD screen TV and had trouble reading the fonts. Thank you for this. I wish more skins would include larger font sizes (at least the choice for one.) I stumbled on this thread by accident.

Quote:<string id="31393">Massive</string>
to
/usr/share/xbmc/addons/skin.confluence/language/English/strings.xml
Any idea what this would be on the newest version? I don't have this file (I have strings.po in the English folders.)
Reply
#13
Thank you for this as it was very useful on my old CRT!

To answer the last poster's question, to fix the menu with a newer version, you indeed need to modify the "strings.po" instead of "strings.xml" in the language of your choice by adding a block like this:

Code:
msgctxt "#31393"
msgid "Massive"
msgstr ""

It may be good practice to add it right after 31392 since the file is ordered but it seems to work fine even if added at the end of the file.
Reply
#14
UPDATE FOR FRODO

Some of the coding is slightly different when you change from Eden v11 up to Frodo v12. So I thought I would update this post to reflect the changes as it has been quite popular.

First add the following block of code into "Font.xml" (insert this code just above the last line of code, which will be "</fonts>")
(ATV location /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/720p/Font.xml)
(Win7 file location C:\Program Files (x86)\XBMC\addons\skin.confluence\720p\Font.xml)


Code:
########################################Custom MASSIVE Font
<fontset id="Massive" idloc="31393" unicode="true">
    <!-- Normal Fonts -->
         <font>
            <name>font10</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>14</size>
        </font>
         <font>
            <name>font12</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>23</size>
        </font>
         <font>
            <name>font13</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font14</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font16</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font30</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>30</size>
        </font>
         <font>
            <name>fontContextMenu</name>
            <filename>Roboto-Regular.ttf</filename>
            <size>25</size>
        </font>
    <!-- Title Fonts -->
         <font>
            <name>font10_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>12</size>
        </font>
         <font>
            <name>font12_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>25</size>
        </font>
         <font>
            <name>font13_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>20</size>
        </font>
         <font>
            <name>font24_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>24</size>
        </font>
         <font>
            <name>font28_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>28</size>
        </font>
         <font>
            <name>font30_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>30</size>
        </font>
         <font>
            <name>font35_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>35</size>
        </font>
         <font>
            <name>font45caps_title</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>45</size>
        </font>

         <font>
            <name>font_MainMenu</name>
            <filename>Roboto-Bold.ttf</filename>
            <style>uppercase</style>
            <size>40</size>
        </font>
         <font>
            <name>WeatherTemp</name>
            <filename>Roboto-Bold.ttf</filename>
            <size>80</size>
        </font>
    </fontset>

Add the Name of the font set into the Strings.po file (Thanks to dizygotheca for helping with this part)
(ATV file location /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/language/English/Strings.po)
(Win7 file location C:\Program Files (x86)\XBMC\language\English\strings.po)


Code:
########################################Custom MASSIVE Font
msgctxt "#31393"
msgid "Massive"
msgstr ""

then select the "Massive" font from within XBMC (System > Settings > Appearance > Skin > Fonts)

and all your text will Bigger!
Reply
#15
Hi there Smile

anyone knows what font i need to change to make the Font under file view list bigger? thanks

skin.confluence/720p/Font.xml)

but cant figure out what line the font is at Smile
Reply
 
Thread Rating:
  • 3 Vote(s) - 4.33 Average



Logout Mark Read Team Forum Stats Members Help
Larger font for Composite TV4.333