Linux MCE remote stopped working but I fixed it
I'm running XBMCbuntu Eden on an Acer Revo AR3610 with a Microsoft MCE remote with a USB IR receiver. It's been working fine for me for quite some time, but stopped working today all of a sudden.

When I enabled debug logging, I noticed that XBMC was receiving the button presses but was not responding to them for some reason.

After much googling (and trying a few things with no luck), I finally found a recent blog post that had the solution:

I was able to fix it more easily than the blogger, though; all I had to do was copy /usr/share/xbmc/system/Lircmap.xml to my XBMC userdata directory, then rename "mceusb" to "mceusb_hauppauge" and reboot.

It looks like lirc decided for some reason to start reporting my remote as having a different name ("mceusb_hauppauge" instead of "mceusb") and that XBMC didn't recognize that new name as something it knew what to do with.
Brilliant !

Thanks, this sorted it for me as well, would be good to know why the device name suddenly changes? or is it the config reverting back to mce all of a sudden?


this fixed my problem i have been looking everywhere my remote was working fine like it has been for years then it just stopped working i then went and tried the remote on 2 other XBMCbuntu machines still would not work i plugged it into a windows 7 machine and found it worked fine i then download a the lastest copy of XBMCbuntu and reinstalled still no luck i followed this and it works i am happy

Logout Mark Read Team Forum Stats Members Help
MCE remote stopped working but I fixed it1
This forum uses Lukasz Tkacz MyBB addons.