TVheadend 100% signal, XBMC: "no input detected"
#1
Hi,
there is a strange issue with live TV functionality. Although tvheadend has a full strength signal, I can't start a tv stream anymore.

Image

Screenshot from opdenkamp's Eden-pvr update 3:
Image

This is happening on OpenELEC box too.

EDIT: I enabled a debug log in tvheadend interface.
Quote:May 21 15:05:16 Transport: A867 USB DVB-T/CESKE RADIOKOMUNIKACE: 626,000 kHz/Prima COOL: Status changed to [Graceperiod expired]

It worked for a month without issues. Could someone tell me what can cause this behavior? Thank you!
My silent AMD Zacate HTPC on MSI E350IA-E45, [email protected]°C when idle, 27sec cold boot
Reply
#2
Cam isn't set up properly most likely
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#3
I agree with dushmaniac.
You probably ran out of your initial free months of viewing Wink

I think this thread must be closed now
Reply
#4
basco: It's free local DVB-T only. :-)

The issue seems to be in the DVB-T usb dongle itself. I plugged that off from USB port for a few hours, then reconnect and it worked again. After next 24 hours the same problem appeared and now I can't get it to work at all.

Please don't lock the thread yet, I'm going to do more research on this (will try another receiver) and post it here. It could be useful for future users...
My silent AMD Zacate HTPC on MSI E350IA-E45, [email protected]°C when idle, 27sec cold boot
Reply
#5
i can recall having these kind of issues in the past.
when you htpc has multiple usb ports it could be that it has an internal usb hub.
pleaseplug the dvb-t dongle in the 1st usb port that is not on the internal usb hub.
if you are using a linux system, check if the usb controller has shared interrupts with other devices in your system.
if so, put the usb controller on a seperate irq.
Reply
#6
I have the same issues with my dongle, running on Ubuntu. It may be a dumb question, but could you help me with the commands that I need to use in order to determine the right irq?
Reply
#7
your log says: "Graceperiod expired".
this probably means that your grace period has expired.
Reply
#8
I had this problem when the option is activated to check signal strength in tvheadend. I then also couldn't open any stream ...

Try this perhaps..
Reply
#9
Have the same issue today, getting no input detected for my usb dvb-t tuner (fta channels). No errors regarding this tuner when i check dmesg either.

edit: ignore, stupid me, someone had plugged out aerial splitter unit so wasnt getting any power.
Reply
#10
I have the same error the last one and a half year.

I'm using the TBS6981 PCIe Tuner Card. DVB-S FreeToAir and i got a 100% signal.

My OS is Ubuntu 11.10 and i used different repo version of tvheadend and therefore the stable 2.1/3.0 build.

Still i'm not using the pvr-addon, i'm using the htsp protocol with driect links via the favorites to watch tv.

The tuner card is hooked up to a 5/8 multiplexer.

I have no erros when i check dmesg.

Can you give me any clou whats going wrong?

Thanks in advance.

regnets


Reply
#11
I bought DVB-S tuner, but still not have sat antenna wire fed to the computer Angel

It's time to try my DVB-T config again (with new tvheadend and new xbmc :-) ) and post my experience here.
My silent AMD Zacate HTPC on MSI E350IA-E45, [email protected]°C when idle, 27sec cold boot
Reply
#12
The graceperiod printout is an internal TVH statement, it simply means TVH did not receive any program data within a certain period (the grace period) and therefore timeout the subscription. It has nothing to do with any contracts you might have etc.. for scrambled content.

I've also had some issues with the signal monitoring stuff, though it seems to be working for me now. However if it does cause problems simply disable it, in 3.2 it should be properly honoured (older versions did not properly honour the settings and so may still have checked quality metric).

Note: I'm using the same TBS card.

Adam
Reply
#13
Hi everybody,

I am facing the same problem with Tv Headend running on my dedicated HTPC:
  • Zotac HD41Plus
  • Ubuntu 12.04LTS
  • Xbmc from Pulse-Eight

When I first plug the USB avermedia A850 black, everything works fine.
But after a stop and restart of XBMC, I got the following message "no input detected".

Everything seems to work properly, on Tv Headend, all quality signal are 100%, and the dongle is well recognized by Ubuntu (lsusb command lists it correctly).

I have to unplug the dongle and replug it in another USB port, for it to work again, and then again after each restart.

I spent hours in different forum, and everything that I found were not really adapted are usefull.

Does anyone help me ?

Thanks in advance for your help

Sebion
Reply
#14
i have the same problem. when i restart the tvheadend service though it works. it is a nuisance because i have to restart the service everytime i reboot my box and wanna watch tv.
Reply
#15
I have seen this myself, it seems to be transient. For the most part it doesn't seem to work after the tuner has been running for quite a while, i.e. it only happens when I first start TVH (and thus enable the tuner). And its completely random, sometimes it never happens at all and others it happens once or twice and then goes away.

I don't believe the fault is with TVH, however it is something I will try and investigate when time permits. I think its more likely to be issues with firmware.

For anyone using the latest version of TVH with option to close all FDs, if you have this ticked try unticking it. This option cripples one of the tuners on my own TBS6981. I believe there is some very odd firmware bug that causes this.

Adam
Reply



Logout Mark Read Team Forum Stats Members Help
TVheadend 100% signal, XBMC: "no input detected"0
This forum uses Lukasz Tkacz MyBB addons.