Linux No Audio w. default install of XBMCbuntu v11.0 on Zotac ZBOX-ID80-U Hardware
#1
Hi all,

Greetings! I'm a first-time XBMC Linux user.
I'm pretty well versed in working with and troubleshooting stuff in the PC world, but I've NEVER really used Linux before.

At the moment, I'm having some trouble with getting any sound to work on a default install of XBMCbuntu v11.0 on Zotac ZBOX-ID80-U Hardware

==

Setup / Specs:

Software:
> XBMCbuntu v11.0
Download as linked here: http://mirrors.xbmc.org/releases/XBMCbun...u-11.0.iso

Hardware:
> Zotac ZBOX-ID80-U (Full specs: http://www.newegg.com/Product/Product.as...6856173034)
> 32GB SSD for the OS
> 2GB RAM

==

Goals:

I'm hoping to be able to get:
- All AV playback via HDMI
- HD Audio with 7.1 Dolby TrueHD and DTS-HD/Master Audio as well

==

What I've tried:

Using the default install, video works fine and I'm able to get video playback, but there's no audio whatsoever. I've tried varying these settings under "Audio Output Device":

No sound:
HDMI (Alsa), iec958 (Alsa), Defaults (Alsa)

These settings will bring up an audio error prompt:
HDA nVidia HDMI 3/ iec958 / default (All Alsa)
HDA Intel HDMI 1 / iec958 / default (All Alsa)
HDA Intel HDMI 0 / iec958 / default (All Alsa)

==

I get the feeling that perhaps I should be installing Ubuntu first, add the proper drivers, and then adding into XBMC?

Any help is greatly appreciated - thanks!
Reply
#2
Quote:- HD Audio with 7.1 Dolby TrueHD and DTS-HD/Master Audio as well

You must have an Audio Engine build. I suggest you using: https://launchpad.net/~wsnipex/+archive/xbmc-xvba

This is a special repository with xvba and vdpau support done by Fernetmenta. It improves player buffering and gets the most out of your vdpau card. Audio Engine also is included. To playback those formats, you have to use HDMI out.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
Firstly: You've got the right computer. Everything's well-supported and in fact ideal there.

Secondly, The DTS-HD/MA and TrueHD passthrough should work for an AudioEngine build, via HDMI, as fritsch says. It doesn't for me, but further checking revealed my combined bluray/av-receiver system only supports those formats on the internal blu-ray player, not on external inputs. Yeah, I was disgusted too. So I have to take the fact those work on AE on trust. Apparently it does though.

XBMCBuntu should probably be considered an appliance - as such if it doesn't work for you the way you want out of the box, rather than fiddle and fiddle and fiddle with it, it probably is best to install a full OS, where subsequent tweaking and upgrades are part of its normal function, rather than a dirty hack.

So:

Install Ubuntu (or one of its variants to taste; eg: Lubuntu for a minimal desktop) 12.04

Make sure all that's working. :-)

Add the following PPAs:

https://launchpad.net/~ubuntu-x-swat/+ar...x-updates/
https://launchpad.net/~wsnipex/+archive/xbmc-xvba

The pages have instructions but you can just open a terminal after initial install and type thusly:

Code:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo add-apt-repository ppa:wsnipex/xbmc-xvba
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings xbmc

This will install the latest nVidia drivers, version 302.17, and a development branch of XBMC. Despite its name and description, which purports to be all about AMD/ATI XVBA support, this branch also has improved support for VDPAU, the GPU-assisted video decoding facilities on the nVidia GPU in your box.

And the new version of XBMC also has AudioEngine support, which seems to be much easier for getting audio working. :-) As in, I have the same GPU as in the Zotac ID80 and on XBMC Eden I had the same problems you have with audio, but with AudioEngine it all pretty much Just Worked.

Once all that's installed, reboot, log into the desktop (ubuntu desktop/lubuntu desktop whatever you picked), while connected by HDMI to the TV and open the nvidia-settings application. You should be able to see in there references to the display name, which will be something like: "Panasonic-TV (DFP-1)". Your exact value will almost certainly vary. The important thing you need is: is it DFP-1 or DFP-0?

Download this xorg.conf: http://xbmclogs.com/show.php?id=6030

And copy it into /etc/X11/xorg.conf, ie, in one go:

Code:
sudo wget -O /etc/X11/xorg.conf 'http://xbmclogs.com/show.php?id=6030&mode=raw'

(This will overwrite your xorg.conf file if you have one. if you've just freshly installed ubuntu, you don't. Oh, and the single-quotes around the URL are important, otherwise the Linux shell does funky stuff because of the & that's in there!)

If that DFP-n value you found earlier is DFP-0, that's it; otherwise you need to change it:

Edit that file:

Code:
sudo nano -w /etc/X11/xorg.conf

(Or your choice of editor, but if you're used to windows and new to linux, you may find nano more comfortable for now)

Change each occurrence of DFP-0 to whatever your TV is. It'll almost certainly be either DFP-1 or DFP-0.

Save and exit.

Reboot. (May not technically be necessary but let's settle it in.) and at the login screen, select XBMC from the menu button to the right of your username and log in. XBMC should launch in standalone mode, which is what you want for proper TV use.

(Certain people, when faced with any audio issues on ubuntu will advise you to deinstall pulseaudio from your system. In my experience it's not necessary - particularly when logging in standalone line this, as pulseaudio is not invoked anyway.)

In XBMC, configure as appropriate. :-) In particular, allow it to change refresh rate to match video. (the xorg.conf file supplied makes sure it will do so to exactly the 23.976Hz required by most movies.) For audio, you probably want something like this:

Image

Differences for you:

Select 7.1 output. (Untested by me, I only have 5.1)

Assuming your AV receiver can definitely handle them, unlike mine, check the TrueHD and DTS-HD capable receiver options. Also AAC, which you might as well have if your AV can do it.

The audio output device to select for both normal and passthrough is probably the one you have that looks most like mine. The part that's likely to be different is where mine says "MEI Panasonic TV" yours will probably identify your TV. Look for "HDA NVidia," (your TV ID) "on HDMI".

You may also have better luck with GUI sounds than I do. Those work perfectly if I select "output stereo to all speakers" but then, unsurprisingly, tracks with stereo are output to all speakers, which is probably not what you want for stereo sources.

Then it should work. The above pretty much gets me to a very nearly perfect setup.

(edit: using fernetmenta's xorg.conf instead, has 23.976 *and* 24-exact modelines)
Reply
#4
Thanks Rachel, I have followed your instructions for my Zotac and I think it is working fine. I am scanning media as I type this, I had terrible trouble with this Zotac on a full blown version of Ubuntu 12.04 so hopefully this is better.

My only issue is when going into the xbmcbuntu dekstop. The screen is cut off, on the full blown version of ubuntu i could go into the nvidia settings and adjust the overscan. However, following your guide leads to the overscan option getting removed for some reason. So on my tv I can only see half of the taskbar. This is easily fixed in XBMC using calibration but if I ever want to use xbmcbuntu desktop its a pain. Do you know anyway around this? Thank you.
Reply
#5
hm, i haven't experienced any overscan issues at all, so no, I don't have anything to add I'm afraid. This may be a TV-specific issue.

Having a look at my TV, there's an option in *its* settings to turn overscan off, which I've set. I probably did that years ago, having been doing this for some time, so I'd forgotten about it. Could try that; but then you'll have to undo your xbmc calibration.

Actually thinking about it, that's probably why SD transmissions (and recordings) tend to show thin black bars on the sides on tv as well as through xbmc... Well, probably; explains it but not going to change it.
Reply
#6
Rachel, I also have the id-80. installed xbmc standalone over 12.04 server. Follwed your instructions here, but i see "error - no devices found" in device and passthrough. any thoughts on that one? Sorry to hijack, can't find this info anywhere else.
Reply
#7
no devices at all? wow.

Um, offhand first thing I can think of is, you installed over "server"; is alsa installed? Also, the server kernel image may not have the alsa modules. in other words; the platform's too minimal. My instructions did start with an ubuntu or lubuntu desktop install. :-)

And it looks like the xbmc package doesn't insist on these things in its own dependencies.

Try apt-get install alsa-base linux-image-generic; reboot, see if we get any further. Or go whole-hog and install lubuntu-desktop (well, mini-hog). (how, btw, are you launching xbmc? Because the easiest way is to log in from the lightdm login screen having selected the XBMC session; and to set that as the default behaviour; all of which can be done without hacking config files :-)
Reply
#8
I have startx in my .bashrc and set user xbmc to login at boot. I'm not home.right now but will try alsa later. I think that may be the issue but I swore it was installed already. We'll see. Thanks for the help.
Reply
#9
ok, so i installed asla and now am faced with a screen saying " XBMC needs hardware accelerated OpenGL rendering. Install an appropriate driver......any thoughts. I was booting into XBMC no problem before this
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
No Audio w. default install of XBMCbuntu v11.0 on Zotac ZBOX-ID80-U Hardware00