Thread Rating:
  • 0 Vote(s) - 0 Average
Windows - Annoying monitor switching, can this be stopped?
#1
Hey guys, I'm curious to know if it's possible to lock XBMC onto a specific monitor. My machine that runs XBMC is in a room off to the side of my media room, where the tv is. The tv is hooked up to the computer through my HTR and uses the second monitor. The problem is, if anyone turns the tv or htr off in the other room, XBMC puts itself back on my monitor in this room. The next time I launch it, I have to go back into system -> video and tell it to display on the other monitor again.

Is there a way perhaps to just specify the monitor that it shows on and have it stay there permenantly even when the monitor is switched off? I wouldn't mind having to edit a file to get it back on this screen should something go wrong with the tv or whatever.

Thanks in advance.
Reply
#2
make your guisettings.xml readonly once you have the wanted setup.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#3
This might work, but I'm not entirely sure. It should have the same effect as what Memphiz suggested above, but would only lock the screen selection:

place this an an advancedsettings.xml (wiki) file in the userdata (wiki) folder:

Code:
<advancedsettings>
    <videoscreen>
        <screen>1</screen>
    </videoscreen>
</advancedsettings>

and I think:
0 = first screen
1 = second screen
2 = third screen
etc
Reply
#4
(2012-08-10, 11:07)Memphiz Wrote: make your guisettings.xml readonly once you have the wanted setup.
Ahh! I was hoping this wasn't the answer, I like to tinker with it sometimes.

(2012-08-10, 12:58)Ned Scott Wrote: This might work, but I'm not entirely sure. It should have the same effect as what Memphiz suggested above, but would only lock the screen selection:

place this an an advancedsettings.xml (wiki) file in the userdata (wiki) folder:

Code:
<advancedsettings>
    <videoscreen>
        <screen>1</screen>
    </videoscreen>
</advancedsettings>

and I think:
0 = first screen
1 = second screen
2 = third screen
etc

This works! I think a little while ago I went digging around through the wiki to see if this setting existed and couldn't find it. Thanks very much for pointing it out.

Now, let's see what else I can mess with in advancedsettings *grubs hands*

Reply
#5
(2012-08-10, 13:12)DoctorDyna Wrote: This works! I think a little while ago I went digging around through the wiki to see if this setting existed and couldn't find it. Thanks very much for pointing it out.

Now, let's see what else I can mess with in advancedsettings *grubs hands*

Awesome. Basically, in addition to what's listed on the wiki page (advancedsettings.xml (wiki)), you can also add things from guisettings.xml that you want to force on.

Glad to hear it worked out.
Reply
#6
I have a very similar situation, but its just different enough that neither solution will work. my secondary display is routed through my home theater receiver, so i can switch between pc, cable, and my other devices. when i switch to cable, then back to pc, while things try to sinc up, xbmc switches back to the computer monitor.

while i had the advancedsettings.xml setup, that option was removed from the "settings/system/video" page in xbmc, but xbmc would not use the second monitor. The resolution option was set at the default low res, when i adjust that, xbmc seams to take the forced config, and move to the desired monitor.

making guisettings.xml read only did not fix the problem either.

additional info: i use a sony tv, an onkyo home theater reciever, and i'm running windows 7 ultimate. the pc has a nvidia geforce 9800 gtx+. The video card does not have hdmi out, so i use a dvi-to-hdmi adapter. the monitor uses dvi-to-vga.
Reply
#7
Similar setup and problem here. What is desperately needed to solve this is a keyboard shortcut or a button on the main screen bound to a "Switch Monitor" command. On computers with dual monitors and possibly a Digital receiver in the middle, Windows will keep enabling and disabling outputs depending on wether a device is switched on or off, making it hard to put XBMC on a specific monitor by default.
Reply
#8
Hoping to bring this old post up!

I also have a problem with switching monitors..
I have a HDMI cablefrom my pc to my TV and a monitor on mijn pc.
When i start XBMC and the tv is off, it will automaticly go to my pc.. Well ofc it is a "normal thing" but i want that XBMC always shows on my tv.
I have tryed the solution up here.. but it diddn't work!

I hope there is something for this!

Pasibun
Reply
#9
bumb!
Reply
#10
Given that you found this thread, I'm sure you searched.... But I don't know why you didn't see the other threads which cover / answer this?

Anyways, the easiest way to do this is to cover pin 19 of the HDMI cable.

http://social.technet.microsoft.com/Foru...file/71953
http://s4.postimage.org/gmog0m7kf/HDMI_B...Pin_19.jpg

Read more about it here:
http://social.technet.microsoft.com/Foru...c80a21fdc2
Reply
#11
From my GTX970, running through a Sony STR-DH750 into a 3D supported HDMI splitter to my daily BenQ 55" 1080p and my movie Optoma HD26 3D 1080p. Kodi always drops back to Fullscreen 1 but if you wait it goes back to 2... until you stop the media, then it drops to 1 and doesn't let you select #2 again. I'm happy to say this fix worked, just restart Kodi or boot up after turning on the projector, works 100% everytime.

@edrikk: The other threads didn't give this piece of code... and a tiny bit of code is FAR easier than covering HDMI pin-19! Took me less than a minute. Also, I'm not jamming tape into any part of my expensive system, let other ppl try that, lol!!!

EDIT: I'm happy restarting Kodi, although for some people they may not want to, and I admit that the pin-19 workaround would likely fix the root of the problem. Too bad there's not a software switch in Windows/Nvidia/AMD drivers though, sigh. Thanks everyone for your help!
Win10 i7-2600k+Msi Gtx970 (Krypton 17.3+Titan)> Hdmi> Sony STR-DH750 7.2ch 1015W DTS-MA/TrueHD AVR> Hdmi3D/4K splitter> 1>BenQ 55RV6600(55"1080p) 2>Optoma HD26(3200 [email protected]) +100" Optoartist pulldown screen
Reply
#12
Somebody broke their time machine...
Reply
#13
(2017-07-17, 00:40)HeresJohnny Wrote: Somebody broke their time machine...
It's still a relevant topic, even as you noted this thread is dredged up from aeons ago. The last post has added his experience to the other options offered in this thread and may be pertinent to some one's issue.
Reply
#14
Cheers for the support. It can be hard to sort HDMI handshake issues and this is the first time I stumbled across a workaround in the 2 years I've been fiddling with Kodi. I didn't know I should be looking to code for a fix. Is there a place that documents stuff like this? I imagine it'd be super helpful if it was more prominent or easier to find. (And yes, I realize I necroed the thread, my bad)
Win10 i7-2600k+Msi Gtx970 (Krypton 17.3+Titan)> Hdmi> Sony STR-DH750 7.2ch 1015W DTS-MA/TrueHD AVR> Hdmi3D/4K splitter> 1>BenQ 55RV6600(55"1080p) 2>Optoma HD26(3200 [email protected]) +100" Optoartist pulldown screen
Reply
#15
You've probably found this thread in your travels, but just in case https://forum.kodi.tv/showthread.php?tid=158432 Basically we're looking at High-bandwidth Digital Content Protection and its handshake loss. https://en.wikipedia.org/wiki/High-bandw...Protection and this issue will be ongoing, any additional information is always appreciated.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Annoying monitor switching, can this be stopped?00