Solved Loss of HDMI when TV is powered off
#1
Hello all, having a problem that I know others posted about here, but I can't find the thread.

Problem:
I want to leave my HTPC and XBMC running 24/7 and power down my TV everyday. After powering down, leaving the TV off overnight and normally while at work the following day, I power on the TV, XBMC is still running but has been shrunk down to small box of about 800x600. It is not a window, there is no windows border. It functions but I can't get it to return to full screen without shutting XBMC down and restarting. I assume this has something to do with the loss of connection between the HTPC and it's monitor. It is an HDMI connection between the two. I have left the TV on overnight (waking up on the couch the next morning) to find the screen saver running on XBMC and it's still full screen. So again, I am assuming it has something to do with the monitor/TV being powered down and XBMC or the AMD drivers are doing something to try and compensate for the unknown resolution and lack of connection.

I want to say the thread I kind of followed a year ago had a script that would prevent this from happening. Can anyone point me to that thread or give me a method to prevent this from happening. I just started using WatchDog and it was awesome to return home yesterday and all the new files I had dropped onto the server showed up in the library without an update. But It was a bit of a downer to have to restart XBMC to use it full screen.

Thanks!!
Reply
#2
I just thought of a few other details that may help or be important.

When i turn the TV on and xbmc is 1/4 screen, the windows desktop is behind it running full screen 1920x1080. So only xbmc is affected, windows seems to be ok with the TV being off for several hours.

My HTPC is not in sleep mode or hibernate. I have disabled both of those, and no other power saving features are enabled as best I can remember.
Reply
#3
Just wondering what size XBMC is when you hit the 'slash key' for windowed mode..? I suspect that some service or something PC is taking XBMC out of full screen mode and into windowed mode which remembers your last windowed size... To check this, hit the slash key and see if it's a quarter size. If this proves out,

<advancedsettings>
<fullscreen>true</fullscreen>
</advancedsettings>

Will give you the size... then it's a matter of tracking down what is causing this. I'd hate to think this might anything to do with HDCP handshaking.
Reply
#4
Thanks Pat, I will check it when I get home and report back. However, I seem to remember a thread about it being a handshaking issue. I have been searching HDMI, I will try a new search for HDCP and see if I can find that thread. It was a hot topic around the time Darhma went to Eden.


Thanks again.
Reply
#5
Ok, the \ does in fact still toggle xbmc from windowed to full screen, but the windowed mode it is in AFTER hitting the \ is not the same as when I first power on the TV. And tonight the behavior was different.

Here is what happened tonight. Power on the TV, Windows 8 desktop opens with XBMC over to the top left corner of the screen. However, tonight the size of the XBMC screen was very different that it has been in the past. I am guessing it was 240 pixels wide by 8-900 pixels tall. I have never seen it at that size before. Hitting the \ key centered a true Windowed XBMC in the center of the desktop with the typical windows boarder with minimize, maximize and close buttons on the top left. \ again goes to true full screen no windows boarder (what I want). So I have 3 distinctly different states that XBMC is in during the first 3 presses of \.

1. Normally a box about 800x600 in size but tonight much thinner and a bit taller probably 240x850
2. A typical Windows application window. Go to settings to check size and I can't read the resolution setting it is too small.
3. Typical full screen no boarder.

On the 4th press I toggle between 2 and 3 above, it never returns to the bizarre boarderless top left corner box.

Going to drop those settings into advancedsettings and see what happens. Won't be able to test till tomorrow evening and have no idea how long the TV must be off before this happens again. I did find a thread at work about this, only 2 posts long, same exact issue, no resolution and both posts came from people using AMD onboard video. I know one of them if not both had APU's like my A8. I will try to find that and post the link.

Again thanks for the help and it maybe an AMD thing.
Reply
#6
It has to do with what your PC does when it doesnt have a monitor connected to it.
It happend to me last year.

Essentially your PC will default to 800x600 when a monitor is disconnected. XBMC will shrink to fit that. When you plug your monitor back in the PC res will default back to 1920x1080 (or whatever) but XBMC will stay at that smaller res and sit up in the top left (atleast thats what mine did).

Make sure you have Full Screen enabled and the resolution set to 1920x1080 in the video output (http://wiki.xbmc.org/index.php?title=Settings/System)
Reply
#7
Gazzyb,

Thanks for the input and that is kind of what I thought. I think AMD when unable to detect a monitor sets itself to a safe resolution as you point out of 800x600. The video output settings are already at full screen and 1920*1080, but I don't know how to get the AMD drivers to stop it's little safety feature. I will search some more. Seems there is a thread about this at AVS but the utility to create a new monitor.inf (their proposed solution) doesn't play nicely with windows 8.

I did drop the line <fullscreen>true</fullscreen> in the adv.xml file as suggested above. For giggles i will search LG for a windows inf file, but I highly doubt I will find one.
Reply
#8
I also just tried this setting change

http://www.overclock.net/t/1235582/deali...autodetect


I will let this rest for now and report back what happens tomorrow night.
Reply
#9
You probably need this- Gefen HDmi Detective Plus.....
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
#10
You need to block pin 19 on your HDMI cable...
See here:
http://social.technet.microsoft.com/Foru...c80a21fdc2

Here's a pic from that forum post:
Image
Reply
#11
I had this happen before I started booting into a shell. What I discovered was XBMC would still work and when I played a movie or TV show it refreshed and fixed itself.
XBMC specs: MINIX U9-H LibreELEC 4K all day

Home Theater - Samsung 65KS8000 - Denon 3200- Ascend Acoustics speakers - Maelstrom 18in sealed sub 7cu ft - Behringer EP2500

UNraid Server – Pentium G3258 – MSI - H81M-P33 – Antec HCG-400M PS - 8Gb RAM
Reply
#12
(2013-03-06, 15:54)bluray Wrote: You probably need this- Gefen HDmi Detective Plus.....

bluray,

Thanks and oddly enough I saw another post where you suggested this during my search. Cool device and I think you are exactly correct that it would solve my issue, but I am looking to do it a bit cheaper. Not sure the benefit is worth the $90 at this point. But thanks for the suggestion. I might jump on this one day if I can't fix it via software or some other means like Tape Smile


(2013-03-06, 20:21)edrikk Wrote: You need to block pin 19 on your HDMI cable...
See here:
http://social.technet.microsoft.com/Foru...c80a21fdc2

edrikk,

I saw that suggestion in the overclockers.net discussion as well. I need to pull my TV off the wall to route some new cables. The HDMI cables I used were just a bit short and I have longer ones to run through the wall. If I get home this evening and find the same results as before, I will certainly give this a try. It fits the cheap and easy solution I am looking for. Would love to fix this via software, but some tape I can deal with.

Thanks again to everyone making suggestions and offering help. I will update later this evening once I find out the state of xbmc tonight.

(2013-03-06, 22:31)joe_sun Wrote: I had this happen before I started booting into a shell. What I discovered was XBMC would still work and when I played a movie or TV show it refreshed and fixed itself.

Mine is so small I can't really navigate through it in the scrunched up state. It is just a few quick button presses to restart xbmc, luckily I don't have to reboot the htpc or anything like that.
Reply
#13
Sorry, haven't had a chance to update this yet, but last night pretty much the same as the night before. What is really odd is since I posted about this looking for help, the size of the scrunched up XBMC on the desktop has changed. Like I mentioned before, it was once about the size of a window at 800x600, the past 2 nights it has been much more narrow and taller, guessing 200 x 900. When I turn off the TV, I hear windows chime indicating it has lost signal, but xbmc doesn't shrink down immediately. Not sure what it is that causes this shrinkage. Think I need to get some viagra for xbmc Smile If I get time this weekend I will try the tape over the pin trick. If that doesn't work I think I will just live with it. Restarting XBMC is actually quicker than waiting for the db update to complete. Seems WatchDog is working and updating the new files I drop on the server each day.


Thanks for all the advice folks! Will update later if I find out anything.
Reply
#14
Did you try the blocking the pin on the HDMI cable
I too have the same issue

I did try to use a script to force the resolution back but it didn't work

It isn't an xbmc issue as I had the same problem when using plex.

I'm going to try the pin blocking when I have some time over the weekend.

N

The 19th pin block method looks like the one for me this weekend.
Reply
#15
This is a known problem, which happened to me also when I used MediaPortal. A number of possible fixes have been posted, here are a few links:

using VNC:
http://forum.team-mediaportal.com/thread...ost-893486
http://forum.team-mediaportal.com/thread...ost-952339

or using a registry hack:
http://forum.team-mediaportal.com/thread...ost-728795

At the time I used the first link and it worked for me. I recently reinstalled Win7, and now have the issue again. Have not yet taken the time to fix this, so please post which option worked for you (if any), so that I can fix mine as well.
Reply
 
Thread Rating:
  • 2 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
Loss of HDMI when TV is powered off4.52
This forum uses Lukasz Tkacz MyBB addons.