XBMC not reading .avi format (Solved)
#1
I have XBMCbuntu set up on an Asrock ios and stream media content from my QNAP NAS. But XBMC can only see the .mkv files and not the .avi files. If it's a folder with only .avi files in it the folder simply does not show up in the menu in XBMC.

The hard drive which holds all the media files is formatted in EXT4. Would that have anything to say? I've tried googling for EXT4 and .avi but can't seem to find any info on it.
Reply
#2
Is your folder with the avi files defined as a media source to XBMC?
Reply
#3
(2012-08-30, 11:48)artrafael Wrote: Is your folder with the avi files defined as a media source to XBMC?

Think so - it's a subfolder to a folder called TV which shows up.

Reply
#4
Are your mkv files also in their own subfolder under the TV folder?

Also, verify the permissions of the avi folder and also of the individual avi files to be sure they have at least read access across the board.
Reply
#5
What protocol are you using to share the files? UPnP? SMB? NFS?
Reply
#6
(2012-08-30, 12:27)artrafael Wrote: Are your mkv files also in their own subfolder under the TV folder?

Also, verify the permissions of the avi folder and also of the individual avi files to be sure they have at least read access across the board.

They have read permission.

The mkv files are also in their own subfolder in the TV folder. I purchased the series Rome on DVD and copied it via Handbrake. Season 1 was copied in avi format and season 2 in mkv format. Both seasons are in a sub folder in the TV folder, but only season 2 is visible. I can see both seasons in a regular file manager.


(2012-08-30, 12:30)Ned Scott Wrote: What protocol are you using to share the files? UPnP? SMB? NFS?

UPnP

Reply
#7
I'm guessing it's a UPnP issue. UPnP servers can be file type sensitive. See if you have the option to enable SMB (Windows Sharing) which should work on any XBMC installation.
Reply
#8
Followed the instructions in this video and that fixed the issue.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC not reading .avi format (Solved)00