Thread Rating:
  • 0 Vote(s) - 0 Average
Linux - Configure time error while cross compiling xbmx
#1
Hi All,

I'm trying to cross compile xbmc-11.1 for TARGET_ARCH= "i586" TARGET_OS= "linux" MACHINE= "fishriver", my host architecture is x86, OS=linux-10.10.

I ran configure file with following option:

xbmc/configure --build=i686-linux --host=i586-poky-linux --target=i586-poky-linux --prefix=/usr --exec_prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/libexec --datadir=/usr/share --sysconfdir=/etc --sharedstatedir=/com --localstatedir=/var --libdir=/usr/lib --includedir=/usr/include --oldincludedir=/usr/include --infodir=/usr/share/info --mandir=/usr/share/man --with-libtool-sysroot=/home/sct/my_workspace/poky_xbmc_09Mar2012/build/tmp/sysroots/fishriver --enable-nls --enable-optimizations --disable-debug --disable-vaapi --enable-external-ffmpeg --enable-dvdcss

The error what I got is:

checking ffmpeg/rgb2rgb.h usability... yes
| checking ffmpeg/rgb2rgb.h presence... yes
| checking for ffmpeg/rgb2rgb.h... yes
| checking for AVFilterBufferRefVideoProps.sample_aspect_ratio... yes
| configure: == Use of external ffmpeg enabled. ==
| configure: error: in `/home/sct/my_workspace/poky_xbmc_09Mar2012/build/tmp/work/atom-poky-linux/xbmc-11.1-r0/xbmc':
| configure: error: cannot run test program while cross compiling
| See `config.log' for more details.
| FATAL: oe_runconf failed


I'm unable to find the cause of error. Please help me to resolve the error.
Reply
#2
generally cross-compile is more difficult than just setting configure options. you also have to deal with all of xbmc's depends and you cannot leak out to the build side. see tools/depends, we typically handle cross there but no one has setup a general linux cross and I can't see enough of what you are doing.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply



Configure time error while cross compiling xbmx00