XBMC + 3D = Crosstalk / Ghosting ? SOLUTION HERE!
#1
So, I've been wondering for a while now why SBS or OU (TAB) 3D MKV movies that I have just don't look very good on my 51" Samsung D550 lately.

In fact, some movies were so bad that they were unwatchable.

The thing is, some of those really bad movies were watched on this SAME TV by me previously, via my old Mede8er, and they were literally perfect.

Now suddenly, via XBMC, on a dedicated HTPC, they are horrible ?

I started doing some research and I found the problem: Overscan / Underscan

So on my system, I had to actually do THREE things to sort this out properly:

1. I logged into uBuntu itself, went to the Catalyst control center for my ATI card, and checked the Overscan / Underscan setting. It was set to 10 and needs to be at 0 ! So I changed that.

But, if you change that on my setup, you are basically overscanning a LOT. To the extent that the entire Linux task bar dissapears off the bottom of the screen.

Regardless, I left it at 0 and went back into XBMC.


2. In XBMC itself, in the System menu, under Video Options, there is a "Video Calibration" option where you can move the top left and bottom right corner markers to make the picture fit on the screen properly.

Any normal person assumes this is the right thing to do and does this. WARNING: If you are going to watch 3D content as well as 2D content DO NOT DO THIS.

This is actually another way of adjusting Overscan and Underscan. You MUST have all co-ordinates set to 0 here too in order for 3D to work properly.


So after that, I had an XBMC menu / UI that didn't fit on the screen properly BUT my 3D movies were now PERFECT. And I mean perfect. It went from so bad that I couldn't watch, where left and right or top and bottom images were 5cm offset and it was a complete disaster to a PERFECT 3D image without ANY ghosting or crosstalk AT ALL.

It's dramatic.

But now obviously you don't want your XBMC UI and 2D movies not fitting on the screen properly with parts of the image missing, so we get to step 3.


3. On my TV there is a specific setting for the "Screen Mode". It can be "16:9", "4:3", "Zoom to fill screen" ... OR "Fit source to screen". That last one is the solution to all my problems.

If you set it to that, it takes the incoming signal and makes sure it fits on the screen EXACTLY. It does NOT mess with your aspect ratio or anything else, it adjusts for the overscan on the TV. But by letting the TV do it, you don't affect the image at all and you DO NOT affect the 3D image overlay for SBS and OU content.



This was an epic find for me because my 3D viewing just went from appalingly bad / unwatchable to literally perfect for every 3D movie I've tried so far.

And obviously all 2D normal stuff is still perfect, I wouldn't accept less.

Read this, know this, understand this if you have XBMC on an HTPC and you are into 3D.
Reply
#2
Some TVs call it "Just scan" or "Pan&Scan".
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#3
I have no idea why modern TVs would call that setting "Pan & Scan".

Pan & Scan is a method of cropping images to fit into an area with a different aspect ratio to the image itself.

With Pan & Scan you are cropping a widescreen image for display on a non-widescreen display device, as explained here:

http://en.wikipedia.org/wiki/Pan_and_scan

What my TV is doing with the setting I'm talking about is effectively scaling the entire image down proportionally to make it fit exactly into the physical visible display area WITHOUT losing any of the image or changing anything about the image.

Obviously my source image IS the exact same aspect ratio as the physical display device and therefore it CAN do that without changing the image or throwing away any part of the image.

So really, it's an Overscan / Underscan adjustment, but done on the target device and NOT on the source.

It seems that the reason that it's so important that it's NOT done on the source (ie by XBMC or by your video card driver) is because if it is, it somehow messes with the pixel offset values and the gaps between the left and right or top and bottom images of a 3D image.

As soon as you apply ANY Overscan or Underscan adjustment to the source, the 2 halves of an SBS or OU 3D image move out of sync. And, the more Overscan or Underscan you apply , the worse the situation gets and the more out of sync the 2 images become and the more ghosting and crosstalk you get.

So the moral of the story is that you cannot have ANY Overscan or Underscan adjustment happening at source if you want to play SBS or OU 3D content properly and perfectly.

On my TV now, with all of this resolved, I have such a perfect 3D experience it's actually ridiculous.

Before, it was just horrible.
Reply
#4
Wow, thank you for these infos!!
I was going crazy trying to understand where the crosstalk problem was coming from, my video card, xbmc or my tv...
I'll try your suggestions and I hope my panasonic vt20 have the "Fit source to screen" mode.
Cheers Smile
XBMC Italian translator, Movieplayer.it scrapers developer and the old "The Orbs" skin creator.
Reply
#5
I really hope it helps.

It was driving me insane too.

I think you have a good chance of sorting it out if you do what I did.
Reply
#6
It worked great!!! No more crosstalk in my xbmc setup!
Tnx SiliconKid Wink
XBMC Italian translator, Movieplayer.it scrapers developer and the old "The Orbs" skin creator.
Reply
#7
Tnx!!!!! :-)
Works perfect!
My LG 55" 3D tv menu says : just scan
Reply
#8
THX from me too, that was the most simple and most helping asnwer!!!!!!!!!!!!!!!!!!!!
Reply
#9
Yep first port of call for any overscan issue is to fix the TV.

I bought 3 or 4 TVs at the end of last year, and the first thing I looked for was the ability to do 1080p, the second thing was the ability to "just scan" - most relatively modern "big name" brands will have the ability to turn off overscan. Samsung, LG, Sony.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#10
SiliconKid, I could kiss you right now!
Reply
#11
Thanks for the tips!

I've now the perfect 3D movies on SBS files...

Unfortunately, my Half OU still don't work... When I turn the 3D on for that movies ( and I don't need to do that for the SBS... The TV does it automatically) I still get 2 images, not side by side but some centimeters one above the other...

Any tips?

Thanks for your time.

Regards from Portugal!

João Lopes
Reply
#12
Hi again...

Found the answer....

I've some scalling for some frequencies on my TV. I've set to 0% in 60hz but didn't removed it for 24hz... Set it to 0 and voilá! Smile

Thanks!
Reply
#13
Sorry to dredge up an old thread again, but i'm suffering with the overscan problem. I have a samsung 51" f4900, and the only option I have is "fit to size" not source. The crosstalk is making it impossible to watch 3D, because your eyes just keep going out of focus!

Lopesco, how did you change the hz? I don't seem to have that in my tv menu either.

I'm confused because when I used to stream from my laptop, pre XBMC, the 3D image was perfect.

Any help, as always, much appreciated. Andrea

****Sorry.. I have an Android box, Ouya, XBMC 12.3.
Reply
#14
You need to do what I describe in the first post.

The problem is overscan. You need to make sure that the overscan on your video card drivers is set to 0 all round.

The problem is not with XBMC and is specific to 3D. If you compensate for overscan on your PC either in the driver settings or in XBMC then you are effectively scaling the image BEFORE you send the image to the TV. That is no good because the TV needs the image to be the original size to accurately determine the center of the image and split the image into 2 so that it can get the 2 frames out for the left and right eye.

That's why it's VERY important that you are not messing with the image size at source and that ONLY your TV is set to fit the picture to the frame. Then it will happen AFTER the TV receives the frames and that will be ok, it will not mess up the alignment of the left and right eye frames for 3D.

In XBMC, go to the video settings and go to the calibration page and make sure everything is set to 0. That will probably mean that the corners of the image are off the screen in your case. That is correct for what you are trying to do.

In other words, you must NOT calibrate the image in XBMC or anywhere else on the PC, the image SHOULD be extending off the screen (unless of course you have the "fit to screen" setting turned on, on the tv, already, in which case it will already be compensating for you).

Bottom line: ONLY the TV must be allowed to fit the image to the frame correctly. NOTHING ELSE must adjust the size of the image and try to scale the image.

@AniMac:

The Android box could be causing you problems over and above the usual problems.

I've seen that people have had various issues with XBMC running on Android and there seems to be less control over certain settings and configuration than there is for the Linux and Windows versions.

From what I've seen, the Android version isn't properly stable yet and things like this, where specific video settings need to be adjusted and you need to be able to control things like overscan, could be a problem if you are running on Android and might actually just not work at this point, period.
Reply
#15
Thanks for the quick reply. I figured that might be the case. Maybe now i'm addicted to XBMC, I should invest in an actual Ouya box? Research time..
Reply
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
XBMC + 3D = Crosstalk / Ghosting ? SOLUTION HERE!52
This forum uses Lukasz Tkacz MyBB addons.