Linux -  Errors with compiling (taglib)
#1
Now with the merges with taglib I can not get XBMC to compile correctly

docs\README.linux states to install taglib(>= 1.8) - That's not a readily available package, only 1.7.

Get:

checking for TAGLIB... no
configure: error: Could not find a required library. Please see the README for your platform.

Compiling from source from: https://github.com/taglib/taglib - Appears to build correctly, no longer get the error that TAGLIB is missing.

Then when doing a make I get the following error right at the end when it's trying to build xbmc.bin - http://pastebin.com/0V1EZ1tE
Reply
#2
read the readme.ubuntu
Reply
#3
got past that and now find that it requires java for some reason - even with bluray disabled, why is that - doxygen or something? can't find a configure flag to disable it, i really don't want a JRE on my system

edit: i guess its this (as it also added the swig dependency): https://github.com/xbmc/xbmc/commit/c25b...a547656e9f

--disable-swigaddons didn't work
Reply
#4
You will need it
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#5
(2012-09-12, 16:28)Martijn Wrote: You will need it

yes i've installed openjdk-7 as it looks like all the documentation is going doxygen from here out.

its just finished compiling, so off to test it now.
Reply
#6
Thanks for the assist Spiff; I must've glanced over that part when I read through it.

I've built taglib as per the instructions in readme.ubuntu

But I'm still getting the error at the end of the make phase: http://pastebin.com/Yqv4d9EW

I may have pooched things along the way, I might do a fresh install over the weekend with a later version of Ubuntu, currently running Natty.
Reply
#7
make v=1 and chech where it picks up taglib from
Reply
#8
check if libtag1-dev is installed, after removing it build ok
Reply
#9
I get the following:

Code:
make -C taglib-1.8/build
make[1]: Entering directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
make[2]: Entering directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
make[3]: Entering directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
make[3]: Leaving directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
[ 98%] Built target tag
make[3]: Entering directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
make[3]: Leaving directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
[100%] Built target tag_c
make[2]: Leaving directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
make[1]: Leaving directory `/home/gryph/Software/XBMC/lib/taglib/taglib-1.8/build'
Reply
#10
Ahhh you got it in one Brutus - libtag1-dev was installed

Removed and it built without an error
Reply
#11
(2012-09-12, 14:39)spiff Wrote: read the readme.ubuntu

Please put this info also in readme.linux

I'm not on Ubuntu and had to search quite a lot
Reply
#12
i can sorta understand, but readme.linux is for general linux and we can't make distro assumptions. i'm sure rolling stuff like arch/gentoo may very well already have it available.
Reply
#13
Should have been looking here, been working thru this for the past few days. Thinking I did not have tablib installed correctly.

+1 for Brutus,
Reply
#14
Why did this suddenly start requiring 1.8? I'm pretty sure it isn't the swig merge because it worked just a few days ago
Reply
#15
(2012-09-14, 15:33)takoi Wrote: Why did this suddenly start requiring 1.8? I'm pretty sure it isn't the swig merge because it worked just a few days ago

Maybe there are also other things merged
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Errors with compiling (taglib)00