Bug Setting action to show info instead of play makes web video slow to start
#1
OS: Win 7
XBMC: 12 RC3

When I set the option to display media information instead of playing it this has the side effect of making my web video slow to start. And by that I mean I get the audio only for about 20 to 30 second before the video appears.

If I reset this option the problem disappear.
Reply
#2
Bump.
Reply
#3
Just to let you know that I still have that problem with 12.1
Reply
#4
What is "web video"? Also, as always, debug log (wiki) needed.
Reply
#5
Maybe related/similar to this? http://trac.xbmc.org/ticket/14192

But, yes, a debug log (wiki) would be helpful regardless.
Reply
#6
(2013-03-29, 07:33)Ned Scott Wrote: What is "web video"? Also, as always, debug log (wiki) needed.

Web Video as in TwiT or Endgadget or CNet...

Here without the display media information option (works fine): Log here

And here with the option set (audio only & crash) : Log Here
Reply
#7
I believe the relevant part is this :

09:15:44 T:5568 DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin TWiT('plugin://plugin.video.twit/','7','?content_type=video&iconimage=C%3a%5cUsers%5cAlain%5cAppData%5cRoaming%5cXBMC%5caddons%5cplugin.video.twit%5cicon.png&mode=4&name=Latest%20Episodes&url=latest_episodes')
09:15:44 T:5568 INFO: initializing python engine.
09:15:44 T:5568 DEBUG: new python thread created. id=21
09:15:44 T:5568 DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - waiting on the TWiT (id=21) plugin...
09:15:44 T:6388 NOTICE: Thread XBPyThread start, auto delete: false
09:15:44 T:6388 DEBUG: Python thread: start processing
09:15:44 T:5568 NOTICE: CDVDPlayer::CloseFile()
09:15:44 T:5568 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
09:15:44 T:5568 NOTICE: DVDPlayer: waiting for threads to exit
09:15:44 T:5568 NOTICE: DVDPlayer: finished waiting
09:15:44 T:6920 NOTICE: Thread Jobworker start, auto delete: true
09:15:44 T:6920 DEBUG: CSaveFileStateJob:Big GrinoWork - Saving file state for video item plugin://plugin.video.twit/?url=http%3A%2F%2Ftwit.tv%2Fshow%2Fham-nation%2F91&mode=2&name=Ham+Nation+-+Episode+%2391%3A+George+Builds+an+AM%2FFM+Radio+Kit&iconimage=http%3A%2F%2Ftwit-xbmc.googlecode.com%2Fsvn%2Fimages%2Fhn600.jpg&content_type=video
09:15:44 T:4732 NOTICE: Thread Jobworker start, auto delete: true
09:15:44 T:5568 ERROR: Control 50 in window 10025 has been asked to focus, but it can't
Reply
#8
Any idea?
Reply
#9
Well there is no library info so perhaps it is taking time looking up something that it won't find.
Reply
#10
(2013-03-31, 22:09)nickr Wrote: Well there is no library info so perhaps it is taking time looking up something that it won't find.

Two question remain:

1- Why does it even try to find info when the source isn't in the library? Is XBMC unable to differenciate between a media file and a streaming plugin?

2- Why does it affect only the video part of the stream and not the audio?
Reply
#11
Good questions, and of course my guess may be entirely off the wall.

Anyhow if you turn off the option to get info instead of playing, you still have the info button to get info, or the context menu to get there a slightly longer way.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#12
This is entirely a guess, as I'm not really familiar with how add-ons work with metadata, but it could also depend on how the add-on is made. It could be that the add-on thinks it has metadata, but actually doesn't, thus has this timing-out attempt to access that data. Just a guess, though.
Reply
#13
(2013-04-01, 09:15)nickr Wrote: Good questions, and of course my guess may be entirely off the wall.

Anyhow if you turn off the option to get info instead of playing, you still have the info button to get info, or the context menu to get there a slightly longer way.

Yes I can do that... As a matter of fact I have to if I want to watch online stream. I guess I'll have to programe my MCE remore ì`button to send the right code to XBMC, instead of reaching for the keyboard.

(2013-04-01, 16:09)Ned Scott Wrote: This is entirely a guess, as I'm not really familiar with how add-ons work with metadata, but it could also depend on how the add-on is made. It could be that the add-on thinks it has metadata, but actually doesn't, thus has this timing-out attempt to access that data. Just a guess, though.

This happens with all the video streaming plugins that I use. Either they copied the same code base or I'm extremelly unlucky.

In any case I'll keep working on it and see if I can find more.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Setting action to show info instead of play makes web video slow to start00
This forum uses Lukasz Tkacz MyBB addons.