•   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
Hi all. Just started using dsplayer as opposed to MPC-HC and loving it. Really needed a way to integrate AC3Filter for better control of downmixing/DRC and this does just that! Just wanted to report two things:

1. Can't use it with Reclock (to take advantage of WASAPI) if I want to be able to seek a lot without it crashing. No biggie, but if anybody else is having issues with it crashing when seeking, you might want to check if you're using Reclock as your audio renderer (in the dsplayer gui settings). Maybe this will be corrected in a later build.

2. For some reason the XBMC animations are jerky instead of fluid (when moving between different movies or different tv shows). Not sure if it is this build, or an issue with 12.1 in general. I'm also using Transparency! skin so that could be it too. Just wanted to report in case it is an issue with the dsplayer build of XBMC. Was not having this issue with official build of 12.0 or Eden.

I'll keep checking back for newer builds and testing them. If issue #2 above can be confirmed as relating to this build, please let me know. Thanks!
Reply
(2013-04-02, 01:48)Slurm Wrote: Please take a look here for a new build with margro's pvr changes.

If it works well I will try to make a patch for DSPlayer branch.

So a merged build does exist? Good to know.Smile I would have tried it if I had TV hardware, but since I don't I'll stick to 12.1.
Raspberry PI 2 + LibreELEC 8 (Kodi 17)
Samsung Galaxy Tab A 10.1 + Kodi 17 for Android
Reply
@Roman_V_M Since Eduard_K create xbmc dsplayer page on his site. Shouldn't first post link to his xbmc page instead of his avsplitter?
Reply
(2013-04-02, 13:43)oldpoem Wrote: @Roman_V_M Since Eduard_K create xbmc dsplayer page on his site. Shouldn't first post link to his xbmc page instead of his avsplitter?

Good point, though the XBMC page does not have English version.
Raspberry PI 2 + LibreELEC 8 (Kodi 17)
Samsung Galaxy Tab A 10.1 + Kodi 17 for Android
Reply
(2013-04-02, 07:38)Roman_V_M Wrote:
(2013-04-02, 01:48)Slurm Wrote: Please take a look here for a new build with margro's pvr changes.

If it works well I will try to make a patch for DSPlayer branch.

So a merged build does exist? Good to know.Smile I would have tried it if I had TV hardware, but since I don't I'll stick to 12.1.

You can try it too if you want to. There shouldn't be anything different for you.

In the meantime I added another patch for watching 3D Movies (Thread):

https://www.dropbox.com/s/vfgg5h6y17lxs2...-dx-3D.exe (This contains both patches margro's pvr and 3D on DSPlayer base).
Reply
(2013-04-02, 03:14)powder21 Wrote: Hi all. Just started using dsplayer as opposed to MPC-HC and loving it. Really needed a way to integrate AC3Filter for better control of downmixing/DRC and this does just that! Just wanted to report two things:

1. Can't use it with Reclock (to take advantage of WASAPI) if I want to be able to seek a lot without it crashing. No biggie, but if anybody else is having issues with it crashing when seeking, you might want to check if you're using Reclock as your audio renderer (in the dsplayer gui settings). Maybe this will be corrected in a later build.

2. For some reason the XBMC animations are jerky instead of fluid (when moving between different movies or different tv shows). Not sure if it is this build, or an issue with 12.1 in general. I'm also using Transparency! skin so that could be it too. Just wanted to report in case it is an issue with the dsplayer build of XBMC. Was not having this issue with official build of 12.0 or Eden.

I'll keep checking back for newer builds and testing them. If issue #2 above can be confirmed as relating to this build, please let me know. Thanks!

I can confirm #1. Unfortunately no change in recent builds
Reply
I would think this issue would be more of a priority for most users, is there any work on getting DSplayer able to play files over the network (NAS, SMB) instead of having to map drives?
Image
Reply
(2013-04-02, 20:15)tman12 Wrote: I would think this issue would be more of a priority for most users, is there any work on getting DSplayer able to play files over the network (NAS, SMB) instead of having to map drives?

All my movies are access through SMB and DSPlayer has no problem with it.

The only problem is IDX/SUB as external subtitle won't recognized by DSPlayer via SMB. Map drive fix that but I'm in process of Mux those sub in MKV / Convert VobSub to SRT/ASS format to not map any drive at all. Because map drive won't work with shared mysql db anyway (I have linux devices on my network)
Reply
(2013-04-02, 20:15)tman12 Wrote: I would think this issue would be more of a priority for most users, is there any work on getting DSplayer able to play files over the network (NAS, SMB) instead of having to map drives?

This works fine for me. I use the servers IP for it.
Reply
(2013-04-02, 14:25)Slurm Wrote:
(2013-04-02, 07:38)Roman_V_M Wrote:
(2013-04-02, 01:48)Slurm Wrote: Please take a look here for a new build with margro's pvr changes.

If it works well I will try to make a patch for DSPlayer branch.

So a merged build does exist? Good to know.Smile I would have tried it if I had TV hardware, but since I don't I'll stick to 12.1.

You can try it too if you want to. There shouldn't be anything different for you.

In the meantime I added another patch for watching 3D Movies (Thread):

https://www.dropbox.com/s/vfgg5h6y17lxs2...-dx-3D.exe (This contains both patches margro's pvr and 3D on DSPlayer base).


Hi Slurm, load your build and I don*t have this evil click noises. Great


Many Thanks!

Juro
Reply
(2013-04-02, 14:25)Slurm Wrote:
(2013-04-02, 07:38)Roman_V_M Wrote:
(2013-04-02, 01:48)Slurm Wrote: Please take a look here for a new build with margro's pvr changes.

If it works well I will try to make a patch for DSPlayer branch.

So a merged build does exist? Good to know.Smile I would have tried it if I had TV hardware, but since I don't I'll stick to 12.1.

You can try it too if you want to. There shouldn't be anything different for you.

In the meantime I added another patch for watching 3D Movies (Thread):

https://www.dropbox.com/s/vfgg5h6y17lxs2...-dx-3D.exe (This contains both patches margro's pvr and 3D on DSPlayer base).

I have added the link to the 1-st post.
Raspberry PI 2 + LibreELEC 8 (Kodi 17)
Samsung Galaxy Tab A 10.1 + Kodi 17 for Android
Reply
(2013-04-03, 21:59)juro1971 Wrote: Hi Slurm, load your build and I don*t have this evil click noises. Great


Many Thanks!

Juro

Thanks for testing.

(2013-04-03, 22:13)Roman_V_M Wrote: I have added the link to the 1-st post.

Tonight I will try to make a patch for both changes and post it here if I'm successful.
Reply
Hey guys,

I upgraded to the Frodo 12.1 release from an older Eden build last night that was working perfect, but now I can't get anything to play with DSPlayer, it looks like it is not picking up my old filtersconfig.xml and mediasconfig.xml files (if I turn on the "use system default filters (directshow merits)" in the video settings, then it does work, but not using my preferred filters; if I turn that off, then when I hit play on an item the UI flashes for a brief second, but nothing plays).

My .XML files are located at (as they always have been):

C:\Documents and Settings\Admin\Application Data\XBMC\userdata\dsplayer\

Has this path been depreciated, or did the format of the filter config change in 12.1?

I'm still using WinXP if that makes any difference.

Many thanks for any info

The REAL Joe

...Nevermind, figured it out (my old mediasconfig.xml was using mkvsource and mkvsplitter which I guess used to be included with the installation files but no longer are, and I had renamed my c:\program files\xbmc folder to xbmc.bak before installing the new version, so the old splitter couldn't be found.

Sorry for the brainfart.

The REAL Joe
Reply
(2013-04-05, 03:35)therealjoeblow Wrote: Hey guys,

I upgraded to the Frodo 12.1 release from an older Eden build last night that was working perfect, but now I can't get anything to play with DSPlayer, it looks like it is not picking up my old filtersconfig.xml and mediasconfig.xml files (if I turn on the "use system default filters (directshow merits)" in the video settings, then it does work, but not using my preferred filters; if I turn that off, then when I hit play on an item the UI flashes for a brief second, but nothing plays).

My .XML files are located at (as they always have been):

C:\Documents and Settings\Admin\Application Data\XBMC\userdata\dsplayer\

Has this path been depreciated, or did the format of the filter config change in 12.1?

I'm still using WinXP if that makes any difference.

Many thanks for any info

The REAL Joe

...Nevermind, figured it out (my old mediasconfig.xml was using mkvsource and mkvsplitter which I guess used to be included with the installation files but no longer are, and I had renamed my c:\program files\xbmc folder to xbmc.bak before installing the new version, so the old splitter couldn't be found.

Sorry for the brainfart.

The REAL Joe

http://forum.xbmc.org/showthread.php?tid...pid1374639

see here: http://forum.xbmc.org/showthread.php?tid...pid1374639

This works perfect for me
Reply
Hi

I'm using lav filters with xbmc ,but when I select external subtitle , the subtitle is blurry and unreadable , What can I do ?


http://img39.imageshack.us/img39/3965/sc...ot000y.png
Reply
  •   
  • 1
  • 13
  • 14
  • 15(current)
  • 16
  • 17
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58