•   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 85
  •   
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi
Hey! I've done everything as you told me to do, however, when I click steam in XBMC, it starts for a second, asking me to accept the license agreements, and then it crashes?

What am I doing wrong, this was not very clear reading, so, I made this file so:

EDIT: Got it working! Thanks to the tips from the other guy F9, and Openbox, etc.

Works fine now! Just... no sound? I added my pulseaudio?

What am I doing wrong?

http://paste.ubuntu.com/7800741/


[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC889A Analog [ALC889A Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC889A Digital [ALC889A Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
[email protected]:~$



I didn't touch nano ~/.asoundrc do I have to do that? I am trying to use pulseaudio, sound from XBMC works with HDMI.



# --auto-generated-- by /etc/xbmc/live.d/01-make-asoundrc.sh
# AUTOUPDATE=True # change this to disable updating of this file
pcm.!default {
type plug;
slave.pcm "hdmi:CARD=NVidia,DEV=0";
}
Reply
You've added the pulse audio commands to the Mac section of the script. The addon has changed a bit since writing that guide and I haven't updated it yet. There is no need to edit the steam-launch.sh file anymore to add pre/post steam scripts. Make sure you have the latest version of the addon (1.9.6), then delete your scripts via the addon settings and create two scripts(outside of xbmc):

EDIT: info moved to xbmcbuntu 13 guide

Don't forget to make both scripts executable.
Then in the addon settings add the above scripts as the pre/post scripts.
That should give you audio in steam BPM.
Reply
Ive finally looked at why the steamos-xpad driver isnt being rebuilt after kernel updates via dkms and it appears to be because of a invalid dkms.conf file. Ive emailed the ppa maintainer but here is the fix that seems to solve the issue. Edit /usr/src/xpad-0.1/dkms.conf and replace the contents to the following:

Code:
PACKAGE_NAME="xpad"
PACKAGE_VERSION="0.1"
MAKE[0]="make KVERSION=$kernelver"
CLEAN="make clean"
DEST_MODULE_LOCATION[0]="/extra"
BUILT_MODULE_NAME="xpad"
AUTOINSTALL="yes"

Youll probably need to rebuild the xpad module

sudo dkms remove xpad/0.1 --all ; sudo dkms build xpad/0.1 && sudo dkms install add xpad/0.1
Reply
Currently running XBMC 12.3. I was using launcher 9.7 for some time but decided to try and get the latest version to work, this has proven to be a bad idea.

After repeated re-installs of steam launcher and removal of the addon data I continue to get a Windows Script Host error

Script: C:\user\............\scripts\launchhidden.vbs
Line: 1
Char:1
Error: Subscript out of range
Code: 880A0009
Source: Microsift VBScript runtime error

This error pops up regardless if I am running an older version of the plug-in or if I am using 12.3 or 13.1 of XBMC
Reply
What happens if you run the command thats in the xbmc log file from the command line? Also what version of windows are you using?
Reply
Update: I uninstalled the add-on, removed both add-on folder locations, and re-installed 0.9.5. Things are back to working at the moment. Is there a version change where the add-on can no longer be used in XBMC 12.3?

I am running Windows 7 SP1

I receive the same windows error window when I attempt to run "LaunchHidden.vbs" from the windows command line.
When attempting to run an older version of launcher (0.9.8, 0.9.7, 0.9.5) this error shows up in the XBMC log file
ERROR: SQL: Abort due to constraint violation
Query: insert into blacklist(id, addonID, version) values(NULL, 'script.steam.launcher', '0.9.9')

When attempting to run version 1.9.6 I no longer get the VB error, but the script times out.

Now if I go into "AppData\Roaming\XBMC\userdata\addon_data\script.steam.launcher\scripts" or "AppData\Roaming\XBMC\addons\script.steam.launcher\resources\scripts" and run the SteamLauncher-AHK.exe manually things work just fine
Reply
Im not sure if the current version still works with frodo, I have not tested the addon with it at all.
I get a error like yours when trying to run the launchhidden vbscript with no arguments (either via cmd or gui), also over time Ive noticed the vbscript likes to fail silently if a incorrect amount of arguments are passed. Can you post your log file of the problem occurring with 1.9.6 + Gotham?

EDIT: looks like frodo fails silently if it doesnt have a cscript prefix command.

Quote:v1.9.7 in first post:
English strings changed and updated.
Script update dialog has changed - yes now updates scripts instead of going to settings screen.
Small fixes.
Readded cscript prefix to windows command, with out it addon fails silently in Frodo.
Reply
Here is my latest log file

http://pastebin.com/F6t7xdUV
Reply
Thanks for the log file. I thought I got rid of that issue - I'll look into it. For now disabling the script update check should fix it.

EDIT: ok I have managed to replicate the issue. question: in Steam-Launch-AHK.ahk in your userdata dir (generally %appdata%\XBMC\userdata\addon_data\script.steam.launcher\scripts) do you have a line near the top of the file like so: ;steam.launcher.script.revision=00X ? Older scripts didnt have this line and that seems to be the problem.

Deleting all the script files in that folder should get the addon running
Reply
v1.9.8 in first post
Quote:Fixed script update check with older scripts
Script files give error messages if run with no arguments
Small fixes

While this version works with frodo, the method it uses for on screen notifications are not frodo compatible. So if you get a error notification the script will fail, but apart from the pre/post scripts do not exist error notification, when you get one the script would be exiting anyway.
Reply
I am going to have to give this a shot as I was looking for an easy way to integrate the two. Ive not tried this yet.. but it looks like you are actually killing xbmc when launching steam.. I understand why as I had issues with sound as well as input being sent to both xbmc and the emu/game I was playing. I worked around it a bit differently though. I simply "pause" xbmc. Below is my mupenlaunch.sh script I use to launch ROMs with mupen64. I have similar scripts to launching other emus and some games that dont require steam.

Code:
#!/bin/bash

xbmc-send --action="XBMC.InhibitIdleShutdown"
killall -STOP xbmc.bin
mupen64plus $2 "$1"
killall -CONT xbmc.bin
xbmc-send --action="XBMC.AllowIdleShutdown"
exit 0

the idleshutdown commands are likely not necessary seeing as how xbmc is set to a stopped state so it shouldnt be able to shutdown or sleep the system anyways... but they don't hurt.

The advantage of this is that when you exit the game and come back to xbmc you are at exactly the place you left it, and it's much quicker than completely relaunching xbmc. Would be a good option to have for those not worried about letting xbmc sit in ram...
Reply
You can set the addon to not kill xbmc, but minimize/maximize xbmc and split your script up and use them as pre/post steam scripts which I think should have the desired effect.

EDIT windows users can use pssuspend.exe, eg:

pssuspend.exe XBMC.exe

pssuspend.exe -r XBMC.exe
Reply
ahh ok. very nice.
Reply
v2.0.0 in first post. I'm pretty happy with this version Smile

Quote:Fixed formatting in addon.xml
Use proper locking in steam-launch.sh script, thanks BtbN!
Updated French language strings, thanks Kre|S!

** People upgrading from pre 1.9.X versions need to check the addon settings - due to changes the 'Script update check' and 'Program location check' get disabled. **
Reply
hi,

I'm trying to install the script via the xbmc "install from zip" menu and get this error when navigating to the zip file:

"addon does not have the correct structure"

I'm new so I'm sure I'm just doing something wrong. I'm sorry if this is a stupid question but all I found on wiki was just straight forward instructions on how to navigate to the zip file and click on it :S

thank
Reply
  •   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 85
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi7
This forum uses Lukasz Tkacz MyBB addons.