HDMI Audio Volume from XBMC remote
#1
Hi,

I have an Acer Aspire R3610 running XBMCbuntu 12.1. I also have a VRC-1100 MCE remote. For the most part, this is all working as I require with one exception - audio. I have literally the TV connected to the HTPC via HDMI, nothing else. No receivers etc.

What I want to be able to do is control the audio output level from the MCE remote. Sadly when I press the volume up/down buttons, nothing happens.

First check I made was to ensure the remote was sending the correct codes. I enabled logging and checked the logs when pressing the keys.

Code:
OnKey: volume_down (f0b8) pressed, action is VolumeDown
OnKey: volume_up (f0b9) pressed, action is VolumeUp

So thats all working.

Next thing I checked was the XMBC audio mixer. I have "Master.0", "PCM.0", "IEC958.0" and "IEC958.1". Changing the volume control for master or PCM does nothing - the volume is at the same level. The IEC ones dont have a volume control, only a mute. If I mute "IEC958.1" it mutes the output via HDMI.

I assume whats going on is XBMC is passing the raw bit stream to the TV and therefore cannot control the output volume itself.

I have tried setting the sound output to analog under Audio Output, same problem.

I have a number of different things listed under output device
  • HDA Nvidia (multi), HDMI 0
  • HDA Nvidia (both), HDMI 0
  • Default (HDA Nvidia HDMI 0)
  • HDA Nvidia, HDMI
  • HDA Nvidia, ALX662 rev 1 Digial S/PDIF
  • HDA Nvidia ALC662 rev1 Analog
  • HDA NVidia (hdmi_complete) HDMI
  • HDA Nvidia (hdmi_formatted) HDMI

Here is my aplay -l
Code:
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Please note I am not bothered about sound quality (couldn't care if its analog output), just want to be able to control the volume from the MCE remote.

Can anyone help?
Thanks
Reply
#2
Remove your asound.conf and retry and uninstall the audiomixer if you are at it.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
Thanks a lot - that has worked, great.

Now one more annoyance - the volume up & down keys work but dont repeat (every other key on the remote repeats)

Cheers
Reply
#4
It never did repeat not ever.

uNi
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
HDMI Audio Volume from XBMC remote00