unexpected crash of Atv : Error Script Failed!
#1
Since I try to use it, my Atv keeps crashing after 15sec of using it. Barely have time to enter menus

I found out I had NitoTV installed and could update XBMC with it.

It said : istalation/upgrade successful
but also gave 2 errors :
E: could not get lock/var/lib/..........
and E: unable to lock the administration directory............

When I tried XBMC again, still crashes the same.

Someting was written in the bottom:
Error Script Failed! Script.common.plugin.cache

I typed this in google and found this:
http://forum.xbmc.org/showthread.php?tid=150812
Too much info, plus it sounds like programming code, which I don't have a clue where and how to do that.

http://wiki.xbmc.org/index.php?title=Add...ugin_cache
When I try to do step 1 it crashes right away

Can someone help by telling me a simple way to fix this?

Thank you
Reply
#2
Hello,

is there a way to get some help here? I'm a single mom with a baby on my hands, so my time is sparse. It's now been 4 days I'm trying to solve this and I'm no programmer/It/server girl. My knowledge is basic and all this jargon is pushing my limits. All I want is to be able to set that ATV.

I tried to enable Debugging on Atv. most of the time it crashes before I get there. I got it once and rebooted as per instructions. Once back on, it seemed Debugging was off again.

I downloaded Cyberduck and can't connect to Atv. Connection failed connection refused

So now what do I doHuh

My Atv is plugged in power + hdmi
In cyberduck I clic upper left button (open connection). in server box i enter Atv IP + Username = root + Password = alpine.

I got the log after updating XBMC. Maybe it can help?

http://pastebin.com/VFMeiiuK
Reply
#3
Platform = AppleTV2
Version of iOS/ATV = 4.3 (2557)
XBMC Build version and date compiled : I don't know how to get this, it crashed too fast. I updated it just now with putty


problem is crash of XBMC after 10 sec or using it.
XBMC is shown as CFBundleName in Atv main menu

I finnaly was able to write down everything after 10 crashes. I have 2 sec to read and write... Thats some serious sport


Darwin Kernel Version 11.0.0
GIT: 20110623-62171b3
compiled 23 jun 2011
Reply
#4
Finaly got my XBMC LOG from CYBERDUCK

http://pastebin.com/ZTZs0udz
Reply
#5
I found 28 crash logs. Juste making this situation more confusing...
This is the latest one.

http://pastebin.com/HRunzPz2

So is anyone going to help or am I talking to myself? Am I at the right place?
Reply
#6
I'd think an update to XBMC would fix this, but I don't know why NitoTV isn't able to update XBMC. A build from summer of 2011 is pretty old for iOS, and I believe that was when we were still in early development versions for iOS.

Have you tried unplugging the ATV2 and plugging it back in for a total reboot? If so and that didn't work, from what I've searched, it sounds like you might have to rejailbreak the ATV2 and reinstall XBMC. Before that, there might be some other things we can try. If I find anything out, I'll post about it here.
Reply
#7
I unplugged and replugged many times.

I tried updating with Putty and with Nito.
with Nito I get : E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

I then tried installing using putty :
Apple-TV:~ root# apt-get install wget
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

I tried deleting the DPKG files located in /var/lib/dpkg/updates with Cyberduck (as per an old post) : permission denied
Reply
#8
When you connect with Putty, try this command:

dpkg --configure -a
Reply
#9
wow.... Here is the answer:

Apple-TV:~ root# dpkg --configure -a
dpkg: error processing org.xbmc.xbmc-atv2 (--configure):
Package is in a very bad inconsistent state - you should
reinstall it before attempting configuration.
Errors were encountered while processing:
org.xbmc.xbmc-atv2
Apple-TV:~ root#
Reply
#10
is the problem only XBMC? Could we just uninstall and re install it?
Do I have to take into consideration to do that with Nito too?

Would it be better for me (while we're at it) to uptade the iOS too? I don't want to be stuck with the newest one that can't be jail broken though...
Reply
#11
Ok... As per : for removing your xbmc settings remove the folder /var/mobile/Library/Preferences/XBMC
I tried and it did some errors. I could not copy the log, but I did a print screen.
I tried re installing XBMC with putty. It stalled at some early stage (a few lines down after saying the last yes).
30 min later I closed putty and Atv. Re opened them, re tried, and I get the dpkg msg again.
Reply
#12
I downloaded the Nitotv Installer for windows.
I clic to removed both XBMC and Nitotv, unplugged Atv, I clic to install both.
When I go back in XBMC, everything looks the same as if never uninstalled...

But now it don't crash anymore, so I was able to enable add ons by using this method : http://www.xbmchub.com/blog/2013/05/22/h...mc-addons/

New problem : i cannot watch anything. When I clic on a video addon i get this message (and it does that for ALL plugins) :
error script failed! : plugin.video. (name of the plugin)

So now what? ....................................

Seriously, ATv is a piece of JUNK.
At this point, I'm sooo fed up, I think I'm better to buy a dish or pay Videotron outrageous monthly fees so that I get freaking peace out of this hacking hell.
Reply
#13
Just don't install it from xbmchub because it will cause problems.
Just follow our wiki guide. Many use it and are happy.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#14
The ATV2 is more "crashy" than it once was due to other iOS functions eating up system resources, and there not really being a proper application system for the ATV2's iOS. It can certainly be frustrating sometimes. (However, other iOS devices seem to work wonderfully with XBMC).

You might want to consider a Raspberry Pi. It's slower in the interface, but easier to set up and crashes a lot less.

Although that doesn't explain why are you are getting script failed messages. Can you get us a debug log (wiki) of when that happens?
Reply
#15
When you say "more crashy than it once was", you refer to when? Because my Atv has been set up in june 2011, which means never got any apple update since then because it's blocked by XBMC and anyways it was sitting on my shelf.

As for debug log, I plugged the Atv, produced 1 crash and a few script error, then when into cyberduck to get the log file
http://pastebin.com/fKPNfgZk

I went to read you wiki guide to install addons http://wiki.xbmc.org/index.php?title=Add-on_manager
I don't see the difference between this and the xbmchub link I gave earlier. Did I miss something?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
unexpected crash of Atv : Error Script Failed!00