Bug Video Stutter on StepForward since Gotham Alpha 7
#1
I've been seeing a couple seconds of video stutter after every StepForward or StepBack since Gotham Alpha 7. I just tried Gotham Alpha 8, and it is still occurring. I've tried every kind of video and audio format I have, and they all seem to do this. It definitely does not happen with Gotham Alpha 5 (I never tried Alpha 6). Here's a log from Alpha 8:

http://xbmclogs.com/show.php?id=65099

I've tried modifying my audio settings, but it doesn't seem to help. PalleO noticed something similar in post 46 of this thread. He seemed to think it had to do with the new transcoding options, but I've seen it happen on AC3 files using passthrough.
Reply
#2
The same thing happens to me with PleXBMC add-on.

I can also confirm that it's being introduced with Alpha 7. Alpha 5 and 6 have no issues with stuttering on step-forward.


Plex-Dev Tobias said it's a bug in the caching code in XBMC. He has already tracked it down but couldn't find the time to make a pull request...

No one else having this problems?
Are the XBMC devs aware of this bug?
Kodi Krypton
macOS Sierra 10.12
Mac mini (late 2012)
Reply
#3
bigbadrabbit - did your discussions in the Plex world show anyone using a non-osx platform having this problem? I'm wondering if it belongs in the OSX support section or in a more general one.
Reply
#4
(2013-10-13, 22:06)RipT Wrote: bigbadrabbit - did your discussions in the Plex world show anyone using a non-osx platform having this problem? I'm wondering if it belongs in the OSX support section or in a more general one.

It seems to be a general problem, not only Mac related.
Could you start a new thread regarding this issue? Your english is probably better mine... Smile
Kodi Krypton
macOS Sierra 10.12
Mac mini (late 2012)
Reply
#5
(2013-10-14, 14:04)bigbadrabbit Wrote:
(2013-10-13, 22:06)RipT Wrote: bigbadrabbit - did your discussions in the Plex world show anyone using a non-osx platform having this problem? I'm wondering if it belongs in the OSX support section or in a more general one.

It seems to be a general problem, not only Mac related.
Could you start a new thread regarding this issue? Your english is probably better mine... Smile

OK. One more request before I start the new thread. Is there a Plex forum thread I can reference where you mentioned this to Tobias? If so can you post a link here so I can reference it in the new thread?
Reply
#6
(2013-10-15, 04:14)RipT Wrote: OK. One more request before I start the new thread. Is there a Plex forum thread I can reference where you mentioned this to Tobias? If so can you post a link here so I can reference it in the new thread?

The thread is located in the PlexPass section and therefore only available for (paying) PlexPass members:
http://forums.plexapp.com/index.php/topi...t-release/


Here's a quote from Tobias:

Quote:Tobias Hieta, on 20 Sept 2013 - 3:42 PM, said:
Oh wait it stutters when you jump back/forward and then it resumes correctly after a while? Sorry for misunderstanding in that case, that is a known bug, which I don't consider that critical.

The bug is in the caching code of XBMC/PHT. I think I know how to fix it, so hopefully I get around to looking into that, it was fixed at some point, but I had to revert the fix because of a crash happening in the fix, so I know where to look, I just need more hours in a day Sad
Kodi Krypton
macOS Sierra 10.12
Mac mini (late 2012)
Reply
#7
Is there anyone working on a solution for this bug?

I've attached two logs:

* Gotham Alpha 5
everything fine, no stutter/buffering on StepForward/Backward

* Gotham Alpha 8
stutter/buffering on every StepForward/Backward

It should have something to do with this errors introduced with Alpha 7:

Code:
17:27:47 T:4764938240   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer

Log Alpha 6
Log Alpha 8


Someone please take a look. Thanks!
Kodi Krypton
macOS Sierra 10.12
Mac mini (late 2012)
Reply
#8
Don't you think we should have different priorities atm - now that Mavericks is out? I mean just look around here in the Forum - users are shitting at us because we are to stupid to support 10.9.

So i guess what i wanted to say - be happy that your installation is usable at all - or get us some osx devs for working on that mointain on TODOs. Its really no Fun on osx atm.

Low priority
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#9
(2013-10-24, 08:39)Memphiz Wrote: Don't you think we should have different priorities atm - now that Mavericks is out? I mean just look around here in the Forum - users are shitting at us because we are to stupid to support 10.9.

So i guess what i wanted to say - be happy that your installation is usable at all - or get us some osx devs for working on that mointain on TODOs. Its really no Fun on osx atm.

Low priority

Well, i don't care about problems with Mavericks because i'm not upgrading until it's safe and therefore i'm not shitting about some or anyone.

I care about this annoying bug that wasn't there before but is now.


Any way, it seems not to be a Mac-only problem. So while it's low priority here, maybe it's bit more priority in the General section...
Kodi Krypton
macOS Sierra 10.12
Mac mini (late 2012)
Reply
#10
Tell those Mavericks users to downgrade then - they don't want to listen to us ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#11
I just posted a similar thread to the general forum here. Memphiz is right, the OSX devs have other problems, and bigbadrabbit is right that this is a general bug. Hopefully this will get some attention from the general devs, or Tobias will submit his pull request. Either way, I think this thread has run its course in the OSX forum.
Reply
#12
Memphiz,

I just want to say thanks for all you devs do to support OSX and all the versions and crazy stuff Apple does to break it.

I can't imagine what a pain it is to try and keep up when the new versions keep introducing so many new issues.

I have a 2009 era mac mini that I love to use as my daily theater driver due to the size and silence, so thanks for what you guys do to try and keep OSX's ports running, I really appreciate it.
Reply



Logout Mark Read Team Forum Stats Members Help
Video Stutter on StepForward since Gotham Alpha 70
This forum uses Lukasz Tkacz MyBB addons.