•   
  • 1
  • 118
  • 119
  • 120(current)
  • 121
  • 122
  • 138
  •   
Release script.skinshortcuts
(2017-03-19, 20:28)brun595 Wrote: I am making on my own skin and have Skin Shortcuts integrated into my skin already (running the latest version of Krypton), but am stuck trying to create a button within SkinSettings.xml that will allow the user to change the background of each of the different menu items set (outside of the management dialog). I will have one button for a single image background, and another for a multi-image background. Creating the button is not the problem, but the <onclick> part of the button is however. I have read through all the docmentation multiple times and come up with what I have below (which is obviously not correct)

<onclick>RunScript(script.skinshortcuts,type=property&amp;property=background&amp;value=??&amp;labelID=mainmenu)</onclick>
<onclick>310</onclick>

For reference, I have a button in the management dialog to change the background for each main menu entry, but I am trying to make another tab in SkinSettings.xml to allow changing the same main menu backgrounds. Any help would be greatly appreciated!

You would need to know the labelID of each menu item that you want to edit - which will, of course, change when the user edits the menu item. If you do know the menu item, then just put its labelID in the labelID parameter. So, to set the background property of the menu item with the labelID 'movies', you'd use labelID=movies. It's worth noting, though, the functions for modifying properties outside of the management dialog are there to set a variety of properties for the default items your skin provides and are not suitable for modifying properties of a customised menu.

(2017-03-19, 22:01)Guilouz Wrote: Issue when creating a new action with source folder :

Code:
20:57:20.335 T:123145440845824   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnicodeDecodeError'>
                                            Error Contents: 'ascii' codec can't decode byte 0xc3 in position 13: ordinal not in range(128)
                                            Traceback (most recent call last):
                                              File "/Users/Cyril/Library/Application Support/Kodi/addons/script.skinshortcuts/resources/lib/gui.py", line 1871, in onClick
                                                selectedShortcut = LIBRARY.selectShortcut()
                                              File "/Users/Cyril/Library/Application Support/Kodi/addons/script.skinshortcuts/resources/lib/library.py", line 1994, in selectShortcut
                                                return self.selectShortcut( group = group, grouping = grouping, custom = custom, showNone = showNone, currentAction = currentAction )
                                              File "/Users/Cyril/Library/Application Support/Kodi/addons/script.skinshortcuts/resources/lib/library.py", line 1994, in selectShortcut
                                                return self.selectShortcut( group = group, grouping = grouping, custom = custom, showNone = showNone, currentAction = currentAction )
                                              File "/Users/Cyril/Library/Application Support/Kodi/addons/script.skinshortcuts/resources/lib/library.py", line 2033, in selectShortcut
                                                selectedShortcut = self._sourcelink_choice( selectedShortcut )
                                              File "/Users/Cyril/Library/Application Support/Kodi/addons/script.skinshortcuts/resources/lib/library.py", line 1800, in _sourcelink_choice
                                                filename = self._build_playlist( selectedShortcut.getProperty( "location" ), mediaType, selectedShortcut.getLabel(), negative )
                                              File "/Users/Cyril/Library/Application Support/Kodi/addons/script.skinshortcuts/resources/lib/library.py", line 1846, in _build_playlist
                                                tree.write( os.path.join( DATAPATH, str( id ) + ".xsp" ), encoding="utf-8" )
                                              File "/Users/Shared/jenkins/workspace/OSX-64/tools/depends/xbmc-depends/macosx10.10_x86_64-target-debug/lib/python2.7/xml/etree/ElementTree.py", line 820, in write
                                              File "/Users/Shared/jenkins/workspace/OSX-64/tools/depends/xbmc-depends/macosx10.10_x86_64-target-debug/lib/python2.7/xml/etree/ElementTree.py", line 939, in _serialize_xml
                                              File "/Users/Shared/jenkins/workspace/OSX-64/tools/depends/xbmc-depends/macosx10.10_x86_64-target-debug/lib/python2.7/xml/etree/ElementTree.py", line 939, in _serialize_xml
                                              File "/Users/Shared/jenkins/workspace/OSX-64/tools/depends/xbmc-depends/macosx10.10_x86_64-target-debug/lib/python2.7/xml/etree/ElementTree.py", line 937, in _serialize_xml
                                              File "/Users/Shared/jenkins/workspace/OSX-64/tools/depends/xbmc-depends/macosx10.10_x86_64-target-debug/lib/python2.7/xml/etree/ElementTree.py", line 1073, in _escape_cdata
                                            UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 13: ordinal not in range(128)
                                            -->End of Python script error report<--

xsp file is correctly created but it's not full :

Code:
<smartplaylist type="movies">
    <name>Films UHD</name>
    <match>one</match>
    <rule field="path" operator="startswith">
        <value>

I know I've said this to you before, but I'll say it one last time - and it's even more relevant at present with just how limited my time is at present - but I need a FULL debug log before I will look into issues. If you can't provide a full - and clean - debug log, then I'm really not interested.

(2017-03-21, 14:38)jurialmunkey Wrote: Is there any way to create widget templates for a group that is *NOT* the mainmenu or submenu and *NOT* on the home screen??

I want to create a widget template for a hub window so that the widget can change depending on which hub item is focussed without reloading every time. Because the number of items can change, I can't just make X number of hidden widgets with conditional visibility based upon focused item.

It's not something I've ever tried, and I'm basing this not on experience but on how the code works (which, with all those surprises that code regularly turns up, means It probably won't work as expected) but IF you know the labelID of the menu you're building then any submenu or submenuOther template should work if you specify the 'name' parameter to the additional menu you want to build against.

My apologies to you and Braz - I know you both have reported bugs which really need fixing. Whilst my time at present is ridiculously limited, I'm going to do my best to have the fixes on git on Monday,
Reply
(2017-03-25, 04:11)BobCratchett Wrote: My apologies to you and Braz - I know you both have reported bugs which really need fixing. Whilst my time at present is ridiculously limited, I'm going to do my best to have the fixes on git on Monday,
No rush Bob, take your time. I haven't been on here too much lately either, too much time playing Far Cry Primal, lol.
Reply
(2017-03-25, 05:54)braz Wrote:
(2017-03-25, 04:11)BobCratchett Wrote: My apologies to you and Braz - I know you both have reported bugs which really need fixing. Whilst my time at present is ridiculously limited, I'm going to do my best to have the fixes on git on Monday,
No rush Bob, take your time. I haven't been on here too much lately either, too much time playing Far Cry Primal, lol.

No rush? Great Smile I'll push fixing your issue back until September at the earliest Tongue
Reply
(2017-03-25, 04:11)BobCratchett Wrote:
(2017-03-21, 14:38)jurialmunkey Wrote: Is there any way to create widget templates for a group that is *NOT* the mainmenu or submenu and *NOT* on the home screen??

It's not something I've ever tried, and I'm basing this not on experience but on how the code works (which, with all those surprises that code regularly turns up, means It probably won't work as expected) but IF you know the labelID of the menu you're building then any submenu or submenuOther template should work if you specify the 'name' parameter to the additional menu you want to build against.

My apologies to you and Braz - I know you both have reported bugs which really need fixing. Whilst my time at present is ridiculously limited, I'm going to do my best to have the fixes on git on Monday,
I couldn't get it to work. Got it to build, but it was adding conditions to match with the mainmenu.

I figured out another solution using includes and params. I think 30 widget items per hub should be enough ha! Although maybe not best practice to have 30 list controls with the same id. I'm not sure how much overhead its going to add if they have no content passed to them, so it seems alright for now.

Thanks for taking the time to look into the bug report. As Braz said, no rush. Although before September would be good Wink Tongue
arctic horizon 2 - alpha release now available.
Reply
When you go to restore menu to defaults is there a way to remove the option Restore an original menu item.... I personal don't need this only reset skin defaults.
Shield TV | Windows 10 | Mariadb | Mii Box
Evolve Ecosystem Repo | TV Melodies | Madnox Holiday Mod
Reply
(2017-03-26, 06:31)smitchell6879 Wrote: When you go to restore menu to defaults is there a way to remove the option Restore an original menu item.... I personal don't need this only reset skin defaults.

https://github.com/BigNoid/script.skinsh...th-gui-308
arctic horizon 2 - alpha release now available.
Reply
Thanks worked like a charm. I guess I should read better.. I get lost sometimes searching for stuff. but thank you.
Shield TV | Windows 10 | Mariadb | Mii Box
Evolve Ecosystem Repo | TV Melodies | Madnox Holiday Mod
Reply
Another dumb question.... I overrode the widget selector sometime back .. I have not edited my main menu from within in the skin since before then ... as that was already the way I wanted... well I went back a few mins ago messing around and went I click on 401 dialog select for the main menu there was nothing there to select.... I managed to get it back working by adding override for common items... but is there a way to revert back to the original ones before and override where added... or is there a complete list of the basic ones I can add into the overrides?
Shield TV | Windows 10 | Mariadb | Mii Box
Evolve Ecosystem Repo | TV Melodies | Madnox Holiday Mod
Reply
(2017-03-26, 08:22)smitchell6879 Wrote: Another dumb question.... I overrode the widget selector sometime back .. I have not edited my main menu from within in the skin since before then ... as that was already the way I wanted... well I went back a few mins ago messing around and went I click on 401 dialog select for the main menu there was nothing there to select.... I managed to get it back working by adding override for common items... but is there a way to revert back to the original ones before and override where added... or is there a complete list of the basic ones I can add into the overrides?

Default overrides.xml file:
https://github.com/BigNoid/script.skinsh...rrides.xml
arctic horizon 2 - alpha release now available.
Reply
Duh... I feel like a idiot... .. guess I should call it a night and go to bed... Thank you again good sir
Shield TV | Windows 10 | Mariadb | Mii Box
Evolve Ecosystem Repo | TV Melodies | Madnox Holiday Mod
Reply
(2017-03-17, 20:33)BobCratchett Wrote:
(2017-03-17, 17:46)axlt2002 Wrote: Thanks for your feedback Bob.

I have actually created a copy of the Estuary skin to be modified and set it as the skin to be used.

The modifications are the ones reported in my previous post. Looking at some other mods, it seems that they are good...just don't work. Confused

Please find hereafter two debug logs as you suggested: the first one is related to the creation of a new menu item called "first trial"...the second is related to restart Kodi...but the changes in the menu are not displayed.

Hope you can help me. Thanks in advance.

OK, the first log shows that the changes you make to the menu are saving correctly. The second log shows that the menu is being rebuilt and the script-skinshortcuts-includes.xml file written without issue.

Next things to check: Smile

Make sure that the item you're adding to the menu doesn't have any automatic visibility conditions added to it, or that the conditions are met. For example, a link to the movies library node won't be visible if there aren't actually movies in your library. Skin Shortcuts Docs: Automatic Visibility Conditions

Then it's a case of checking that you're importing the script-skinshortcuts-includes.xml file and <include />'ing the menu correctly. If you've got the skin on git, give a link to the source and I'll take a quick look to see that it's correct.

Hi Bob,

I had finally time to make some further trials. You were right, there was the automatic visibility condition preventing the item to be displayed. Now everything is ok.

For the time being I'm satisfied. Next step will be the widgets integration...
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
@jurialmunkey - Can you please test the branch here and let me know if that fixes things for you/causes any new issues? Cheers Smile

@braz - Same deal, same branch please Smile (This should only affect using $NUMBER in the label portion of a custom property option - not the value. Hope that's what you wanted!)
Reply
(2017-03-28, 20:59)BobCratchett Wrote: @jurialmunkey - Can you please test the branch here and let me know if that fixes things for you/causes any new issues? Cheers Smile

@braz - Same deal, same branch please Smile (This should only affect using $NUMBER in the label portion of a custom property option - not the value. Hope that's what you wanted!)
Will test tonight, thanks Bob! Does this version also allow one to set a group override of submenu items? Smile

Update: Just tested, that fixed it for me. $NUMBER[] now works for property labels in my overrides.xml.
Reply
(2017-03-28, 20:59)BobCratchett Wrote: @jurialmunkey - Can you please test the branch here and let me know if that fixes things for you/causes any new issues? Cheers Smile

Working beautifully so far. Tested with a number of different conditions and couldn't manage to break it. I'll let you know if I come across anything, but for now it seems to be working as expected. Thanks for the fix! Smile
arctic horizon 2 - alpha release now available.
Reply
OK, the two fixes are now merged into master.

(2017-03-28, 22:01)braz Wrote: Does this version also allow one to set a group override of submenu items? Smile

Nope, this is bug fixes only Smile

Actually, I'm not at all up to date with feature requests that have come through and, to be perfectly honest, whilst I could dig through several pages of the thread to read up on what people want there's always the possibility that they wanted it at the time but have moved onto other things. So I'd request that details of any feature requests - including this one - are opened as issues on the git repo. In some cases they may be looked at, refused and closed. But in other cases, it means there's a single place that can be looked at to easily see what features people want.
Reply
  •   
  • 1
  • 118
  • 119
  • 120(current)
  • 121
  • 122
  • 138
  •   



Logout Mark Read Team Forum Stats Members Help
script.skinshortcuts8
This forum uses Lukasz Tkacz MyBB addons.