Himedia Q5 II and Q10 II guide for XBMC and native external player (and NFS)
#1
I have been trying to get my brand new Himedia box to run XBMC for a while now.

Finally, I managed to find a solution (permanent? I am not sure) to get XBMC running.
I am not a specialist so I might not be able to explain why it works, I've just tried and tried according to information I gathered from many sources.
This guide should help anyone having this box to get XBMC playing any video file locally and from any nfs folders (your NAS for example, my case)

Actually, the Himedia player cannot play video file through network! You will ask "but it works when it is used with the Himedia Media Center". Indeed, it does but there is a trick and I managed to find it and to reproduce it for other media managers as XBMC.
When you use the Himedia Media Center, it temporarily creates in /mnt/ nfs or smb folders. Which means the player thinks video files are local ones!!

What you need:
-XMBC Gotham alpha 11 (Frodo 12.3 does not launch HimediaPlayer whatever I do)
-A modified playercorefactory.xml to automatically launch the native Himedia player
-This FILE to root the box
-Busybox (if you cannot download it from google play, find the apk on google)
-Script Manager (if you cannot download it from google play, find the apk on google)

1. Install XBMC

2. Paste playercorefactory.xml in \sdcard\Android\data\org.xbmc.xbmc\files\.xbmc\userdata (show hidden files to see .xbmc)

At this point you should be able to play any local video.
Now for files on NFS folders.

3. Root you box (works with Q5 II and Q10 II)
-Connect your box to your router by ethernet and write down the IP
-Unrar the file
-Launch Q5-II ROOT.exe (you may have strange signs, don't worry)
-Press any key when prompt
-Type the IP address of your box and press enter
-The box will reboot and it is done
-Quit

4.Install Busybox and launch it to finalize the installation (choose normal installation)

5.Install Script Manager

6.Create a main folder where you want all your NFS folder(s) to be mounted. IT MUST BE ON THE SDCARD!
For example I have created:
/sdcard/nfs
And I have created a sub directory for my video:
/sdcard/nfs/NAS_Video

7.I have created this script:
busybox mount -o nolock,hard,intr,vers=3 -t nfs YOUR.IP.ADDRESS:/volume1/video /sdcard/nfs/NAS_Video
Copy paste in a text file and change IP Address, directory etc etc

FOR SYNOLOGY NAS "volume1" must be added as I did.

If you want more NFS folders mounted (example music) you can add on sub directory and create one more script
Example for
/sdcard/nfs/NAS_Video
/sdcard/nfs/NAS_Music
The scripts should be
Script 1 :
busybox mount -o nolock,hard,intr,vers=3 -t nfs YOUR.IP.ADDRESS:/volume1/video /sdcard/nfs/NAS_Video
Script 2:
busybox mount -o nolock,hard,intr,vers=3 -t nfs YOUR.IP.ADDRESS:/volume1/music /sdcard/nfs/NAS_Music

I tried to put both lines in the same script but I don't why it does not work. I am pretty sure it is possible but as I said I am not a specialist.

Save it/them somewhere on your sdcard (at the root in my case)

8. Launch ScriptManager
-Select your script (when prompt select text script)
-Run it to test
-If nothing wrong check with a file manager (ES File Explorer for example) that you have you nfs folder(s) mounted
-Go back to Script Manager
-Select your script again
-Select Boot and SU
-Save
Do it again if you have more than one script

DONE!

Reboot you box and check again in ES File Explorer

Next time in XBMC to add new video files, choose Android root file and select your mounted folder(s).

I have this solution working for me for now.
I hope it will help a lot as it seems many have been trying to get XBMC on Himedia
And don't forget to directly launch XBMC at start up (use himedia application manager for that)

One issue is Internet streaming, the default XBMC player crashes all the time with Gotham while it works perfectly with Frodo (but Frodo does not work with HimediaPlayer)...Maybe in the coming beta it will be fixed.
Reply
#2
Mittel
This is awesome. I have been looking for something like this for a while. Thank you for posting. I will also attempt get mine going this weekend, and I'll post some of my findings, if any..
One question: Which fw did you start with? 1.04 or 1.05 .. And which version of the box do you have, the “en” or the “eMMC” version..

Thank you for posting.
Reply
#3
I have the non eMMC version and the 1.05 firmware, but I see no reason it would not work on eMMC or other firmwares.

One thing that still does not work is internet streaming (XBMC addons like TV etc). I tries with the XBMC player, MXPlayer .... but with no success
Reply
#4
I have the q10 II eMMC version and have just installed this version of xbmc and it works a treat. If you are going to use Istream (xbmx addon for streaming) I would recommend uploading the modded playercorefactory.xml and have the inbuilt dvd player (xbmc as default)
http://www.mediafire.com/download/o4cprb...player.apk

Works a charm. 3d and HD Audio for direct images / files played from within xbmc.
Reply
#5
Hello,
It looks great! I just got a himedia. This device is very good and at a very good price In Asia. Does anyone know if this tutorial work on q10 II plus ?
Thanks by advance.
Reply
#6
hello! one moment to the other one stopped working my box Himedia Q10II with (xbmc frodo). TV says "Mode not supported". What can I do? I tried them different two TV(samsung LED) and HDMI cable. How can I fix the problem? (Without reset screen? reset or something? Sombody can help me?Thanks!
Reply
#7
Hi everyone !!
Hope anyone can help me with this. Ive just bought a new HIMEDIA Q10ii player with the only one intention of watching 3D iso movies.
I must said that Im really dissapointed. 3D is unwatchable.
Dont know if there is something wrong with the configuration but its impossible to watch not even for a minute.
Its not easy to explain but its like watching something thats not making foccus. During a scene you have to unface the tv again and again because its really disturbing.
I own a Playstation 3 and watch 3D blurays all the time. And everything is perfect.
Have anyone experienced this with your players ?
Thanks in advance !!
Reply
#8
Hi

@ cyberphil: this - really good - tutorial works on g10II (plus) as well.
@ zoltanhu: there should be no problem. Take a look in the system settings of xbmc, your himedia and your TV. You should first try to setup it all on 720p and - if this works - after that change it all to 1080. In my opinion the resolution in xbmc is only important for the graphics and not for the videos but maybe that your TV has a problem with it
@ e007la: I'm sure that you are using the firmware 1.05 These firwae has unfortunatly a bug with 3d-video. You should download and install the new firmware 1.06 beta. You can dowmload it f.i. here: http://www.myhdplayer.de/Android-TV-Box/...bpbu51deh1

If one of you are germans or you are able to understand german then I can recommend to you this forum:
http://www.himedia-player.de/

SaEt9000
Reply
#9
(2014-04-08, 20:26)SaEt9000 Wrote: Hi

@ cyberphil: this - really good - tutorial works on g10II (plus) as well.
@ zoltanhu: there should be no problem. Take a look in the system settings of xbmc, your himedia and your TV. You should first try to setup it all on 720p and - if this works - after that change it all to 1080. In my opinion the resolution in xbmc is only important for the graphics and not for the videos but maybe that your TV has a problem with it
@ e007la: I'm sure that you are using the firmware 1.05 These firwae has unfortunatly a bug with 3d-video. You should download and install the new firmware 1.06 beta. You can dowmload it f.i. here: http://www.myhdplayer.de/Android-TV-Box/...bpbu51deh1

If one of you are germans or you are able to understand german then I can recommend to you this forum:
http://www.himedia-player.de/

SaEt9000

SaEt9000, thanks so much !! I will try as soon as possible.
These last two day I've been experimenting with this player and I have a couple of questions:
The first one is about the fluorescent display. Does it only shows the actual time. What about the elapsed time while watching a movie. Is there any settings for changing this ? I used to do that with my old Himedia 600b !!
The second thing is about movie covers. I've heard that xbmc does show covers of movies stocked on internal or external drives. Is it correct ? If I installed this xbmc apk will I still be able to use the default player ?
Thanks again.
Reply
#10
Hi,

because of the display:there is no option to change it at the moment. Maybe, that there will be an additional option in future firmware-versions...

It is right: the covers will be saved in different local folders.

If you are using xbmc you can still use your himedia-mediacenter with all local players.
If you are able to configure your xbmc, than you can use your local himedaiVideoplayer as external player for xbmc. It works good - the exception is Bluray.iso or bluray-folder. Until now there is no solution. But that is not a problem of your himedia, xbmc is not able to play bluray.iso with external videoPlayer until now.

SaEt9000
Reply
#11
(2014-04-09, 12:18)SaEt9000 Wrote: Hi,

because of the display:there is no option to change it at the moment. Maybe, that there will be an additional option in future firmware-versions...

It is right: the covers will be saved in different local folders.

If you are using xbmc you can still use your himedia-mediacenter with all local players.
If you are able to configure your xbmc, than you can use your local himedaiVideoplayer as external player for xbmc. It works good - the exception is Bluray.iso or bluray-folder. Until now there is no solution. But that is not a problem of your himedia, xbmc is not able to play bluray.iso with external videoPlayer until now.

SaEt9000

Hi again !!
I installed xbmc yesterday and it seems to work fine.
The only thing I dont understand is how to make it automatically download covers and information of my movies.
When I go to MOVIES I am able to see the movies storaged on my hard disk but the only cover I see is the jpg I already had on each movie folder. I dont see the ones that xbmc was supposed to download or the movie information either.
What I'm doing wrong ?
Reply
#12
eMMC for 1.06 Q5 ii Q5II: http://pan.baidu.com/s/1eQgO1eq ..i have no problem installing & running XBMC 12.2 or 12.3 with old 1.04 firmware..thanks for the guide
Reply
#13
guys i tried to mount my network drive into Himedia Q16 , but i got this error.. please help

Image
Image
Reply
#14
Hi,

I am new. Just bought a Q5II emmc version,firmware 1.0.6. I just install the gotham 13.1 on my Q5II himedia. Whenever i start to stream any stuff,icefilms,yify or 1 channel etc. The application will crash and shut down. Do we have any fix for this? i tried to follow your instruction but I am stuck at

point 2 Paste playercorefactory.xml in \sdcard\Android\data\org.xbmc.xbmc\files\.xbmc\userdata (show hidden files to see .xbmc).

Thanks in advance!
Reply
#15
(2014-06-24, 07:34)Hydeyuki Wrote: Hi,

I am new. Just bought a Q5II emmc version,firmware 1.0.6. I just install the gotham 13.1 on my Q5II himedia. Whenever i start to stream any stuff,icefilms,yify or 1 channel etc. The application will crash and shut down. Do we have any fix for this? i tried to follow your instruction but I am stuck at

point 2 Paste playercorefactory.xml in \sdcard\Android\data\org.xbmc.xbmc\files\.xbmc\userdata (show hidden files to see .xbmc).

Thanks in advance!

you can check setting/Video/Acceleration. Try enabling libstagefright and disabling mediacodec.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Himedia Q5 II and Q10 II guide for XBMC and native external player (and NFS)00