Bug -  Low quality audio over Bluetooth headphones
#1
I've got a set of bluetooth headphones that work fine with OS X, but as soon as XBMC starts playing a file, the quality goes to crap and the Bluetooth audio codec gets changed to SCO from SBC. Before I play a file, the UI audio in XBMC works just fine over the headphones. Quitting XBMC restores the better codec.

I can't figure it out at all. I've tested in 14.0 alpha 3, and the issue persists.

System specs:
Mac mini (Mid 2011), 10.9.4, XBMC 13.2.

Any ideas? I'm at my wits end...

Thanks!
Reply
#2
I was able to work around this by forcing XBMC to use the "Fixed" output configuration, with sampling rate limited to 44.1 kHz.

Irritating, and bizarre.
Reply
#3
Not so bizarre - XBMC selects best match - if your source is 48000 hz and your audio device (the headphones) suggest they support it - it might just select it. But 48000hz also results in more data sent which might be to much for the bluetooth bandwidth - so the quality is reduced.

Just really guessing here - but why not?
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#4
(2014-09-04, 17:01)drunkensailor Wrote: I was able to work around this by forcing XBMC to use the "Fixed" output configuration, with sampling rate limited to 44.1 kHz.

Irritating, and bizarre.

Same issue here. I can confirm that your solution works. I think this is somewhat related to bluetooth devices that offer multiple audio profiles (headphones and high quality audio).

Hoping it will be resolved soon.

Thanks!
Reply
#5
I don't know how this should be solved on my side tbh.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#6
Fixed. Thanks a lot.
Reply
#7
Confirmed as a solution here too, Kodi RC1, OSX, Bose headset.
Reply
#8
Solution works like a charm!
Reply
#9
The fixed 44.1 kHz solution does not work any more, any other suggestions to solve this?
Reply
#10
44.1 kHz solution worked for me (MBP 2017)
Platforms: Windows 10 - OS X - iOS - OSMC (Vero 4K)
Reply
#11
(2017-07-17, 09:57)tripkip Wrote: 44.1 kHz solution worked for me (MBP 2017)
 Not trying to necropost, but I thought it would be helpful for future Googlers (such as myself) that this solution is STILL the solution to this issue, clear up to KODI 17.6, December 2017. (You have to enable advanced view in the lower left hand corner to see these settings users are talking about). Fixed Output and 44.1 fixes it.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Low quality audio over Bluetooth headphones00