Req PVR add-on for MediaPortal 2?
#31
A few notes around my experiences of using the MP2 release together with Kodi:

I am since two days running the MP2 sunner release server and it is much more stable than the MP1 release. The engine is still the same with some dead-locks when stopping and restarting just as for MP1 (I need to reboot the computer when the TVservice needs to be restarted, almost every time). My dead-lock issues are likely connected to me using the DvbSky T980c card with CI/CAM. But that card and my TBS5881 with CI/CAM are working much better on MP2 than MP1 still. My other TV-cards are however working flawlessly under MP2, they were a bit flaky on MP1 though. The software around the TV-service seems to be a bit better in MP2 which Kodi-support benefits from.

I recommend to run a clean install and to import any configuration from MP1 (exported from there). It is not recommended to run MP1 and MP2 together, at least I had issues with information leakage between them (did not understand why though).

I had some issues to install the Kodi-plugin, until I understood that it should not be installed in "C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\", but rather in "C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\SlimTv.Service3\Plugins", note that the TV-service has it's own plugin-directory! It would be great if that could be described in the installation instruction, because it took me quite some time to realize that (and a file search for otehr plugins dll-files until I realized the path to use).

But overall, I have almost only positive experience from upgrading to MP2 as a PVR backend for Kodi. Some plugins are still not supported in MP2, which means that I can't get a web-interface for the server, but RDP logins works quite well also...
Reply
#32
Using the new server plugin results in an empty EPG in Kodi for me. The channels import fine and I can tune them all. No guide data though.
The guide data is fine inside MP2. I'm using guide data downloaded with zap2xml. I have done several installs with the same results.
Reply
#33
(2016-01-23, 07:16)boke Wrote: Using the new server plugin results in an empty EPG in Kodi for me. The channels import fine and I can tune them all. No guide data though.
The guide data is fine inside MP2. I'm using guide data downloaded with zap2xml. I have done several installs with the same results.

I get that on Android, but not for OpenElec on RPi2. I haven't looked into what differs yet,

Hmm, maybe my EPG data from MP1 is still active in my RPi? I have seven days ahead stored. Need to check that out when I et home again...
Reply
#34
[quote='boke' pid='2223174' dateline='1453526207']
Using the new server plugin results in an empty EPG in Kodi for me. The channels import fine and I can tune them all. No guide data though.
The guide data is fine inside MP2. I'm using guide data downloaded with zap2xml. I have done several installs with the same results.

I have the same results with no guide data inside of Kodi and I am using mc2xml for guide data.
Reply
#35
I have now noted that I have the same issue as well. It was the Kodi DB that wasn't cleaned out when I moved from MP1 to MP2 (I had seven days of data stored). Does anyone have a work-around at least?

I will try to use "TV-guide" plugin and store my data in xmltv-format for reading from the Kodi plugin. Have tried it locally on my TV-server and it seems to work, now I just need to test it on my raspberry when I get back home.
Reply
#36
Hi.
In the MediaPortal forum there also is a thread about this topic.
http://forum.team-mediaportal.com/thread...te.131516/

If anyone needs to know something about MediaPortal2 Server and/or TV engine you are welcome to ask there too..
The MediaPortal2 devs are willing to help solving this so it should be possible to get the MP2 server working as backend for Kodi PVR soon.
Reply
#37
(2016-01-23, 07:16)boke Wrote: Using the new server plugin results in an empty EPG in Kodi for me. The channels import fine and I can tune them all. No guide data though.
The guide data is fine inside MP2. I'm using guide data downloaded with zap2xml. I have done several installs with the same results.
Found the problem. I was issuing an incorrect EPG query when using SQLite as backend database.
The problem should be solved after updating your TVServerKodi plugin to TVServerKodi plugin v1.12.0.131.
You can download the latest version from the TVServerKodi plugin website or using this direct link.

@Lehmden: thanks for the link and offer for support. I will post this fix also at the Mediaportal forum.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#38
(2016-01-31, 21:00)margro Wrote:
(2016-01-23, 07:16)boke Wrote: Using the new server plugin results in an empty EPG in Kodi for me. The channels import fine and I can tune them all. No guide data though.
The guide data is fine inside MP2. I'm using guide data downloaded with zap2xml. I have done several installs with the same results.
Found the problem. I was issuing an incorrect EPG query when using SQLite as backend database.
The problem should be solved after updating your TVServerKodi plugin to TVServerKodi plugin v1.12.0.131.
You can download the latest version from the TVServerKodi plugin website or using this direct link.

@Lehmden: thanks for the link and offer for support. I will post this fix also at the Mediaportal forum.

Works great now. Thank you!
Reply



Logout Mark Read Team Forum Stats Members Help
PVR add-on for MediaPortal 2?0
This forum uses Lukasz Tkacz MyBB addons.