Win The Newest version of MediaPortal TVServer - TVServerXBMC plugin
#46
Hmmm....about Perlians problem, mayby the instructions are not explicit enough:
http://kodi.wiki/view/MediaPortal_TV-Server

The SMB account info defaults to empty, so should the instruction state that either the user should:
1) fill the info with some existing account on his mediaportal-server. Might even need instructions how to decide/find the account to ne used...
2) or configure the windows sharing settings on the mediaportal server so that it does not require account at all

...many users might have set an auto-login account on their mediaportal box...so they don't realize that for remote access they should fill that info...if they even happen to remember which accounts exist on their mediaportal-server-box...
Reply
#47
(2015-10-13, 05:06)karniemi Wrote: 2) or configure the windows sharing settings on the mediaportal server so that it does not require account at all

I had it configured like 2). Sharing was wide open (Everyone, Full control) so I also expected that an account was not necessary at all but even then I needed an account.
Reply
#48
With 2., I meant: "Password protected sharing" disabled in Network and Sharing Center...
Reply
#49
Can someone upload or email the server dll? the dropbox link is down again and I have MP up and running and want to try it with Kodi

thanks!
Reply
#50
I am also hoping to upgrade my server to the latest plugin version could anyone provide a link to v1.12.0.129? The dropbox links on the page linked in the wiki are down.

Many thanks

Jolltax
Reply
#51
the link to the newest plugin is broken, can someone upload the TVServerKodi plugin v1.12.0.129 for download?

thx
Reply
#52
The dropbox links work fine here (maybe a temporary problem). I've added a mirror on my Google drive:
TVServerKodi download mirror
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#53
(2015-09-27, 23:20)Perlian Wrote: Just started today installing my raspberry pi 2 with openelec xmbc kodi with mediaportal as backend pvr. I followed all manuals but my live TV refuses to stream to my rpi 2. The only time it worked was when i selected ffmpeg instead of tsreader in the xmbc addon. This resulted in a greenish kind of blurred image. Everything else is working in the addon. I have EPG data, can see my recordings and I am able to play them.
Not sure if this was the result of a buffer/network problem or the not activated mpeg2 codec. My MediaPortal works on a Windows 7 remote client via the network without any problems (LiveTv-buffer is stored on a RAM-disk so should be fast enough). So I just want tot make sure by asking here, can you use tsreader within the addon with MePo on a Windows 7 machine? Or do I need tot use the ffmpeg way of playback in the xmbc addon on a raspberry rpi 2?

If I use the tsreader on my raspberry I always get a not allowed error as if the live TV and recorder TV are not shared correctly but I know that this not a problem since I was able to get it working via ffmpeg playback.

I had the same problem. As always when I'm entering username and password to access network shares, I enter the username in the follwing form: servername\username. BUT I found out that this does not work in the MP Kodi plugin. Had to use only username. And I also had to open tcp/9596 port in W10Pro's FW. Now everything is working perfect. Wink
Reply
#54
Big THX margro fpr the new Plugin v1.12

channel change speed is ok, but with XBMC 13 it was faster

Is there any way to optimize?
Reply
#55
Sorry to bother you but I am not able to install the TVServerKodi plugin v1.12.0.129 on the TVServer of MediaPortal.

I am using: MediaPortal 2 summer, Kodi 15.2 in a single seat constellation on Window 10.

Gentle.config has been changed in: <Provider name="SQLite" assembly="Gentle.Provider.SQLite" / -->
Having understood that MediaPortal 2 database works with SQLite. Am I wrong?

After having activated TVServerKodi.exe in Plugin of MediaPortal ServerTV gave this result:

TvServer Debug EXE: 1.12.0.129
Connected to the MediaPortal TVServer running on: 'localhost'
Referenced assemblies:
TvControl version=1.12.0.0
TvDatabase version=1.12.0.0
TvLibrary version=1.12.0.0
An exception occurred while connecting to the database. Did you select the right backend? TVServerKodi default=MySQL; change your Gentle.conf file if you are using MSSQL.
The exception: System.Runtime.Remoting.RemotingException: Der angeforderte Dienst wurde nicht gefunden.

Server stack trace:
bei System.Runtime.Remoting.Channels.BinaryServerFormatterSink.ProcessMessage(IServerChannelSinkStack sinkStack, IMessage requestMsg, ITransportHeaders requestHeaders, Stream requestStream, IMessage& responseMsg, ITransportHeaders& responseHeaders, Stream& responseStream)

Exception rethrown at [0]:
bei System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
bei System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
bei TvControl.IController.GetDatabaseConnectionString(String& connectionString, String& provider)
bei TVServerKodi.Commands.Program.Main(String[] args)
Starting debug version of the TVServerKodi plugin
The database backend (provider MySQL) could not be reached.
Check the connection string: Server=home;Database=MpTvDbRC2;User ID=sa;Password=sa;charset=utf8;Connection Timeout=300;
TVServerKodi has problems connecting to the database. Check your settings (Gentle.config)
Press Enter to exit.

Apparently this plugin do not occur in the MediaPortal TVserver plugin list. There is nothing to activate.

Could you help or hint?
Thanks in advance!
Reply
#56
Louis119, check http://forum.kodi.tv/showthread.php?tid=204882
Reply



Logout Mark Read Team Forum Stats Members Help
The Newest version of MediaPortal TVServer - TVServerXBMC plugin0
This forum uses Lukasz Tkacz MyBB addons.