• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 17
  •   
  Thread Closed
Kodi v14.2 beta testing (includes fixes for crash problems seen in 14.0 & 14.1)
#1
While these are test builds for a bugfix version, they are still test builds and could possibly be unstable. Proceed with caution and always backup (wiki) your settings!


What is this:
  • These are test builds for anyone who would like to help with testing the Kodi v14.2 bugfix release to find a solution for the crashing of webserver
  • No new features have been added to this version.
  • Only bug fixes have gone in.
The main aim of this thread is to help identify the core issue of the crashing on 14.0/14.1 Windows builds.



How to help:

  1. If v14.0 was crashing and still crashing with v14.1 OR something was working in v14.0 and is now broken in v14.1: This is the main thing we want to know about. Please include in your post:
    • Say if this was also an issue in v14.0/14.1 or not.
    • A debug log (wiki)
    • The build date (in the download URL or in system info on Kodi). Specify which one you tried.
    • Details about your system (OS, hardware specs, etc)
    • Steps needed to reproduce the issue (play a movie, go to a file list, use an add-on, etc)
    • The more details, the better.

  2. If something was broken in v14.0 and is now fixed in v14.2: feel free to post about that. Confirmation is always nice.

  3. If something was broken (but not crashing) in v14.0 and is still broken in 14.1: please do not report it in this thread unless it's something we specifically asked to be tested. Report those bugs/issues in a new thread.



Where to download:
RC1 builds can be downloaded from
http://kodi.tv


Changes:
Changes for v14.1/14.2 are listed here: https://github.com/xbmc/xbmc/commits/Helix
and on top we do add several commits that should hopefully fix the crashing.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
#2
Okay i'll get the party started.
Been without internet for a few days (Not of my choosing).
Anyway i see there is a new build, but i would still like to submit 4 Crash from the old version since i also submit 1 crash from the new version, meaning whatever it was it's not fixed.

4 crashes over about 3-4 days spand, using this version 1899641 (post)
This *.rar contains:
4xFolders
All with
1x Kodi.log
1x xbmc_crashlog
1x xbmc_stacktrace
https://www.dropbox.com/s/fwowter5sobpye...n.rar?dl=0

And as promised a crash on the new one. Made as described here, and also in the posts here.
Quote:To make it crash i started a TvShow episode then i opened Yatse app on my smartphone and navigated to the "Now Playing" screen (basically is the second screen when you swipe left from the app's main screen) and "dang" Kodi crashed.
1898477 (post)

This *.rar contains
1x Kodi.log
1x xbmc_crashlog
1x xbmc_stacktrace

https://www.dropbox.com/s/x3ykq58clkuzjh...e.rar?dl=0
#3
@Kiggerbare : Hi mate, did you tested the build from 22/01 (post #199 from the "old" thread)? For me that build is still running without a single crash and no test build so fast last that much.
Also if i got it right the build in this thread is indeed based on 14.1 branch but it doesn't have Karlson2k's commits/fixes yet ( someone please correct me if I'm wrong).
#4
The build in the first post is this build:
1902022 (post)

with karlson2k fixes, IE post 208, which should include the setlocale fixes which we think are likely to be the cause of most issues around webserver api calls.

The other build is from an older post, which doesn't have the setlocale fix.
#5
(2015-01-26, 19:25)cg110 Wrote: The build in the first post is this build:
1902022 (post)

with karlson2k fixes, IE post 208, which should include the setlocale fixes which we think are likely to be the cause of most issues around webserver api calls.

The other build is from an older post, which doesn't have the setlocale fix.
Thx for clearing this up. In this case i will switch to this build too so you guys can get more feedback. Cheers and keep up the good work!
#6
Been using the build from 23 January on win 7 for several hours now, playing music and music videos from a NAS and heavily fiddling around with ios and android remotes. No crash so far.
#7
Guess I shouldn't have posted that. After listening to radio using the ListenLiveEU addon Kodi crashed. I uploaded logs. etc. to this ticket.

http://trac.kodi.tv/ticket/15725
#8
First post updated with new build.
Now it includes additional fixes from Helix pre-14.1 branch.
#9
(2015-01-27, 00:54)DarkHelmet Wrote: Guess I shouldn't have posted that. After listening to radio using the ListenLiveEU addon Kodi crashed. I uploaded logs. etc. to this ticket.

http://trac.kodi.tv/ticket/15725

Appears that trac is down Sad However, I can repro the listenliveeu addon issue.

It appears to be an issue with python (so a different crash from the web server one) around re-initializing the python engine after it's unloaded.

Firstly it's crashing on finalize, but something silently throws it away. This is because there's no main thread state saved from initialize, IE in this code path:
https://github.com/Karlson2k/xbmc/blob/w...n.cpp#L566

Once that was fixed the re-init would lock up. This appears to be because on re-init the GIL lock is needed. To fix this I've moved the code to take the lock if threads were initialized before calling PY_Initialize.

So the area of code from:
https://github.com/Karlson2k/xbmc/blob/w...n.cpp#L541

Ends up looking like:
Code:
    if (PyEval_ThreadsInitialized())
      {
          // This is not first Python initialization
          CLog::LogF(LOGDEBUG, "Python threads were already initialized");
          PyEval_AcquireLock(); // Acquire GIL
      }

      Py_Initialize();

      // If this is not the first time we initialize Python, the interpreter
      // lock already exists and we need to lock it as PyEval_InitThreads
      // would not do that in that case.
      
      if (!PyEval_ThreadsInitialized())
      { // First Python initialization, current thread is registered by Py_Initialize()/PyEval_InitThreads()
          CLog::LogF(LOGDEBUG, "Initializing Python threads");
          PyEval_InitThreads(); // Also acquire GIL
      }
      {
          PyThreadState* curThrPyState = PyGILState_GetThisThreadState();
          if (curThrPyState != NULL)
          {
              CLog::LogF(LOGDEBUG, "Current thread was already registered in Python");
              m_mainThreadState = curThrPyState;
          }
          else
          {
              CLog::LogF(LOGDEBUG, "Current thread was not registered in Python");
              m_createdThreadState = PyThreadState_New(PyThreadState_Get()->interp); // No need for NULL check as NULL is a fatal error
              PyThreadState_Swap(m_createdThreadState);
              m_mainThreadState = m_createdThreadState;
          }
      }

At this point it seems like livelisteneu doesn't crash/hang on me. (but that doesn't mean there aren't more lurking issues in the python, as I think karlson2k's been working on that area)
#10
Another crash here.
*.rar contains:
Kodi.log
2x crashlog *.dmp
Stacktrace.log

https://www.dropbox.com/s/icko48qic6xy34...h.rar?dl=0

EDIT: This is using the "26 January" Version in the first post.
#11
Kodi crashes on updating database (mostly music) after starting. I'm using the "Universal Album Scraper". The GUI hangs, the update thread continue with his work (seeing the logfile grows after the GUI hangs).

Using version from post #1
Windows 7 x64 with MySQL-Database.

Logfile, Screenshot with time, crashlog and stacktrace can be find here.

Edit:
This was also an issue in v14.0.
#12
Using KodiSetup-20150126-3b82da0-w32_fix_crash_h.exe build, Kodi will not restore/maximize after being minimized. To repro start video playback, minimize Kodi and then maximize it. The audio will keep playing but the screen goes blank. Sometimes I'm able to press X and return to the application after this the UI is corrupted.

debug xbmc.log: http://xbmclogs.com/show.php?id=405576
XBMC crashlog: http://xbmclogs.com/show.php?id=405577
#13
(2015-01-28, 01:06)drpizznock Wrote: Using KodiSetup-20150126-3b82da0-w32_fix_crash_h.exe build, Kodi will not restore/maximize after being minimized. To repro start video playback, minimize Kodi and then maximize it. The audio will keep playing but the screen goes blank. Sometimes I'm able to press X and return to the application after this the UI is corrupted.

debug xbmc.log: http://xbmclogs.com/show.php?id=405576
XBMC crashlog: http://xbmclogs.com/show.php?id=405577
If i remembered correctly i also had that issue, but with a test build from 22 /01, and that was based on the 14.0 branch.
#14
New build in the first post.
Now with the same fixes that used to fix crashing on Android x86.
#15
Another crash using the 26 january version.
So switching to the new now..

Anyway, *.dmp and stacktrace log was empty.

https://www.dropbox.com/s/fhmk28bb5vce0d...h.rar?dl=0
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 17
  •   
  Thread Closed
 
Thread Rating:
  • 3 Vote(s) - 3.67 Average



Logout Mark Read Team Forum Stats Members Help
Kodi v14.2 beta testing (includes fixes for crash problems seen in 14.0 & 14.1)3.673