•   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 56
  •   
WIP Windows DirectX 11 upgrade test thread
(2015-06-22, 14:42)afedchin Wrote: @tungmeister, Memphiz is right. The "quality" of shadertoy screensaver/visualization depends on float precision. In DX11 float precision depends on your hardware and drivers. I also want to say that nothing has changed in this regard.

Well I'm running a GTX 970 and I'm using the same drivers as I was with the previous build?
Reply
Well I don't know exactly why you faced with this. I haven't get this on my Intel HD4600 which is less powerfull than yours, but I have the same effect on my HD2000. Try to play with settings in NVidial Control Panel.
Reply
(2015-06-23, 20:23)afedchin Wrote: Well I don't know exactly why you faced with this. I haven't get this on my Intel HD4600 which is less powerfull than yours, but I have the same effect on my HD2000. Try to play with settings in NVidial Control Panel.

I'll have a play when I'm home and report back.
Reply
Just as info:

The DX11 build fixes video freezing with TV recordings and LiveTV TS when seeking and play/pause.

This issue was persisted in 14.2, 15b1 and 15b2

If background info is needed please tell me.
Reply
@afedchin
i added the dxva hd scaling = true and played some videos. The only options is could chose from were dxva/auto.
I haven't got any interlaced video to try out. The rest looked fine.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
@Martijn,
Did you add setting to <video> section?

Edit:
as.xml should contains
Code:
<video>
  <dxvaallowhqscaling>true</dxvaallowhqscaling>
</video>
Reply
With this tests versions everything seems fine but no matter the skin i cannot control in pvr the channel numbers. Normally in argustv i set there the order and i choose in livetv section to follow the pvr backend numbering but its a no go. If i try with kodi channel manager to rearrange the channels i end up with all the channels with 0 number.
What i don't know is if this is a isenguard problem generic or this specific version here.
For the rest all seems fine and faster with a bit of pixelating in sd channels (nvidia 970 latest drivers)
There's no substitute for experience
Reply
(2015-06-25, 21:07)afedchin Wrote: @Martijn,
Did you add setting to <video> section?

Edit:
as.xml should contains
Code:
<video>
  <dxvaallowhqscaling>true</dxvaallowhqscaling>
</video>

still no DXVA-HD
http://www.xbmclogs.com/pgrzl31ut
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
Afaik, this advanced setting just enables the HQ PS scalers in DXVA rendering mode, ie. it controls whether the setting "Enable HQ scalers for scaling above ..%" has any effect at all when using the DXVA renderer.
The "DXVA-HD" renderer is DX9 technology, isn't it? So I guess you won't find it in a DX11 program :-)
Reply
Well @afedchin asked if i could test it so Smile
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
Guess I'm wrong then... Anyway, I can only see DXVA as well (Intel HD 4600 and Intel G45).
Reply
(2015-06-21, 23:13)afedchin Wrote: If you can provide a better solution, it's a good time. We all can test it before dx11 will be merged.

I've created a couple of patches that add an option "Always on top". This setting already existed as an advanced setting, but only worked (somewhat) in windowed mode. So I added support for full screen mode and made it a GUI option instead of an advanced setting (since it's actually useful now).

It works pretty well so far, but I can only test with Intel (HD4600 and G45).

You can find it here: https://github.com/Shine-/xbmc/tree/alwaysontop
Reply
(2015-06-26, 21:58)Martijn Wrote: Well @afedchin asked if i could test it so Smile
@Martijn, Shine is right. This enable PS HQ scalers with DXVA renderer. In DX11 no more DXVA and DXVA-HD, there is only d3d11 video processing which is called DXVA in Kodi (so as not to cause surprise Smile) As I saw in your log all works as expected, so I think we can enable HQ scalers by default.

@Shine I'll take a look. But always on top for full screen mode sounds strange. This mode is already top most.
Reply
Was there any 100% reliable way to replicate the problems with the HQ scalers, I've never used them but have 2 PC's with Nvidia I could test on.
Reply
@jjd-uk
IIRC the problems occurs on NVidia cards with dxva renderer and HQ scalers. But I can be wrong. here is thread with discussion http://forum.kodi.tv/showthread.php?tid=...va+scalers
Reply
  •   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 56
  •   
 
Thread Rating:
  • 6 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
Windows DirectX 11 upgrade test thread3.56