•   
  • 1
  • 501
  • 502
  • 503
  • 504(current)
  • 505
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2019-12-05, 07:25)IT007 Wrote: The Kodi keep alive setting never did anything for me, only that registry fix.  I always use external LAV filters myself, be sure to keep those up to date. Could it be an Atmos thing? One thing you could try is decode everything in LAV audio and send LPCM to test. If it works, you could only use bitstreaming with dolby. 

I'm running out of ideas but this add-on Add-on:Unpause_Jumpback (wiki) could make it a little less annoying. If the delay is constant use that and set it to rewind like 5 seconds.

Yeah, in the process of ruling everything else out. I did install that addon already as well, having it set to jump back 10 seconds. What is odd is that if I pause and unpause like 2 seconds later, then I only loose like a second of audio. But if I leave it paused for say 1-2+ minutes, then its between 5-8 seconds delay.
Reply
(2019-12-05, 18:07)sp90378 Wrote:
(2019-12-05, 07:25)IT007 Wrote: The Kodi keep alive setting never did anything for me, only that registry fix.  I always use external LAV filters myself, be sure to keep those up to date. Could it be an Atmos thing? One thing you could try is decode everything in LAV audio and send LPCM to test. If it works, you could only use bitstreaming with dolby. 

I'm running out of ideas but this add-on Add-on:Unpause_Jumpback (wiki) could make it a little less annoying. If the delay is constant use that and set it to rewind like 5 seconds.

Yeah, in the process of ruling everything else out. I did install that addon already as well, having it set to jump back 10 seconds. What is odd is that if I pause and unpause like 2 seconds later, then I only loose like a second of audio. But if I leave it paused for say 1-2+ minutes, then its between 5-8 seconds delay. 

Well, I take this back. I just below through the registry edit and just went back and realized the 0000 subkey was a Microsoft one and not Nvidia. Found the one with Nvidia and updated those ones and the issue is resolved! I put the commands in a reg edit file so I can easily update them if a drive update or something ever reverts the change back. 

Thanks a ton guys!!
Reply
No problem, I had that problem for a long time too before finding the fix.
Reply
(2019-12-05, 20:07)IT007 Wrote: No problem, I had that problem for a long time too before finding the fix.

The odd thing is though that I never had this issue when I had the Yamaha receiver. I upgraded it because I got a Fire TV Cube 2nd gen, and will use that now for Netflix, etc. for HDR/DV support, but found the receiver did not have DB support, so I replaced it with this Pioneer (as I would have done another Yamaha, but I got a great deal on the Pioneer, and I wanted to upgrade from 5.1 to 5.1.4 so needed the extra channels). So either the power saving mode never happened, if its related to HDMI negotiation, OR the Yamaha just did not care and used what was the last audio through it, so it would not drop audio, renegotiating from scratch.

Oh well. Glad its fixed now though Smile
Reply
Yeah it must be a combination of things that causes it, I'm pretty sure I got it after upgrading my GPU.
Reply
is there any way to apply and toggle a filter in DS like you can with MPC-HC, there is a bug with AMD 5700 cards where incorrect gamut is selected for HDR ( for some users), fix is to apply this shader by Alexkral ober on DOOM9

i could obvioulsly just use MPC as an external player for HDR but I dont want to do that.
Reply
Check the DSPlayer set up guide. You can add shaders by creating media rules that include any attached shaders.

You could even use the starter files provided as a starting point and modify them. They include rules to route each file type to the correct external filters.

The required external filters include LAV Filters and an installation of XySubFilter.
Reply
(2019-12-11, 00:28)Warner306 Wrote: This is a bit beyond me, instructions assume knowledge I dont have. 

I first put the shader I want to use called HDRFIX in

T:\KODI DS4\system\players\dsplayer\Shaders

Next I added to shaders.xml

  </shader>
<shader name="HDRFIX" id="22">
    <path>HDRFIX.hlsl</path>
    <profile>ps_2_0</profile>
</shaders>


Now I edited the MKV line in mediaconfig.xml like so, this was just to apply the shader to all MKV files first to see if it worked, it did nothing, where have I gone wrong, i'm trying at least Smile


<rule filetypes="mkv">
  <shaders>
        <shader id="22" />
      </shaders>
      <source filter="avsource" />
      <splitter filter="avsource" />
      <video filter="mpcvideodec" />
      <!-- You can do like that to specifie a DXVA only filters.
      If you want to use the same filter for DXVA and non DXVA media, just add
      a single <video> line.
      <video>
        <video dxva="true" filter="mpcvideodec" />
        <video filter="mpcvideodec" />
      </video> -->
      <audio filter="ffdaudiodec" />
      <!--<extra>
        <extra filter="ac3filter" />
        <extra filter="dcgraphiceq" />
      </extra>-->
Reply
I recently discovered that the following issue reported in this thread impacts 64-bit Kodi DSPlayer users who use Apollo Lake, Gemini Lake, and (as I found myself as a Surface Pro 7 user) Ice Lake processors as well as quite possibly other recent (circa 2016 and later) families of Intel processors. As an avid AMD'er with access to all families of Ryzen processors, I can confirm that all AMD processors (Zen, Zen+, and Zen 2) are safe from this Intel-only hardware-related bug:
(2018-09-24, 22:16)ilGimmy Wrote: if curl is the issue, you can download it from https://curl.haxx.se/download.html (in the past I fixed a similar problem extracting libcurl.dll from Stefan Kanthak cab file).
I'll try and report back...
edit:
Kodi 16b2 on NUC6CAYS
I installed libcurl.dll from https://skanthak.homepage.t-online.de/do...7.61.1.cab and got same error.
then I replaced libeay32.dll with the one from openssl-0.9.8h-1-bin.zip (https://datapacket.dl.sourceforge.net/pr...-1-bin.zip) and it worked!

I think openSSL need to be checked.

I was racking my brain over this for a good half day until I stumbled on this thread, to which I can confirm that not only Apollo Lake and Gemini Lake processors (e.g. the Pentium J4205, Pentium Silver J5005) are affected, but the most recent Intel Ice Lake processors (e.g. the Core i7-1065G7 found in the Surface Pro 7 exhibits the same behavior) are also directly impacted by this bug. Fortunately, this issue has already been patched in the main development branch of Kodi which concerns 99% of this forum making this a non-issue for most users. However, for impacted 64-bit DSPlayer users, bear in mind that you will need to manually copy and replace the two .dll files (libcurl.dll and libeay32.dll) in your Kodi program folder (i.e. "C:\Program Files\Kodi\"). You can get these files from the following two links below. In the case of libcurl.dll, make sure to pull the version under the AMD64 folder since you specifically need the 64-bit version of the library:
https://skanthak.homepage.t-online.de/do...7.61.1.cab
https://sourceforge.net/projects/gnuwin3...p/download

I am cross-posting this in here the Kodi DSPlayer thread in the hope that others who are impacted also read this. Perhaps it can be integrated into a custom release here at a future date.
Reply
(2019-12-11, 01:00)mclingo Wrote:
(2019-12-11, 00:28)Warner306 Wrote: This is a bit beyond me, instructions assume knowledge I dont have. 

I first put the shader I want to use called HDRFIX in

T:\KODI DS4\system\players\dsplayer\Shaders

Next I added to shaders.xml

  </shader>
<shader name="HDRFIX" id="22">
    <path>HDRFIX.hlsl</path>
    <profile>ps_2_0</profile>
</shaders>


Now I edited the MKV line in mediaconfig.xml like so, this was just to apply the shader to all MKV files first to see if it worked, it did nothing, where have I gone wrong, i'm trying at least Smile


<rule filetypes="mkv">
  <shaders>
        <shader id="22" />
      </shaders>
      <source filter="avsource" />
      <splitter filter="avsource" />
      <video filter="mpcvideodec" />
      <!-- You can do like that to specifie a DXVA only filters.
      If you want to use the same filter for DXVA and non DXVA media, just add
      a single <video> line.
      <video>
        <video dxva="true" filter="mpcvideodec" />
        <video filter="mpcvideodec" />
      </video> -->
      <audio filter="ffdaudiodec" />
      <!--<extra>
        <extra filter="ac3filter" />
        <extra filter="dcgraphiceq" />
      </extra>-->

I'm not sure if your shader will work or not. Start with the starter files in the DSPlayer guide, set DSPlayer to use those external filters and then use the GUI for media rules in the DSPlayer settings to add the shader to the existing rule for mkv files.

It doesn't look like you are using the starter kit for external filter use.
Reply
ok, thanks
Reply
thanks but I gave up with this, just couldnt work it out, i'm using portable too so its confusing where stuff is, and I couldnt work out how to do the media rules bit, seemed like too much faffing for me unfortunately. I have two workarounds I can use for now, I can use the shader in  MPC-HC which can be turned on and off with a shortcut, or I can HDR to SDR tone map and not trigger HDR at all.
Reply
how can i change subtitle positions? I figured it out years ago but for some reason last night kodi decided to reset all my settings so i'm having to redo them.

I've tried changing it from video calibration and that doesn't work, and i've tried changing it from inside xysubfilter settings. (i can change font size/style but not position)
Reply
madVR has some options that should work if you are using DXVA2 (copy-back) video decoding.
Reply
(2019-12-23, 11:54)Warner306 Wrote: madVR has some options that should work if you are using DXVA2 (copy-back) video decoding.

where are those located at?
Reply
  •   
  • 1
  • 501
  • 502
  • 503
  • 504(current)
  • 505
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347