v14 -  autorun Kodi in Raspbian
#1

Hi guys!
I installed on Raspbian the Kodi 14.2
I have a problem
Kodi does not run on system startup
System V script in /etc/init.d/ created automatically
But it does not work
I could not find a solution

Who knows how to make autorun Kodi in Raspbian?
Thank you!
Reply
#2
Quote:Running
To run XBMC, run kodi-standalone from a VT (i.e. not under X). XBMC accesses the display directly and not via Xorg.

If you want Kodi to automatically start when the system boots, edit /etc/default/kodi and change ENABLED to 1:

ENABLED=1
Run sudo service kodi start to test this.
http://michael.gorven.za.net/

Reply
#3
cool, just had to do this to still be able to shutdown from within Kodi after that.
Reply
#4
After I changed enabled=1 it work fine. But all the add-on and files in Music, Videos are not listed.

When I exit Kodi and again come back from desktop it works fine. Please help.
Reply
#5
I'd suggest you use OSMC if you want to kodi to autorun.
It is much better configured and optimised (and more up to date) than the version in raspbian.

You'll still have access to installing debian packages.
Reply
#6
when run from /etc/default/kodi with enabled=1 or from a supervisor program Kodi will not load my custom theme. The same behavior when a "sudo kodi-standalone" is issued as opposed to non sudo (with whom kodi starts in the desired theme).

Could it be that both /etc/... and supervisor ways of starting kodi are use the super user?
Reply
#7
Just tested it. On raspberry.

Running kodi from rc.local or supervisor will start the process as root, causing all sorts of problems.

What I did is added this line to rc.local:
su - pi -c "kodi-standalone"

Now kodi starts at boot under pi user, with my custom theme and doesn't restart if I try to quit it.
Reply
#8
(2016-10-17, 10:35)mirceaciu Wrote: Just tested it. On raspberry.

Running kodi from rc.local or supervisor will start the process as root, causing all sorts of problems.

What I did is added this line to rc.local:
su - pi -c "kodi-standalone"

Now kodi starts at boot under pi user, with my custom theme and doesn't restart if I try to quit it.


A better solution is to specify the user to run kodi in /etc/default/kodi:

# Set this to 1 to enable startup
ENABLED=1


# The user to run Kodi as
#USER=kodi (default)
USER=pi

You'll still need to enable kodi autostart service:
sudo systemctl enable kodi.service

sudo reboot
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
autorun Kodi in Raspbian00