Linux Cannot read media with nfs share + mysqld [SOLVED]
#1
Exclamation 
I have Kodi running on Arch Linux exporting the media via nfs and using mysqld as described on the wiki. Everything works as expected on the local box (running kodi, nfs, and mysqld). When I copy the ~/.kodi/userdata/advancedsettings.xml to brand new Raspberry Pi2 also running Arch Linux, I am able to see the movies but when I go to play any of them, I get, "This file is no longer available would you like to remove it from the library?" I have the deps (libnfs) installed on that RPi2 box so I'm unclear what's missing.

Here is the kodi.log and advancedsettings.xml I'm using on both boxes. Not sure what I'm missing as I have been successful with this setup in the past.

EDIT: I just spun up a VM (Arch x64) and I get the same errors that I do on the RPi2 so the error is indeed consistent.
Need help programming a Streamzap remote?
Reply
#2
most likely /etc/exports + nfs permission issue ...

20:56:04 T:1787110192 ERROR: CDVDPlayer::OpenInputStream - error opening [/mnt/data/movies/Elephants_Dream.mkv] <- that's even a system mount, so check your permissions.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
I thought that too, but I am able to either:
1) Manually mount on the filesystem and access them as the kodi user.
2) Ignore the mysqld and add them in kodi via nfs://foo.bar.

I think the problem is in the fact that I exported the old database and imported it into mariadb. I just nuked /var/lib/mysql and rebuilt it from scratch and everything works as expected. WhyHuh
Need help programming a Streamzap remote?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Cannot read media with nfs share + mysqld [SOLVED]00