•   
  • 1
  • 69
  • 70
  • 71
  • 72
  • 73(current)
iOS App Signer - Install Kodi without Jailbreak (iOS and tvOS)
Is there a way to avoid the need for regular resigning?

If the ATV 4K is jailbroken perhaps?
Reply
Hi Guys,

I have a small problem that I get the error message: App installation failed. This application does not support this kind of device.

I have a Apple TV. I selected in Xcode also tvOS. I go step by step the instructions for Xcode and iOS App Signer. Tried the unstable release 18.0 Beta 5 also stable release 17.6.

But have the same error message.

Thank you in advance for your support.
Reply
There is no Kodi 18 for tvOS at the moment.

Here you find the latest tvOS builds based on Kodi Krypton:

http://mirrors.kodi.tv/test-builds/darwin/tvos/

The tvOS port needs maintainers:

https://forum.kodi.tv/showthread.php?tid=326914

If you see yourself in a position to help, you would make some people happy here. Wink

Regards
frontend software - tvOS | android tv | win10 | kodi krypton
frontend hardware - apple tv | nvidia shield tv | yamaha rx-a1020 | quadral 5.1 | samsung le40a789
backend software - debian | kernel 4.14 | proxmox | omv | zfs raid-z2 | docker | emby | vdr | vnsi | fhem
backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | dd max s8
Reply
I just did this again yesterday after about a year. I had to try and remember the process becasue I had a hell of a time about a year ago trying to get it onto my iPad. So here are some of the errors I figured out hopefully it helps someone else. The ipa file you create with the Appsigner has to have the same name as the app you create in XCode. When you open XCode before you start doing the steps make sure your iPad/iPhone is connected. Then in the upper left corner click where it says iPhone XR etc. Then at the top select your device. It should at some point suggest you go to settings, general, device management and authorize or trust your dev ID on the device. Then follow the rest of the steps on the first page and you should be golden.
Reply
Has anyone been successful in getting the iOS signer to work with Xcode 10.1 and Mojave?

I am assuming the issue is Xcode 10.1 based as it had worked previously. The error is the unable to fix error.
Reply
There is a guide to update Kodi on iOS on removed.
Reply
Please don't post promotional links to such sites, especially ones that peddle things like VPNs which Kodi does not need.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
(2015-11-01, 21:56)DanTheMan827 Wrote: your signing certificate and the profile.

Hi Dantheman - I followed these instructions as closely as possible and I still can't get codesigning and the provisional profile work correctly and so I am unable to make the IPA -- when I do make the IPA, I can't 
load it onto the appleTV4 device because it returns an provisional profile expired or revoked.  I have probably redone this 20 times without success. I need some help if you offer support. Thank you
Reply
Hello - So I am a newbie here. 
Let me start off by saying I installed Kodi with iOS App Signer just under a year ago and it was perfect. Now - maybe coincidentally - Kodi is no longer working. One solution was to reinstall (no audio signal issue). No big deal. Well now I cannot get anything to work. I am using:
Xcode 10.1
iOS App Signer 1.10
tvOS 12.11 (I think this is where it started)
I also have a paid dev account

I've revoked, removed, cursed at certificates until I am blue in the face and knuckles.  So a few things happened also.
When I logged into my dev account (first time in 9 months probably) it prompted me to accept new terms and conditions (could not do anything until I did that).
I have tried logging out through Xcode and back in. 
I manually added all certificates.
When I build a project I see the cert reference code 3J######
When I go to iOS App Signer I cannot get it to see the Provisioning Profile cert.  Signing certificate is correct.
So either Xcode is not generating it (but not throwing any errors) or App Signer cannot see it or locate it.

I am sure it is probably a stupid, simple fix but HELP - thanks
Reply
So going further down this rabbit hole - I do have a Paid dev account so I contacted Apple and they sent the steps copied below. For whatever it is worth in the past I was NOT doing steps 7-9. So that is all done.
Open Xcode I see Signing Certificate  iPhone Developer: USER NAME (3J########).  This matches what is in the keychain.
Open iOS App Signer - Signing Certificate is correct and matches
Provisioning Profile is still not seeing it. It shows Re-Sign Only, Choose File - and then it shows a old profile that does not match the certificate "tvOS Team Provisioning Profile: *(VK##########)"
So I am guessing the * means it is an old profile/reference that it can no longer find. But how do I get it to point to the new/correct one?

=====================================
Sign in to Apple Developer.

2. Click on "Certificates, Identifiers & Profiles".

3. Click on “Development" under the “Certificates” section, and click on your distribution certificate.

4. Click Revoke and follow the instructions.

5. Click on the plus sign to add a new certificate.

6. Select “iOS App Development" option, and click Continue.

7. Follow the steps printed in the webpage. That involves opening the Keychain application on your Mac and generate a Certificate Signing Request from there. Click Continue.

8. Upload the .CSR file and click Continue.

9. A certificate is generated for distribution. Download it and double click it to integrate it in your keychain.
Reply
  •   
  • 1
  • 69
  • 70
  • 71
  • 72
  • 73(current)
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
iOS App Signer - Install Kodi without Jailbreak (iOS and tvOS)58