WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
#25
(2016-02-17, 18:20)hslansky Wrote: I am having a problem with the sync process for multi-part movies, such as The Lord Of The Rings. I use standard Kodi naming conventions and the movie plays fine, however, EMMs sync process process fails. My directory structure is:

Code:
Directory of P:\HT Media Library\Blu Rays\Lord Of The Rings - The Return Of The King (2003)
04/29/2015  06:42 PM           139,053 banner.jpg
04/29/2015  06:42 PM         1,041,482 clearart.png
04/29/2015  06:42 PM         1,205,243 disc.png
04/29/2015  06:42 PM           872,321 fanart.jpg
04/29/2015  06:42 PM           490,902 landscape.jpg
04/29/2015  06:42 PM           209,388 logo.png
04/15/2014  08:25 AM    35,481,548,763 Lord Of The Rings - The Return Of The King (2003) Part 1.mkv
02/09/2016  01:48 PM            16,193 Lord Of The Rings - The Return Of The King (2003) Part 1.nfo
04/15/2014  09:03 AM    38,294,269,218 Lord Of The Rings - The Return Of The King (2003) Part 2.mkv
04/29/2015  06:42 PM           845,998 poster.jpg

and the error I am receiving from sync is:

Code:
04:41.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_32_UpdateInfo_Movie.MoveNext    11    TRACE    [APIKodi] [Kodi KODISERVER] UpdateMovieInfo: "The Lord of the Rings: The Return of the King" | Start syncing process...    
04:41.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_26_SearchMovie.MoveNext    21    WARN    [APIKodi] [Kodi KODISERVER] SearchMovie: "P:\HT Media Library\Blu Rays\Lord Of The Rings - The Return Of The King (2003)\Lord Of The Rings - The Return Of The King (2003) Part 1.mkv" | NOT found in host database!    
04:41.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_32_UpdateInfo_Movie.MoveNext    21    TRACE    [APIKodi] [Kodi KODISERVER] UpdateMovieInfo: "The Lord of the Rings: The Return of the King" | NOT found in database, scan directory on host...    
04:41.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_41_VideoLibrary_ScanPath.MoveNext    21    TRACE    [APIKodi] [Kodi KODISERVER] ScanVideoPath: "/share/Public/HT Media Library/Blu Rays/Lord Of The Rings - The Return Of The King (2003)" | Start scanning process...    
04:41.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_45_IsScanningVideo.MoveNext    21    TRACE    [APIKodi] [Kodi KODISERVER] IsScanningVideo: True    
04:42.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_45_IsScanningVideo.MoveNext    21    TRACE    [APIKodi] [Kodi KODISERVER] IsScanningVideo: False    
04:42.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_26_SearchMovie.MoveNext    21    WARN    [APIKodi] [Kodi KODISERVER] SearchMovie: "P:\HT Media Library\Blu Rays\Lord Of The Rings - The Return Of The King (2003)\Lord Of The Rings - The Return Of The King (2003) Part 1.mkv" | NOT found in host database!    
04:42.1    generic.Interface.Kodi.Kodi.APIKodi    generic.Interface.Kodi.Kodi.APIKodi+VB$StateMachine_32_UpdateInfo_Movie.MoveNext    21    ERROR    [APIKodi] [Kodi KODISERVER] UpdateMovieInfo: "The Lord of the Rings: The Return of the King" | NOT found on host! Abort!    
04:42.1    generic.Interface.Kodi.KodiInterface    generic.Interface.Kodi.KodiInterface+VB$StateMachine_71_GenericRunCallBack.MoveNext    1    WARN    [KodiInterface] [Kodi KODISERVER] RunGeneric Movie Update | Sync Failed:  The Lord of the Rings: The Return of the King

Please let me know if I am doing something wrong or if you need more information to troubleshoot the problem.

ATM it's not possible to sync multi part movies and (perhaps) BDMV or VIDEO_TS folder structures. Kodi use a very crappy "path" info in database to save multipart movies.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
 
Thread Rating:
  • 2 Vote(s) - 5 Average


Messages In This Thread
RE: Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread - by DanCooper - 2016-02-17, 18:34
nfo file status? - by NightMyst - 2017-06-21, 07:24
Audio metadata error - by Doomnie - 2017-11-04, 08:16
EmberMM Import Poster.jpg - by MePoEmberMM - 2018-02-06, 01:27
User rating sync - by fred_gaou - 2018-04-28, 22:25
database is locked - by gorb - 2019-08-19, 11:41


Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52