•   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-05-03, 16:06)Pienoet Wrote: Didn't anybody else notice that refreshrate switch from 60hz to 50hz is not working when watching live tv or am i really the only one?

I did a fresh install on my rpi2 with LE stable 16.1 from LE site then i update with #0502 build and still no refreshrate swith. (videoplayback is freezes)
When swithing from 60hz to 24hz videoplayback is fine..

If needed i can provide some logs.

Yes, enable debug and video component specific debug and post a log.
Does the issue occur when playing a file (e.g. from a tv recording?)
(2016-05-03, 19:37)SkywalkerPD Wrote: Every item I start from my library starts the same movie...? When I check the file paths they are correct. I can't find out why this is happening. I'm running on the 0502 build, with Estuary skin. The skin is not the problem. I tried with another skin as well. Same problem.

Seems to be related to the following error...

ERROR: Unable to load /usr/lib/kodi/system/players/VideoPlayer/libdvdnav-arm.so, reason: /usr/lib/kodi/system/players/VideoPlayer/libdvdnav-arm.so: cannot open shared object file: No such file or directory

So it skips all the folders with DVD structure, and the first directory (after 24 with the above error) with an .mp4 file in it is played every time.

Right.... I read this has to do with DVD playback being disabled.... Didn't notice this before, because I used this system primarily for playing .avi files. Now my kid wanted to watch a disney DVD...

Can I downgrade this system to LibreELEC 7.0 official build? Or doesn't that work?
(2016-05-03, 20:06)SkywalkerPD Wrote: Can I downgrade this system to LibreELEC 7.0 official build? Or doesn't that work?

Yes, downgrading should work.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-03, 20:21)Milhouse Wrote:
(2016-05-03, 20:06)SkywalkerPD Wrote: Can I downgrade this system to LibreELEC 7.0 official build? Or doesn't that work?

Yes, downgrading should work.

Up and running again on LibreELEC 7.0 all seems to work well. Thnx!
(2016-05-03, 19:43)popcornmix Wrote:
(2016-05-03, 16:06)Pienoet Wrote: Didn't anybody else notice that refreshrate switch from 60hz to 50hz is not working when watching live tv or am i really the only one?

I did a fresh install on my rpi2 with LE stable 16.1 from LE site then i update with #0502 build and still no refreshrate swith. (videoplayback is freezes)
When swithing from 60hz to 24hz videoplayback is fine..

If needed i can provide some logs.

Yes, enable debug and video component specific debug and post a log.
Does the issue occur when playing a file (e.g. from a tv recording?)

When playing a file from recording when refreshrate set to 60 hz it doesn't switch to 50 hz but it plays 60hz.

Here are my logs:

refreshrate 60hz
refreshrate 50hz
recording 60hz
(2016-05-03, 13:59)popcornmix Wrote:
(2016-05-02, 20:24)zed200 Wrote: In he last version of Openelec Milhouse Build (8.0) I can not find the option "Accelerated playback speed".

Did this option disappear ?

Yes, it was dropped due to lack of feedback.

I have added it back in, so should be in tonight's Milhouse LE build. (But note there will be no more Milhouse OE builds).
Thank you I will wait for this version
If I use the build milhouse of Kodi it is mainly for this function
This is one of the few features that I miss in KODI compared to VLC, even if it does not work as well as in VLC ...
New LibreELEC.tv Krypton build #0503: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.6.0-rc5 #1 Tue May 3 21:15:59 BST 2016 armv6l GNU/Linux

# vcgencmd version
May  3 2016 17:47:44
Copyright (c) 2012 Broadcom
version b870a5bbf6c662327916ee582c22309c9f997b3d (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160503211458-#0503-g0b27675 [Build #0503]

# vcdbg log msg 2>&1 | grep DTOK
002484.444: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (0b276752, changelog) and tip of XBMC master (fa16b76a, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. New firmware
  3. Hacky scheme to enable accelerated playback as first ff step
Build Details:
  1. Firmware (May 3):
    • firmware: dtoverlay: Run scripts before and after changes See: link
    • firmware: imx219: Enable SW sharpen in the builds
    • firmware: imx219: Disable SW sharpening by default
    • firmware: gencmd: Allow PVT debug registers to be read
  2. XBMC:
    • Update settings.xml (PR:9738, 1 commit, 1 file changed)
    • VideoPlayer: inputstream, check status of Create (PR:9739, 1 commit, 1 file changed)
    • guilib: update items of GUIMediaWindow after adding a media source (PR:9736, 2 commits, 2 files changed)
    • [guilib] - fix for multiimage controls in case imagepath switches to empty (PR:9715, 1 commit, 1 file changed)
    • [gui] Use SelectDialog for SortMethod selection (PR:9647, 2 commits, 3 files changed)
    • [python] - whitelist some GUI_MSG_NOTIFY_ALL messages for WindowXML windows (PR:9727, 1 commit, 1 file changed)
  3. inputstream.smoothstream:
    • add depends::expat::platform.txt (352b14eb)
  4. newclock5:
    • New commits in this build:
      • Hacky scheme to enable accelerated playback as first ff step (3c2c9c94)
      • Revert "mmalrenderer: reduce logging spam for bypass mode" (86e12547)
      • mmalrenderer: Avoid creating presenting thread when it is not required (1075e96e)
      • RenderManager: Inform renderer even when display refresh matches (f6d364d1)
      • RenderManager: Disable vsync adjust - it causes unpleasant glitches after seeking (bd4ec64e)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Have just installed the above build and get 50i to 50p MMAL Advanced deinterlacing on both OMX and MMAL accelerated playback, so Live TV is fine.
I ran across a problem affecting both build #503 and #502. Build #424 is not affected.

Any attempt to play TuneIn radio results in a system hang, Oddly Pandoki and ther music streaming programs are not affected.

Here's a log.

http://xbmclogs.com/pa2tgnflt

thanks
Hi there, I am running #503 and have noticed that upon reboot that it hangs at the kodi (hexagon) screen for a while before going into the menu. What can i provide in terms of logging or trace detail to assist with what is causing the delay?
(2016-05-04, 05:50)david1976aus Wrote: Hi there, I am running #503 and have noticed that upon reboot that it hangs at the kodi (hexagon) screen for a while before going into the menu. What can i provide in terms of logging or trace detail to assist with what is causing the delay?

A debug log (wiki).

Enable debugging, reboot, then upload your whole kodi.log file to a pastebin site - easiest method is to ssh in and run "cat /storage/.kodi/temp/kodi.log | paste" then paste the link.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I prefer connecting to my RPI with SSH key instead of password, but I always run into this issue:
http://raspberrypi.stackexchange.com/que...-password/

The solution there works, but why are the defaults (ownership/permission on /storage) different/wrong (noobs install)?
(2016-05-04, 10:41)ElectricPim Wrote: I prefer connecting to my RPI with SSH key instead of password, but I always run into this issue:
http://raspberrypi.stackexchange.com/que...-password/

The solution there works, but why are the defaults (ownership/permission on /storage) different/wrong (noobs install)?

Good question. I'd noticed ssh key login didn't work.
Code:
chown root:root /storage
fixes it for me. I didn't need to chmod it (the default 700 worked okay for me).

I can't think of a reason why it is set to an owner of 1000.
(2016-05-04, 13:05)popcornmix Wrote:
(2016-05-04, 10:41)ElectricPim Wrote: I prefer connecting to my RPI with SSH key instead of password, but I always run into this issue:
http://raspberrypi.stackexchange.com/que...-password/

The solution there works, but why are the defaults (ownership/permission on /storage) different/wrong (noobs install)?

Good question. I'd noticed ssh key login didn't work.
Code:
chown root:root /storage
fixes it for me. I didn't need to chmod it (the default 700 worked okay for me).

I can't think of a reason why it is set to an owner of 1000.
The permission default here (noobs) was 775 for /storage.
AFAIK 1000 is normally the (sudo) user in Linux distributions, most have root disabled, but not OE/LE.
(2016-05-04, 00:15)noggin Wrote: Have just installed the above build and get 50i to 50p MMAL Advanced deinterlacing on both OMX and MMAL accelerated playback, so Live TV is fine.

Did you already tried refreshrate switching 60hz to 50hz watching Live TV?
  •   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319