•   
  • 1
  • 29
  • 30
  • 31(current)
  • 32
  • 33
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-05-09, 03:34)dlxmax Wrote: Just upgraded to 0508 from 0507 and there appears to be a huge bug. Using either Confluence or Estuary, launching addons results in a blank screen showing only the KODI background image. Some addons flash their menu for a split second and then it goes back to the background image. Will post logs if needed, but I imagine you can reproduce this easily. FWIW, the Libreelec settings addon works (Quasar, KODI Log viewer among the broken).

Yes, I noted the same thing with TuneIn and Pandoki. I am posting my logfile on the Estuary site. You see the same problem in Confluence?
OK for the odd addon behaviour I've added a comment on PR9778.

@bill_orange: I think you've got a couple of problems. The odd menu/flashing behaviour is due to this ongoing deadlock issue (obviously #0508 includes only a partial fix), however the "Misplaced [" errors are either skin issues or add-on issues, possibly in Estuary file 1080i/MyPics.xml. Please run it past the Estuary developers, they can confirm if it's their issue or not.

Edit: Yes, the "Misplaced [" errors are Estuary skin errors, they appear when entering Estuary Home > Pictures for the first time.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-09, 04:06)bill_orange Wrote:
(2016-05-09, 03:34)dlxmax Wrote: Just upgraded to 0508 from 0507 and there appears to be a huge bug. Using either Confluence or Estuary, launching addons results in a blank screen showing only the KODI background image. Some addons flash their menu for a split second and then it goes back to the background image. Will post logs if needed, but I imagine you can reproduce this easily. FWIW, the Libreelec settings addon works (Quasar, KODI Log viewer among the broken).

Yes, I noted the same thing with TuneIn and Pandoki. I am posting my logfile on the Estuary site. You see the same problem in Confluence?

Confluence also go mad with #0508. Youtube addon also cannot back list after video playback.

1. Run Youtube Addon.
2. Get list and Play video and stop.
3. Youtube addon cannot be back to list.
(2016-05-03, 05:03)stourwalk Wrote: Ok - moved back to 0501 (I should note that 0421 was actually 0420 - I was stupidly looking at the date (sorry!)) - and changed the resample quality *from* GPU to High - problem goes away.

Same is true for Low/Medium too.

So for me the issue is narrowed down to the GPU Accelerated resampling. It's a RPI2 B+ btw and fwiw my config.txt looks like.. http://sprunge.us/BXZG

I'm afraid I'm not hearing the difference here. I've tried with your sample file as well as other dts files.
Do you have any other non-default audio settings? Using amplification? "Boost centre channel when downmixing"? "Stereo Upmix"? "Maintain original volume on downmix"?
(2016-05-09, 13:22)popcornmix Wrote:
(2016-05-03, 05:03)stourwalk Wrote: Ok - moved back to 0501 (I should note that 0421 was actually 0420 - I was stupidly looking at the date (sorry!)) - and changed the resample quality *from* GPU to High - problem goes away.

Same is true for Low/Medium too.

So for me the issue is narrowed down to the GPU Accelerated resampling. It's a RPI2 B+ btw and fwiw my config.txt looks like.. http://sprunge.us/BXZG

I'm afraid I'm not hearing the difference here. I've tried with your sample file as well as other dts files.
Do you have any other non-default audio settings? Using amplification? "Boost centre channel when downmixing"? "Stereo Upmix"? "Maintain original volume on downmix"?

I was afraid you were going to say that Smile Which is why I posed the question in the first place to see whether it was just me for some reason (which it appears to be).

First tonight I'll reset all the audio settings back to default and try it again and try and narrow down the setting that causes it, although I didn't think I had deviated that wildly from the default settings anyway, but I guess something has crept in over time! Will get back to you when I've done some digging.

Thanks
(2016-04-27, 07:47)MikeKL Wrote:
(2016-04-27, 01:13)Milhouse Wrote:
(2016-04-26, 20:14)MikeKL Wrote: Hmm perhaps spoke to soon, during reboot to load latest splash screen (Looking great :Wink ) appear to be having similar symptoms/problem (mentioned here?) with multi kodi crashes and kodi restarts before a clean start of kodi

Kodi.crashlog
kodi.log (after clean start)

Once everything up and running kodi stable (Note build #0424 installed on top of a clean LibreElec beta 2 updated to #0423 before #0424)

Debug-enabled build #0426x: RPi2

Please upload a new crashlog, thanks - with luck it will provide a clue to a PVR or core developer as PVR addons shouldn't crash Kodi.
Hope information in following 3 debug logs before a clean start of kodi is helpful, will be away for next few days so if more test and logs required, will be available from mid next week. Thanks

Debug crashlog 1
Debug crashlog 2
Debug crashlog 3
Clean kodi boot 4
Quick update to state, I have now jumped from #0426x debug build to #0503 3rd May and #0508 today and am still observing Kodi crash loops for approx 4 to 5 kodi crashes before a clean start of kodi. (My usage case with the two pvrs backends/frontends active etc)

#0503 kodi_crashlog before clean complete start of Kodi
#0508 kodi_crashlog before clean complete start of Kodi
#0508 Kodi log (clean start of Kodi)

Note: Tvheadend backend updated to HTS Tvheadend 4.1.1945 ~ LibreELEC Tvh-addon v8.0.102-#0503-milhouse
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
(2016-05-09, 04:17)Milhouse Wrote: OK for the odd addon behaviour I've added a comment on PR9778.
With #0508 like others and yourself Milhouse, I am also find my usual addons not working, in my case the iplayer www and itv addons.

kodi.log with debug enabled.
(Manually loaded to gist.github, filesize to big for pastebin)

Note: With debug enabled in kodi, had problems sshing to Pi to create log and create pastebin link directly?

Code:
LibreELEC (community) Version: devel-20160508211119-#0508-g7becc33
LibreELEC git: 7becc33edec8a0b070d8fafad336ad44e4e8fc81
LibreELEC:~ # $HOME/.kodi/temp/kodi.log | pastebinit
-sh: /storage/.kodi/temp/kodi.log: Permission denied
http://sprunge.us/TMji
LibreELEC:~ #
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
(2016-05-09, 08:45)parcel Wrote: Confluence also go mad with #0508. Youtube addon also cannot back list after video playback.

1. Run Youtube Addon.
2. Get list and Play video and stop.
3. Youtube addon cannot be back to list.

Should be fixed in tonight's build #0509 (PR9778 has been updated).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-09, 19:54)MikeKL Wrote: Note: With debug enabled in kodi, had problems sshing to Pi to create log and create pastebin link directly?

Code:
LibreELEC (community) Version: devel-20160508211119-#0508-g7becc33
LibreELEC git: 7becc33edec8a0b070d8fafad336ad44e4e8fc81
LibreELEC:~ # $HOME/.kodi/temp/kodi.log | pastebinit
-sh: /storage/.kodi/temp/kodi.log: Permission denied
http://sprunge.us/TMji
LibreELEC:~ #

You've missed off the cat command - you're trying to execute the log, and pipe the output through pastebinit which won't work hence the "Permission denied" error (as you - rightfully - don't have execute permission on the log file).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-09, 20:36)Milhouse Wrote:
(2016-05-09, 19:54)MikeKL Wrote: Note: With debug enabled in kodi, had problems sshing to Pi to create log and create pastebin link directly?

Code:
LibreELEC (community) Version: devel-20160508211119-#0508-g7becc33
LibreELEC git: 7becc33edec8a0b070d8fafad336ad44e4e8fc81
LibreELEC:~ # $HOME/.kodi/temp/kodi.log | pastebinit
-sh: /storage/.kodi/temp/kodi.log: Permission denied
http://sprunge.us/TMji
LibreELEC:~ #

You've missed off the cat command - you're trying to execute the log, and pipe the output through pastebinit which won't work hence the "Permission denied" error (as you - rightfully - don't have execute permission on the log file).
user error, apologies BlushBlush
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
(2016-05-09, 18:59)MikeKL Wrote: Quick update to state, I have now jumped from #0426x debug build to #0503 3rd May and #0508 today and am still observing Kodi crash loops for approx 4 to 5 kodi crashes before a clean start of kodi. (My usage case with the two pvrs backends/frontends active etc)

#0503 kodi_crashlog before clean complete start of Kodi
#0508 kodi_crashlog before clean complete start of Kodi
#0508 Kodi log (clean start of Kodi)

Note: Tvheadend backend updated to HTS Tvheadend 4.1.1945 ~ LibreELEC Tvh-addon v8.0.102-#0503-milhouse
These crashes seem to be PVR.FilmOn related. I don't have any fixes, so I'd suggest opening an issue on the PVR FilmOn github and maybe someone familiar with the add-on can suggest something.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-09, 20:46)Milhouse Wrote: These crashes seem to be PVR.FilmOn related. I don't have any fixes, so I'd suggest opening an issue on the PVR FilmOn github and maybe someone familiar with the add-on can suggest something.
PVR.filmon Issue #50 opened, Thank you
rPi3B+, SanDisk Ultra 8Gb SD, Milhouse kernel_5.x LE ​Testbuild (Kodi 19 Matrix) -> Onkyo TX-SR608 AV Receiver -> Philips 42" LCD TV
KVIM2 Pro, SanDisk Ultra 8Gb SD, kernel_5.x LE Testbuild (Kodi 19 Matrix) -> LG 27UD69-W 4K Monitor -> AudioEngine A2+ Speakers
I can confirm the OOM crash of kodi when watching livetv via pvr.hts addon

Code:
[ 3877.843088] Out of memory: Kill process 566 (kodi.bin) score 880 or sacrifice child
[ 3877.843302] Killed process 566 (kodi.bin) total-vm:1281480kB, anon-rss:682080kB, file-rss:0kB, shmem-rss:0kB

Seems something leaks memory indeed. Trying to disable hw acceleration and will see if it still leaks ...

Leak rate is around 2MB in 10secs for 720x576 mpeg2 livetv 25fps and memory is not freed when playback is stopped.

Edit: - same memory leak when playing h.264 movies from my nas - fullhd leaks between 1 - 1.6MB in 10 secs - seems its not really related to the frame size...

Edit2: - above findings where with 3 render buffers setup in settings->system->video, changing this doesn't effect the leak rate.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
New LibreELEC.tv Krypton build #0509: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.6.0-rc7 #1 Mon May 9 21:07:05 BST 2016 armv6l GNU/Linux

# vcgencmd version
May  6 2016 13:57:24
Copyright (c) 2012 Broadcom
version 0cc642d53eab041e67c8c373d989fef5847448f8 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160509210600-#0509-g796a577 [Build #0509]

# vcdbg log msg 2>&1 | grep DTOK
002487.360: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (796a5777, changelog) and tip of XBMC master (ab6ece74, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. New 4.6.0-rc7 kernel
  3. Updated PR9778, should fix remaining add-on issues
Build Details:
  1. LibreELEC.tv:
    • systemd: fix machine-id uniqueness (PR:276, 1 commit, 2 files changed)
    • kodi: update appliance.xml after settings reshuffle. (PR:326, 1 commit, 1 file changed)
  2. XBMC:
    • fix frameMoveGuard intruduced here by 82218b570c8d5e7d2ace70cbe71f24e… (PR:9782, 1 commit, 1 file changed)
  3. kernel 4.6.y:
    • Commits no longer in build:
      • Updated smsc95xx driver to check for a valid MAC address in eeprom before using smsc95xx.macaddr parameter passed on command line. (38f73b1d)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:325: linux: update to 4.6-rc7
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Beside the memory leak those debug prinouts are pretty excessive and should be moved into its own debug log category (they are printed at each frame move):

Code:
22:55:05 1769.533936 T:1962872832   DEBUG: FrameMove ExternalCalls: 37, Sleep: 4
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
  •   
  • 1
  • 29
  • 30
  • 31(current)
  • 32
  • 33
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319