Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-05-11, 14:05)Milhouse Wrote:
(2016-05-11, 11:28)bite_your_idols Wrote: hi!
I am testing libreELEC 8/kodi 17 into my raspberry and I have 2 issues, maybe are silly questions...

1) I realized that if you copy and paste an addon folder inside /storage/.kodi/addons/ folder system does not recognizes it, neither after reboot... Is this a new feature of kodi or something related to alpha stage in libreELEC?

2) when trying to launch my retroarch addon I get some errors realted with missing libs (libavcodec.so.56, libavformat.so.56, libavutil.so.54, libswscale.so.3, libswresample.so.1). I guess it is related with ffmpeg update, isn't it?

thanks!

1) Yes this is the new addons behaviour in Kodi 17. Add-ons will now be disabled by default unless they are installed from a repository or from zip. If you delete your Addons*.db, all your add-ons will be disabled. You'll need to manually enable your copied-in add-on.

2) You need to rebuild your add-on, linking against the correct library versions - those libraries you mentioned have all been bumped by +1 following the switch to ffmpeg3, ie. libavcodec.so.57, libswresample.so.2 etc.

That is really a pitty, I use copy addon's a lot to get my different test builds up 2 speed, now it's one copy action and done. Isn't there a workaround or easy to enable all copied addon's at once or whatever?

With kind regards
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by apoc [t.i.m.] - 2016-05-11, 18:19
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319