Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-06-21, 00:20)BobCratchett Wrote:
(2016-06-15, 02:35)BobCratchett Wrote: The lirc update (I'm presuming) is causing me issues with my gpio remote. A lot of the important buttons - select and back for example - aren't being recognised and there's no sign of them in the log. The number buttons, volume and arrow buttons all still seem to be working.

It may be there's just been a change to the mapping, but the relevant PR is beyond my ability to decipher. Full debug log is here, and - if it's of any use - my lircd.conf is here. If there's any other info I can provide, let me know.

Just updated from 618 to 620, and am experiencing the same issue again (well almost, this time the back button appears to work) in that some keys on my remote aren't being recognised. I've tried following some of the advice from the x86 builds thread - IRW doesn't show any input for the keys that aren't working, and the output from a few commands requested on the other thread:

systemctl status > http://sprunge.us/NbRV
dmesg > http://sprunge.us/chgE
journalctl -a > http://sprunge.us/UIii

From what I can see, the buttons mapped to the following aren't working:-

KEY_OK, KEY_RED, KEY_BLUE, KEY_YELLOW, KEY_GREEN, KEY_CHANNELUP, KEY_CHANNELDOWN, KEY_INFO, KEY_PVR, KEY_VIDEO, KEY_TITLE, KEY_TEXT, KEY_SUBTITLE

I haven't yet confirmed that this was introduced in 619 (though it seems likely as the lirc bump was re-introduced in that) but am downloading it now and will update the post when it's installed (internet is slow so this will take a while!)

Edit: Can now confirm 619 as the culprit.

I see the same issue. Additionally there is a strange effect when pressing KEY_UP that in Kodi it is repeated over and over again.I checked the log files but didn't see any indicator on what is going on.
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by MarcLandis - 2016-06-21, 15:23
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319