Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
I'm having problems with intermittent startup using #618 (I use lirc) on both a b+ and a zero.
On the b+ I'm mounting storage via NFS, it's local on the zero. The b+ has a wired connection, the zero uses wireless.

When the 'failure occurs, #618 manages to boot, display the animation (a 'blue' kodi animation on the b+ and a 'libreelec' animation on the zero?) then sits there with a fully black screen (i.e. before the kodi splash screen appears).

When in the 'locked' state, you can ssh into the box, but ssh locks up (even ctrl-c won't exit the session) before printing the LibreELEC banner (although "Warning: untrusted X11 forwarding setup failed: xauth key data not generated" is generated when appropriate so it seems the ssh daemon is running). It feels like sshd isn't able to sporn a shell for some reason.

Normally I run with 'Wait for network before starting kodi' turned on with a 10 second timeout (I use a shared sql database), but you can sit forever waiting for kodi to start. I've just turned it off via the GUI and the problem has re-occured so it doesn't seem to be related to this feature.

It seems that if I ssh into the box while the splashscreen animation is running (a question of timing) the box will always boot up properly. If I wait until the animation has finished playing ssh will only connect properly if the fault doesn't occur.

In locked-up cases, using the nfs mounted storage partition on the b+ I can see .kodi/temp/kodi.log but it hasn't been updated since the last run - so it doesn't look like a kodi related thing - more LibreELEC / systemd.

Any ideas what I should try next to enable some useful remotely accessible logging?

Edit: I've managed to get something useful out of a 'locked up' box by bypassing the shell (ssh [email protected] journalctl -b > journal.txt) not sure what it's telling me: http://pastebin.com/PjGqbdzJ

Edit2: On the grounds that "systemctl restart kodi" runs the splash animation and the lockup seems to occur between the animation and the 'fixed' kodi splashscreen, I've disabled the animation: (touch /storage/.config/splash.disable). No lockups yet... Will post back if it re-occurs.
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by metaron - 2016-06-26, 13:37
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319