Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-07-17, 12:37)metaron Wrote: I'm a little confused about this 'fixed' lirc in #0714 and later having just tried it and #0716.
I use "dtoverlay=gpio-ir" in config.txt to drive my IR rx device.

When I go back to #0618 everything works (i.e. I can use my remote to drive kodi's interface):
...
I've tried swapping back to "dtoverlay=lirc-rpi" but that doesn't seem to change anything. Still no response to my remote using irw or within kodi.

NB: My remote isn't a MCE remote or such, it's just a one I had lying around which I created an lircd.conf file for using irrecord and put in /storage/.config

I've tried the lastest Alpha LibreElec builds and they have the same issue. (7.0.1 and 7.0.0 work)

Something's obviously different for me compared to all the other happy campers out there.

Well I worked out what my problem is. The config file I created for my Grey 'Pioneer STB' remote using irrecord seems to confuse the new version of lirc. When I tried to create a new file for it (using the irrecord in #0716) several keys do the same thing.
Seems the latest lircd can't cope with "bits 32" for some reason, detecting them as "bits 16"....

I've switched to using a Sky remote using a different config file and all is fine.
Time to investigate with lirc upstream ...
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by metaron - 2016-07-17, 20:06


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319