Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-07-24, 18:12)smp1 Wrote: I noticed a rare but very annoying bug. This usually happens when watching a HD DVB-S channel for a prolonged period of time (12+ hours).
The video and audio just freeze and the RPi is useable for a while, then in will completely lock up and reboot.

I'm not sure if this debug log would be useful, I enabled it after the stall occured (18:46:59) but before the RPi completely froze.

http://sprunge.us/FiZh

Does it really reboot (whole device restarts) or does Kodi crash (and restart)? Can you see if you have a crash log (see first post, note #4) which you should normally have when Kodi restarts.

This doesn't look good:
Code:
06:45:18 20617.371094 T:1961574400   ERROR: SQL: [MyVideos107.db] SQL error or missing database
                                            Query: INSERT INTO settings (idFile,Deinterlace,ViewMode,ZoomAmount,PixelRatio, VerticalShift, AudioStream,SubtitleStream,SubtitleDelay,SubtitlesOn,Brightness,Contrast,Gamma,VolumeAmplification,AudioDelay,OutputToAllSpeakers,ResumeTime,Sharpness,NoiseReduction,NonLinStretch,PostProcess,ScalingMethod,StereoMode,StereoInvert,VideoStream) VALUES (454,1,0,1.000000,1.000000,0.000000,-1,-1,0.000000,1,50.000000,50.000000,20.000000,0.000000,0.000000,0,0,0.000000,0.000000,0,0,1,0,0,-1,2122604092)
06:45:18 20617.371094 T:1961574400   ERROR: SetVideoSettings (smb://SMP-PC/MEDIA2/That.80s.Show.S01.480p.WEB-DL.AAC2.0.H.264-NOGRP/That.80s.Show.S01E06.Hulu.Rip.480p-TheMCP.mp4) failed

Looks like we're trying to pass 26 values to a query with only 25 columns...

Edit: The SQL error is in a deinterlace patch and will be fixed soon, maybe even for tonight's build. Could possibly be the cause of a restart... crashlog would confirm.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by Milhouse - 2016-07-24, 22:21


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319