•   
  • 1
  • 179
  • 180
  • 181(current)
  • 182
  • 183
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
Hey. Latest build solves it.

Thanks chaps. Great work as always.
(2016-10-26, 21:39)mezo Wrote: is there an image file of your builds? i want to try usb boot, since next branch is now used. or is there any other way to write your builds to usb/sd?

Use the 7.90.007 image, write it to your SD card etc., then upgrade using these builds. Once you've booted from SD, use the SD card to create your USB boot drive. Remove SD card, boot from your USB drive.

Alternatively use 7.90.007 img.gz to create your USB drive, then extract the bootcode.bin, start.elf and fixup.dat files from the latest Milhouse tar file and copy these files over the same files on your USB drive.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #1026: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.4 #1 Wed Oct 26 21:23:39 BST 2016 armv6l GNU/Linux

# vcgencmd version
Oct 25 2016 17:02:22
Copyright (c) 2012 Broadcom
version cd1ab218dc23c84d9e6d984385a57f2471600300 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161026212236-#1026-g4328ac2 [Build #1026]

# Kodi version
Kodi (17.0-BETA5 Git:9e1e22a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (4328ac28, changelog) and tip of XBMC master (9e1e22a2, changelog) with the following modifications: Build Highlights:
  1. libcec 4.0.0
    Quote:Warning: Minimal testing performed so far, this is very bleeding edge...
    Please report problems/regressions/bugs so that developers can respond accordingly.
Build Details:
  1. LibreELEC.tv:
    • emby: upgrade to 3.0.8300 (PR:885, 2 commits, 3 files changed)
  2. XBMC:
    • [gui] cosmetics: fix indent in GUISliderControl.cpp (PR:10773, 1 commit, 1 file changed)
    • [estuary] fallback to icon in poster view (PR:10772, 1 commit, 1 file changed)
    • VideoPlayer: fix segfault on eof caused by postprocessing (PR:10780, 1 commit, 5 files changed)
    • [docs/android] Wrong toolchain (PR:10778, 1 commit, 1 file changed)
  3. libcec:
    • Added LG-Reconnect-Request (PR:256, 1 commit, 1 file changed)
    • changed: replace libcec3v4 debian package as it causes conflicts (822efc63)
    • fixed: only send out an active source message when the active route is set to us and we're not the active source yet (59263172)
    • fixed: work around for amps not responding to power status requests, but sending routing changes. issue #186 (7ce191f7)
    • changed: don't feature abort vendor command 0x0B sent by LG, but ignore it. issue #242 (9362d396)
    • API cleanup. bump to 4.0..0. see debian/changelog.in for details. added setting to configure automatic avr wakeup. closes #156 (736dd56b)
    • fixed: compilation with full debugging enabled (756507dd)
    • fixed: data packets are used by serial communication too and got trimmed with the smaller 16 byte size (e83d7024)
    • fixed: bump minimum lib version to 4 (554203b1)
    • fixed: typo in method name (6ae15255)
    • fixed: cecc-client compilation on Windows (7035a3ab)
    • fixed: reorder warning on rpi (24794722)
    • fixed: missing #include (bc7f007f)
    • fixed: return value wasn't checked correctly in CLibCEC::RegisterClient() (92128fa5)
    • changed: removed deprecated FindAdapters() and MuteAudio() (f49b884e)
    • changed: moved transmitting volume change commands to CCECBusDevice (59c35e3d)
    • changed: send volume change commands to the TV if no audio system is present. Only some TVs support this. closes #223 (648ee912)
    • fixed: cec-client had the path and com port mixed up after f49b884e49f02de043e9a18d06a1db71195ec457 (17a3e102)
    • changed: only call bcm_host_init() and only call it once. issue #252 issue #191 (07cbc7e0)
    • new AO CEC adapter (d03dd792)
    • fixed: return CEC_DEFAULT_PHYSICAL_ADDRESS if the address can't be read for aocec (b0c63066)
    • cosmetics (472026f9)
    • fixed: some missing locks in the new aocec code (1019bb5e)
    • fixed: true/false may be something else than 1/0 in the new aocec code (a49516a5)
    • fixed: correct error level in aocec (7b46dd65)
    • cosmetics (8c9444bb)
    • Merge branch 'pr218' (ab6c1384)
    • fixed: sync LibCecSharp with API changes (a755c246)
    • cosmetics (1bdf7442)
    • updated changelog (5e737908)
    • fixed: cec?-client.exe wasn't signed after build script changes (7e494b16)
  4. p8-platform:
    • fixed: debian package building on some platforms (2d90f986)
  5. inputstream.rtmp:
    • Fix OpenSSL (PR:6, 2 commits, 2 files changed)
  6. newclock5:
    • New commits in this build:
      • Revert "libcec: use system audio mode request instead of power on to start AVR reliable" (384841df)
      • Revert "[cec] Update for libcec 3.1.0" (92db996b)
      • Revert "[cec] Temp - more logging" (e35ec01f)
      • Revert "[cec] Don't discard buttons when repeat mode is enabled" (fa461dc2)
      • Revert "[cec] Add settings for configuring button repeats" (2da5fd6b)
      • Revert "cec: hack: pretend bump to 3.1.0" (4acaf6fd)
      • Revert "[libcec] Add repeating keypress patch from popcornmix' repo" (3cdaab35)
      • Revert "[cec] Don't suspend pi on tv switch off - it can't wake up" (54ee3d9b)
      • bump to libCEC 4.0.0 (e2e1ba73)
      • Added advances settings for action when TV goes standby (5a9f7bb7)
      • Add CEC IMX adapter as known type and set no polling. - that eliminates extensive periodic /sys walkthrough (2e4db1e3)
      • changed: removed no longer used com port override (0d889bf3)
      • added: setting to make libCEC wake up the AVR explicitly when activating the source. (13ea4082)
      • cec: Bump to 4.0.0 (38a51fcf)
      • Revert "[power] hack - don't kill lirc or cec" (204ec23e)
      • [cec] Don't suspend pi on tv switch off - it can't wake up (e3c80caa)
      • [cec] Add settings for configuring button repeats (43882b05)
      • [cec] Don't discard buttons when repeat mode is enabled (2397aad0)
      • [cec] Temp - more logging (190347d4)
      • [power] hack - don't kill lirc or cec (184d5eac)
      • VideoPlayer: cleanup VideoCodec interface, SetDropState (8d2356a8)
      • MMAL: Update to new dropping scheme (c231b184)
  7. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:10785: add privacy policy
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-20, 08:56)Milhouse Wrote:
(2016-10-20, 05:06)smp1 Wrote: I was running build 1010 for a few days now and tonight I noticed a weird issue - one of the CPU cores - "CPU 2" was stuck at 100% load. No idea what triggered this or how to reproduce. I ran "top" via ssh, kodi.bin was using ~120% of the cpu.
These kind of issues are not easy to pin down. If you run "top -Hp $(pidof kodi.bin)" you should see all the threads for the kodi.bin process - if the thread creating the CPU load is called LanguageInvoker then it's an add-on causing the problem (unfortunately can't say which add-on). If it's kodi.bin itself then using strace on the kodi.bin process might yield some clues (strace can be installed from one of the LE add-ons, System Tools I think).
This happened again. One of the CPU cores is stuck at 100%.

# top -Hp $(pidof kodi.bin)
Code:
PID USER      PR  NI    VIRT    RES    SHR S %CPU %MEM     TIME+ COMMAND
813 root      20   0  494548 139720  37624 R 99.9 18.5 949:37.01 kodi.bin
738 root      20   0  494548 139720  37624 S  6.0 18.5 365:38.95 kodi.bin
832 root      21   1  494548 139720  37624 S  0.3 18.5  45:38.81 JobWorker
764 root      21   1  494548 139720  37624 S  0.0 18.5   0:01.48 Announce
765 root      20   0  494548 139720  37624 S  0.0 18.5   0:00.00 FDEventMoni+
785 root      20   0  494548 139720  37624 S  0.0 18.5 208:22.98 ActiveAE
786 root      19  -1  494548 139720  37624 S  0.0 18.5  68:17.47 AESink
787 root      19  -1  494548 139720  37624 S  0.0 18.5  64:10.15 VCHIQ compl+
788 root      19  -1  494548 139720  37624 S  0.0 18.5  10:46.59 HDispmanx N+
789 root      19  -1  494548 139720  37624 S  0.0 18.5   0:00.00 HTV Notify
790 root      19  -1  494548 139720  37624 S  0.0 18.5   0:00.00 HCEC Notify
791 root      19  -1  494548 139720  37624 S  0.0 18.5  11:42.28 AESink
792 root      19  -1  494548 139720  37624 S  0.0 18.5  18:12.24 ILCS_HOST
793 root      20   0  494548 139720  37624 S  0.0 18.5   0:00.00 CRBPWorker
809 root      20   0  494548 139720  37624 S  0.0 18.5   0:29.23 kodi.bin
810 root      21   1  494548 139720  37624 S  0.0 18.5   1:35.88 PeripBusUSB+
812 root      21   1  494548 139720  37624 S  0.0 18.5   0:18.13 PeripBusAdd+

When I run "strace -p 813" it just say: strace: Process 813 attached and thats it.
(2016-10-27, 00:28)smp1 Wrote: This happened again. One of the CPU cores is stuck at 100%.

If you enable debug logging is anything spamming the log?
Code:
kill -SIGSEGV $(pidof kodi.bin)
and uploading the crashlog may indicate what the call stack of the busy thread is.
(2016-10-26, 16:29)bleep42 Wrote: If I then change deinterlace to either OFF or MMAL-Advanced(half) or MMAL-Bob(half) the file does play back fine.
If I use Auto or MMAL-Advanced or MMAL-Bob, the sound goes out of sync.
So it sounds from your comments above that this is to be expected with software decoding, in which case it might be worth Mike splashing out £2.40 (say $3) on a MPEG-2 licence because that same test file plays fine on my Pi1 with a licence.
Thanks Popcornmix. :-)
Regards, Kevin.

Hi Guys,

I've got the mpeg-2 licenses. When I say omx or mmal, I'm talking about having the hw renderers enabled in the player settings.

I just tried 'Sync playback to display' again, and I still see no difference, either with omx-hw or sw rendering.

I've got a recording with a glass-clink that occurs about 26 seconds into the recording, and I'm seeing the sound off by about 2 seconds at that point. (clink occurs ~2 seconds before you see the glasses touch)

I will try to extract the first minute of that recording later, so I can provide a link, since it's been such a good check (for me) to see how far of the audio is.

I haven't seen any settings for interlace, even though I've got my menus set to 'expert'. Where are those?

Thanks!
Mike
With 1025 and the MediaPortal TV client, it gets stuck on startup. TV EPG information is loaded, but then I get the spinning wheel on screen (using Titan skin) which never goes away.

No logs yet, sorry, but I thought I'd post this in case others see similar issues.

Mark
today I decided to give this another try and installed a fresh 1026.
Are PVR addons supposed to work out of the box or am I missing something?
because IPTV Simple client was unable to start, says "Can't load shared library"
the log itself: http://sprunge.us/aaQh
(2016-10-27, 01:14)mikeb8591 Wrote:
(2016-10-26, 16:29)bleep42 Wrote: If I then change deinterlace to either OFF or MMAL-Advanced(half) or MMAL-Bob(half) the file does play back fine.
If I use Auto or MMAL-Advanced or MMAL-Bob, the sound goes out of sync.
So it sounds from your comments above that this is to be expected with software decoding, in which case it might be worth Mike splashing out £2.40 (say $3) on a MPEG-2 licence because that same test file plays fine on my Pi1 with a licence.
Thanks Popcornmix. :-)
Regards, Kevin.

Hi Guys,

I've got the mpeg-2 licenses. When I say omx or mmal, I'm talking about having the hw renderers enabled in the player settings.

I just tried 'Sync playback to display' again, and I still see no difference, either with omx-hw or sw rendering.

I've got a recording with a glass-clink that occurs about 26 seconds into the recording, and I'm seeing the sound off by about 2 seconds at that point. (clink occurs ~2 seconds before you see the glasses touch)

I will try to extract the first minute of that recording later, so I can provide a link, since it's been such a good check (for me) to see how far of the audio is.

I haven't seen any settings for interlace, even though I've got my menus set to 'expert'. Where are those?

Thanks!
Mike

Hi Mike,
In that case sounds like your licence key isn't being recognised.
Press the letter o key on your keyboard while playing one of these videos an information display should appear, the top item "Video decoder" should have (HW) on the end of the line, if it says (SW) you need to investigate why your licence key isn't being used.
To change the deinterlacing method, wave your mouse around while watching one of these videos, at the right hand side of the display is the settings icon (a cog) move the mouse over this and a menu will pup up, with "video settings" as an option, select that and the top item in the list is the deinterlace settings.
I found all this out by doing searches.
Regards, Kevin.
cant install tvheadend on latest build

Code:
ERROR: Failed to unpack archive 'special://home/addons/packages/service.tvheadend42-8.0.105.zip' to '/storage/.kodi/temp/d5f5d079-69be-4fe6-ae4f-ec99c8b2dff1'

is this because of usb boot or ist this a general problem?
(2016-10-27, 12:24)mezo Wrote: cant install tvheadend on latest build

Code:
ERROR: Failed to unpack archive 'special://home/addons/packages/service.tvheadend42-8.0.105.zip' to '/storage/.kodi/temp/d5f5d079-69be-4fe6-ae4f-ec99c8b2dff1'

is this because of usb boot or ist this a general problem?

It's a general (and known) problem, seems to be due to PR10711 added in #1023.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
This is about CEC on an old-ish LG TV.

I am experiencing intermittent CEC drops and other weird/changed behaviours (for example Kodi doesn't wake up when I turn the TV back ON from sand-by, I need to press a remote button for CEC to go through an apparent complete reconfig).

How do I provide the necessary logs to help sort it out?

Is this sufficient?
1.2.2 advancedsettings.xml for input devices

Thanks!

Nico
(2016-10-27, 13:39)camelreef Wrote: This is about CEC on an old-ish LG TV.

Last night's build included a major update to libcec. Is your problem changed with last night's build?
For logs, enable debug logging and CEC in the component specific logging. Reboot and reproduce the problem.
Post an issue here: https://github.com/Pulse-Eight/libcec/issues
(make sure you are using latest build).
(2016-10-27, 13:45)popcornmix Wrote:
(2016-10-27, 13:39)camelreef Wrote: This is about CEC on an old-ish LG TV.

Last night's build included a major update to libcec. Is your problem changed with last night's build?
For logs, enable debug logging and CEC in the component specific logging. Reboot and reproduce the problem.
Post an issue here: https://github.com/Pulse-Eight/libcec/issues
(make sure you are using latest build).

I was very hopeful when I read last night's changelog! But no change... That's what triggered my post. Better do it now than too late!

I'm always on the latest build!

I'll report in the right place, then.

Thanks!

Nico
(2016-10-27, 13:45)popcornmix Wrote:
(2016-10-27, 13:39)camelreef Wrote: This is about CEC on an old-ish LG TV.

For logs, enable debug logging and CEC in the component specific logging. Reboot and reproduce the problem.
Post an issue here: https://github.com/Pulse-Eight/libcec/issues
(make sure you are using latest build).

The issue has been reported here:

LG TV - Stand-by to ON not enough to wake Kodi up

Nico
  •   
  • 1
  • 179
  • 180
  • 181(current)
  • 182
  • 183
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319