Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-11-24, 15:40)hanspeter Wrote: Ran for >12hrs, no errors. I also could not find any way to provoke the crash... Do you have any ideas what the root-cause could be? If you suspect a (hardware) memory problem, would overclocking the memory to an unstable value maybe provoke it...? Or what about running memtester while kodi is running?

I hardware issue seemed possible when only you had a problem. As gendo also saw a similar crash, then a hardware issue is less likely.
Most likely the arm is trying to access memory in the top 16M of address space. This should be used by the GPU but there may be a situation I'm missing,
If I could reproduce this then diagnosing it would be easier.

As total_mem=1008 works and total_mem=1024 (the default if unspecified) doesn't work, it may be interesting to see what the threshold is.
E.g. Try total_mem=1016. If that seems good try total_mem=1020, and if not try total_mem=1012.

If you get a crash where ssh still works, then dmesg output may be useful.
After a reboot then .kodi/temp/kodi.old.log may be useful if it shows what was going on from just before the crash.
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by popcornmix - 2016-11-24, 17:59


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319