Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-11-27, 14:03)herrmeier01 Wrote: On #1126 with a fresh install I'm not able to install VDR addon. There is a compatibility issue.
An upgraded system which has VDR installed doesn't have this problem when updating the VDR addon

The error when installing service.multimedia.vdr-addon is this:
Code:
22:05:16.702 T:1489195936   DEBUG: CAddonInstallJob[pvr.vdr.vnsi]: requires xbmc.pvr version 5.2.0 which is not available
22:05:16.703 T:1489195936   ERROR: CAddonInstallJob[service.multimedia.vdr-addon]: The dependency on xbmc.pvr version 5.2.0 could not be satisfied.

There's an out of date version of pvr.vdr.vnsi (version 2.6.7) available online in the LE repo (created for Kodi 17 beta 5) that has a dependency on xbmc.pvr 5.2.0 (which isn't available in the latest build).

The version of pvr.vdr.vnsi I include in the latest build (v999.2.6.9) is disabled by default, but has the correct dependency on xbmc.pvr 5.2.1 (this is provided by the latest build).

While the local pvr.vdr.vnsi add-on is disabled the installation of service.multimedia.vdr-addon will fail because the online pvr.vdr.vnsi add-on is incompatible.

Maybe this behaviour is correct - I really don't know. After all, the installed local add-on is disabled so perhaps it makes sense for Kodi to "prefer" the alternative online add-on instead. Or maybe it doesn't. I'm undecided.

Anyway, the solution is to enable the local and already installed pvr.vdr.vnsi client add-on (version 999.2.6.9), and THEN install service.multimedia.vdr-addon from zip. This way the dependencies will be correctly satisfied during installation of service.multimedia.vdr-addon.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average


Messages In This Thread
RPi2: no DV-codec? - by bubi - 2016-07-10, 10:30
DV-video not working - by bubi - 2016-07-15, 19:48
RE: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0) - by Milhouse - 2016-11-28, 00:44


Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319