•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-04-23, 17:33)Milhouse Wrote:
(2016-04-23, 16:42)M4tt0 Wrote: Have several issues:
* Deactivating English keyboard layout and activate the German one has not effect.
* Copied my sources.xml and advancedsettings.xml files linking to my MySQL server, the database is imported but all covers / pictures are missing.
* Several messages that add-ons (dependencies) can not be found / met (e.g. Amazon Prime Instant Add-on).
I reckon(!) that this is simply due to the absence of the 8.0 LibreElec-Addon repo. Is there some workaround for that?

Some context would help, is this an upgrade or fresh install? If upgrade, from what?

Covers/pictures missing - no idea without a debug log. Check your artwork metadata, texturecache.py is included in these builds.

Dependencies - probably disabled add-ons. Welcome to Kodi 17.

Apologies, Milhouse! Here the context:

I have been waiting for your LE8.0 test builds as my "entry" into Krypton and created a test system on an external USB HDD for that, which is running off an i5 HSW NUC. Because I could not find img.gz 8.0 builds I used the LE7.0B2 for a clean install (wanted to make sure the partition sizes are big enough). However, I only configured the network in this version before manually upgrading to 8.0 with the first tar file you have published in this thread. At that stage that was the "cleanest" LE8.0 state I could achieve. Everything else, i.e. configuration of regions, time zones, video and audio settings, etc. were already conducted in LE8.0. Wanted to test the new inputstream goodies, realized that inputstream was already installed and activitied in the build, curled widevine and installed the amazon instant addon from the zip file linked in your post #1 (liberty version).

The sources.xml and advancedsettings.xml files I have been referencing above stem from my OE (15.2 EGL) production system, which I have been and am still running since several months off an internal SSD in my NUC (I have been skipping Jarvis for sub-optimal video quality on Intel). Standard MySQL integration and sources on my NAS, nothing fancy whatsoever. I copied those files to the LE userdata folder and rebooted the system. It took some time for LE to restart (wasn't surprised as I assume some new DB versions were created on the MySQL server). Afterwards, my movies and series appeared in LE (standard Estuary skin), but - as indicated - without covers.

Unfortunately my family is occupying the 15.2 production system right now. Will be trying to get you some debug logs later tonight. If you need any other information beyond that, please just let me know...
With Build #0423, I can't activate TVHeadend Client:

Quote:23:46:24 57.193729 T:139713293932672 ERROR: PVR - Add-on 'Tvheadend HTSP Client' is using an incompatible API version. XBMC minimum API version = '5.2.0', add-on API version '5.1.1'
23:46:24 57.193794 T:139713293932672 ERROR: UpdateAddons - failed to create add-on Tvheadend HTSP Client, status = 6

€: Github-Version is already for 5.2.0:
https://github.com/kodi-pvr/pvr.hts
(2016-04-23, 23:49)dirtydesaster Wrote: €: Github-Version is already for 5.2.0:
https://github.com/kodi-pvr/pvr.hts

Yes, that change merged after build #0423, and will be in the next build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hate to bring this issue back up but I'm still having it =\

2309403 (post)

I've since followed the crowd and moved to Milhouse/LE builds

currently on #0420 (#0423) had issue with myth tv add-on so had to move back to #0420.

I've realized if I move my HDMI straight to the TV the issue goes away. I've also tested it in another room with a Marantz receiver and there is no issue either.

So this seems to be based around my Denon receiver. My question and confusion is why does it start when I move to Kodi 17.0? 15.X there were no issues and if I go back the issue immediately goes away. However logs are not showing anything (per my previous post)

The guys at Intel (free desktop) are asking me to use the 15.X kernel with the newer software. I'm not sure how to do that is it as easy as swapping the kernel file under the /flash folder?

Would love to get this pesky problem solved.

Thanks everyone!
ESXi 5.5 | VMs : [unRAID] [PLEX] [SAB] [CP] [Sonarr] [uTorrent] [MySQL] [Apache] [Mythbuntu]
@SmallwoodDR82 you have a pm about denon black screen issue
Until Leopold can update his addon (if he is planning to?) I made a modified addon for devupdate because I didnt want to hack up my existing addons.

Note: Only one source is enabled/visible, and that is Milhouse LibreELEC dev builds

https://github.com/miigotu/script.libree...structions
(2016-04-21, 20:12)mule1 Wrote:
(2016-04-20, 15:51)mule1 Wrote: I just switched from fritsch build to milhouse build and after some skips in .ts-files I'm getting extreme playback hiccups (distortion, frame repeating, pausing etc.). This behaviour is reproducable every time I do some skipping. The kodi log is being flooded with "VAAPI" warnings/erros. I tried the latest milhouse build and many different older ones (even back to #0214). All l tried builds show the same behaviour on my Intel NUC 34010. Only switching back to a fritsch build (older or newer ones) solves this issue.

Kodi log: http://pastebin.com/Y9PHC3kR
With the latest build #0420 .ts-files are unwatchable because the hiccups begin right after the start of the playback. With builds #0419 and before the hiccups first start after some skipping as described above.
Please tell me how i can help to find the reason for this issue.
Updated to this build. MythTV addon wont enable now. Log results in the following:

09:02:49 1536.527100 T:140569881856064 ERROR: PVR - Add-on 'MythTV PVR Client' is using an incompatible API version. XBMC minimum API version = '5.2.0', add-on API version '5.1.1'
09:02:49 1536.527100 T:140569881856064 ERROR: UpdateAddons - failed to create add-on MythTV PVR Client, status = 6

Thoughts?
(2016-04-24, 16:04)FreakinSyco Wrote: Updated to this build. MythTV addon wont enable now. Log results in the following:

09:02:49 1536.527100 T:140569881856064 ERROR: PVR - Add-on 'MythTV PVR Client' is using an incompatible API version. XBMC minimum API version = '5.2.0', add-on API version '5.1.1'
09:02:49 1536.527100 T:140569881856064 ERROR: UpdateAddons - failed to create add-on MythTV PVR Client, status = 6

Thoughts?

If you read the release post it says that most PVR clients are broken with the latest due to the PVR bump. Most likely the next release will have the updated clients.
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
(2016-04-24, 10:07)Roby77 Wrote: @SmallwoodDR82 you have a pm about denon black screen issue

You got a easy solution?

Pls share it with all denon users Smile
(2016-04-24, 16:05)pyrodex Wrote:
(2016-04-24, 16:04)FreakinSyco Wrote: Updated to this build. MythTV addon wont enable now. Log results in the following:

09:02:49 1536.527100 T:140569881856064 ERROR: PVR - Add-on 'MythTV PVR Client' is using an incompatible API version. XBMC minimum API version = '5.2.0', add-on API version '5.1.1'
09:02:49 1536.527100 T:140569881856064 ERROR: UpdateAddons - failed to create add-on MythTV PVR Client, status = 6

Thoughts?

If you read the release post it says that most PVR clients are broken with the latest due to the PVR bump. Most likely the next release will have the updated clients.

You're right. Looks MythTV just updated their addon. I'll just patiently wait for the next release. Thanks!
(2016-04-24, 16:21)meowmoo Wrote:
(2016-04-24, 10:07)Roby77 Wrote: @SmallwoodDR82 you have a pm about denon black screen issue

You got a easy solution?

Pls share it with all denon users Smile

Which problem do you have ? Did you try edid solution ?

Please read


https://forum.libreelec.tv/thread-155.html


No but now i don't feel alone anymore Big Grin


My solution with chromebox was forcing 60hz for gui and using edid at boot for hd audio but no more valid with beebox

I'm now testing several solution and i will report good or bad news
(2016-04-23, 16:42)M4tt0 Wrote: * Deactivating English keyboard layout and activate the German one has not effect.

Can you test this with build #0417 and confirm if you have the same behaviour. Then test build #0418, and confirm what behaviour you have.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0424: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0-rc4 #1 SMP Sun Apr 24 21:26:16 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160424212453-#0424-gf232504 [Build #0424]

Based on tip of LibreELEC.tv master (f2325048, changelog) and tip of XBMC master (96524c25, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. PVR API 5.2.0 bumps
  3. Ensure os.* addons are always enabled
Build Details:
  1. LibreELEC.tv:
    • RPi: fix 4.4.7 kernel config (PR:221, 1 commit, 2 files changed)
  2. XBMC:
    • [pvr] update xbmc.pvr gor api 5.2.0 (PR:9670, 1 commit, 1 file changed)
    • ADDON: revert announcement interface, not thread safe (PR:9654, 1 commit, 3 files changed)
    • [PVR] CPVRClients::GetTimers: Improve error handling. (PR:9655, 1 commit, 4 files changed)
    • fix observers (PR:9669, 1 commit, 2 files changed)
    • [PVR] fix crash returning wrong type for CEpgPtr (PR:9668, 1 commit, 2 files changed)
    • [IMX/RefClock] refactor refclock IMX core engine. (PR:9637, 1 commit, 7 files changed)
    • [addon] add doxygen documentation for skin controls (PR:9560, 1 commit, 33 files changed)
    • fix build-tools deprecation (PR:8818, 1 commit, 1 file changed)
    • FFmpegImage: Fix memory leak (PR:9661, 1 commit, 1 file changed)
    • PVR code cleanup (PR:9658, 9 commits, 14 files changed)
    • native/TexturePacker: fix compilation with gcc 4.6 (PR:9378, 1 commit, 1 file changed)
    • [peripherals] fix deadlock (PR:9510, 5 commits, 4 files changed)
    • [addons] database improvements (PR:9642, 4 commits, 3 files changed)
  3. inputstream.mpd:
  4. pvr.demo:
    • adapt to PVR API 5.2.0 (PR:35, 1 commit, 2 files changed)
  5. pvr.dvblink:
    • adapt to PVR API 5.2.0 (PR:47, 1 commit, 3 files changed)
  6. pvr.dvbviewer:
    • adapt to PVR API 5.2.0 (PR:34, 1 commit, 5 files changed)
  7. pvr.filmon:
    • adapt to PVR API 5.2.0 (PR:49, 1 commit, 3 files changed)
  8. pvr.hts:
    • adapt to PVR API 5.2.0 (PR:219, 1 commit, 3 files changed)
    • Fix async state handling. (PR:217, 2 commits, 3 files changed)
  9. pvr.iptvsimple:
    • adapt to PVR API 5.2.0 (PR:75, 1 commit, 3 files changed)
  10. pvr.mediaportal.tvserver:
    • adapt to PVR API 5.2.0 (PR:40, 1 commit, 3 files changed)
  11. pvr.mythtv:
    • adapt to PVR API 5.2.0 (PR:64, 1 commit, 3 files changed)
  12. pvr.nextpvr:
    • adapt to PVR API 5.2.0 (PR:45, 1 commit, 3 files changed)
  13. pvr.njoy:
    • adapt to PVR API 5.2.0 (PR:28, 1 commit, 3 files changed)
  14. pvr.stalker:
    • adapt to PVR API 5.2.0 (PR:57, 1 commit, 3 files changed)
  15. pvr.vbox:
    • adapt to PVR API 5.2.0 (PR:126, 1 commit, 3 files changed)
  16. pvr.vdr.vnsi:
    • changes to settings (PR:79, 3 commits, 6 files changed)
  17. pvr.vuplus:
    • adapt to PVR API 5.2.0 (PR:43, 1 commit, 3 files changed)
  18. pvr.wmc:
    • adapt to PVR API 5.2.0 (PR:43, 1 commit, 4 files changed)
  19. xbmc/master (FernetMenta):
    • Commits no longer in build:
      • ADDON: revert announcement interface, not thread safe (ad95a289)
  20. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-04-24, 18:42)Roby77 Wrote:
(2016-04-24, 16:21)meowmoo Wrote:
(2016-04-24, 10:07)Roby77 Wrote: @SmallwoodDR82 you have a pm about denon black screen issue

You got a easy solution?

Pls share it with all denon users Smile

Which problem do you have ? Did you try edid solution ?

Please read


https://forum.libreelec.tv/thread-155.html


No but now i don't feel alone anymore Big Grin


My solution with chromebox was forcing 60hz for gui and using edid at boot for hd audio but no more valid with beebox

I'm now testing several solution and i will report good or bad news

Not alone for sure Smile Whats funny is I'm on a Plasma and Denon also. Maybe something there?

Here is a quick Youtube link : https://youtu.be/e3GQac0v57E

Very short video but it gets the point across. Just sitting at main menu my screen will randomly flash. Does it 1 to 5 times a minute, whether I'm playing video or not.

Side note - I'm on #0424 and MythTV is fixed Smile but looks like they did some LIRC remapping. My context button doesnt work anymore Sad

Thanks for all your hard work Milhouse/Kodi Team!
ESXi 5.5 | VMs : [unRAID] [PLEX] [SAB] [CP] [Sonarr] [uTorrent] [MySQL] [Apache] [Mythbuntu]
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111